LINUX.ORG.RU

Не могу установить ядро линукса

 , ,


0

1

Здравствуйте, мне нужно установить более раннюю версию ядра. Скачиваю с этого сайта https://kernel.ubuntu.com/~kernel-ppa/mainline/v4.20.17/ ядро версии 4.20.17.

Потом пишу в терминале sudo dpkg -i *.deb, в итоге получаю данную ошибку:

dpkg: зависимости пакетов не позволяют настроить пакет linux-headers-4.20.17-042017-generic: linux-headers-4.20.17-042017-generic зависит от linux-headers-4.20.17-042017, однако: Пакет linux-headers-4.20.17-042017 не установлен.

dpkg: ошибка при обработке пакета linux-headers-4.20.17-042017-generic (–install): проблемы зависимостей — оставляем не настроенным dpkg: зависимости пакетов не позволяют настроить пакет linux-image-unsigned-4.20.17-042017-generic: linux-image-unsigned-4.20.17-042017-generic зависит от linux-modules-4.20.17-042017-generic, однако: Пакет linux-modules-4.20.17-042017-generic не установлен.

dpkg: ошибка при обработке пакета linux-image-unsigned-4.20.17-042017-generic (–install): проблемы зависимостей — оставляем не настроенным При обработке следующих пакетов произошли ошибки: linux-headers-4.20.17-042017-generic linux-image-unsigned-4.20.17-042017-generic

Впервые занимаюсь таким, вообще не понимаю ничего.

Учти, что при даунгрейде (или «ручном» апгрейде) ядра (особенно если ты не с 4.20.x на 4.20.y переходишь, а более серьезное измение) может внезапно отвалиться графика

annulen ★★★★★ ()

однако: Пакет linux-headers-4.20.17-042017 не установлен.
однако: Пакет linux-modules-4.20.17-042017-generic не установлен.

дык, установи указанные пакеты, пакет ядра требует их наличие в системе для своей установке. по идее они должны быть там же.

pfg ★★★ ()

На Ubuntu надо внести изменения в файлик, которые находится непомню где. Извини, но вот вылетело из памяти. Но знаю точно, что пока его не поправишь, хер что соберешь.

LGH ()