LINUX.ORG.RU

ошибки во время обновления в ubuntu


0

0

Всем привет)) сегодня выскочил менеджер обновлений в юбунту, после обновления выдал ошибки: Настраивается пакет linux-image-2.6.32-24-generic (2.6.32-24.41) ... Running depmod. update-initramfs: Generating /boot/initrd.img-2.6.32-24-generic Not updating initrd symbolic links since we are being updated/reinstalled (2.6.32-24.39 was configured last, according to dpkg) Not updating image symbolic links since we are being updated/reinstalled (2.6.32-24.39 was configured last, according to dpkg) Running postinst hook script /usr/sbin/update-grub. Generating grub.cfg ... Found linux image: /boot/vmlinuz-2.6.32-24-generic Found initrd image: /boot/initrd.img-2.6.32-24-generic Found linux image: /boot/vmlinuz-2.6.32-23-generic Found initrd image: /boot/initrd.img-2.6.32-23-generic Found linux image: /boot/vmlinuz-2.6.32-21-generic Found initrd image: /boot/initrd.img-2.6.32-21-generic Found memtest86+ image: /boot/memtest86+.bin done Examining /etc/kernel/postinst.d. run-parts: executing /etc/kernel/postinst.d/dkms 2.6.32-24-generic /boot/vmlinuz-2.6.32-24-generic run-parts: executing /etc/kernel/postinst.d/nvidia-common 2.6.32-24-generic /boot/vmlinuz-2.6.32-24-generic run-parts: /etc/kernel/postinst.d/nvidia-common exited with return code 10 Failed to process /etc/kernel/postinst.d at /var/lib/dpkg/info/linux-image-2.6.32-24-generic.postinst line 1003. dpkg: не удалось обработать параметр linux-image-2.6.32-24-generic (--configure): подпроцесс установлен сценарий post-installation возвратил код ошибки 2 Настраивается пакет linux-headers-2.6.32-24-generic (2.6.32-24.41) ... Examining /etc/kernel/header_postinst.d. run-parts: executing /etc/kernel/header_postinst.d/dkms 2.6.32-24-generic /boot/vmlinuz-2.6.32-24-generic run-parts: executing /etc/kernel/header_postinst.d/nvidia-common 2.6.32-24-generic /boot/vmlinuz-2.6.32-24-generic run-parts: /etc/kernel/header_postinst.d/nvidia-common exited with return code 10 Failed to process /etc/kernel/header_postinst.d at /var/lib/dpkg/info/linux-headers-2.6.32-24-generic.postinst line 110. dpkg: не удалось обработать параметр linux-headers-2.6.32-24-generic (--configure): подпроцесс установлен сценарий post-installation возвратил код ошибки 2 При обработке следующих пакетов произошли ошибки: linux-image-2.6.32-24-generic linux-headers-2.6.32-24-generic E: Sub-process /usr/bin/dpkg returned an error code (1

как это исправить? В линах новичок, пробовал гуглить, но решения не нашел(((

В синаптик зайди - исправь. Возможно придётся что доставить/удалить. Репы трогал?

amorpher ★★★★★ ()
Ответ на: комментарий от amorpher

репы не трогал, запустил синаптик, смотрю логи сегодня было Commit Log for Fri Aug 20 09:59:33 2010 Эти пакеты обновлены: google-chrome-stable (5.0.375.126-r53802) to 5.0.375.127-r55887 linux-headers-2.6.32-24 (2.6.32-24.39) to 2.6.32-24.41 linux-headers-2.6.32-24-generic (2.6.32-24.39) to 2.6.32-24.41 linux-image-2.6.32-24-generic (2.6.32-24.39) to 2.6.32-24.41 linux-libc-dev (2.6.32-24.39) to 2.6.32-24.41

Возможно придётся что доставить/удалить.

что именно? синаптик молчит и не чего не предлагает.

musson4 ()

решили проблему. Проблема была в пакете nvidia-common. 1. снес дрова видяхи nvidia. 2. снес пакет nvidia-common 3. обновил систему 4. поставил nvidia-common 5. поставил дрова видяхи

uname -a Linux linux1 2.6.32-24-generic #41-Ubuntu SMP Thu Aug 19 01:12:52 UTC 2010 i686 GNU/Linux

все отлично, ошибок при обновлении нет.

PS Василий спасибо)))))

musson4 ()
Вы не можете добавлять комментарии в эту тему. Тема перемещена в архив.