LINUX.ORG.RU

Не устанавливаются программы через apt-get

 


0

1

Ставлю любой пакет через пакетный менеджер, выдает вот это:

root@localhost:/home/reedych# apt-get install libboost-all-dev
Чтение списков пакетов… Готово
Построение дерева зависимостей       
Чтение информации о состоянии… Готово
libboost-all-dev is already the newest version (1.58.0.1).
Следующий пакет устанавливался автоматически и больше не требуется:
  libxfce4util6
Для его удаления используйте «apt autoremove».
обновлено 0, установлено 0 новых пакетов, для удаления отмечено 0 пакетов, и 0 пакетов не обновлено.
не установлено до конца или удалено 8 пакетов.
После данной операции, объём занятого дискового пространства возрастёт на 0 B.
Хотите продолжить? [Д/н] 
Настраивается пакет imagemagick:i386 (8:6.8.9.9-6) …
update-alternatives: ошибка: альтернативный путь /usr/bin/compare-im6 не существует
dpkg: ошибка при обработке пакета imagemagick:i386 (--configure):
 подпроцесс установлен сценарий post-installation возвратил код ошибки 2
dpkg: зависимости пакетов не позволяют настроить пакет cups-filters:
 cups-filters зависит от imagemagick (>= 6.4~), однако:
  Пакет imagemagick:i386 пока не настроен.

dpkg: ошибка при обработке пакета cups-filters (--configure):
 проблемы зависимостей — оставляем не настроенным
dpkg: зависимости пакетов не позволяют настроить пакет printer-driver-foo2zjs:
 printer-driver-foo2zjs зависит от foomatic-filters, однако:
  Пакет foomatic-filters не установлен.
  Пакет cups-filters, предоставляющий foomatic-filters, пока не настроен.

dpkg: ошибка при обработке пакета printer-driver-foo2zjs (--configure):
 проблемы зависимостей — оставляем не настроенным
dpkg: зависимости пакетов не позволяют настроить пакет foomatic-db-engine:
 foomatic-db-engine зависит от cups-filters (>= 1.0.42) | foomatic-filters (>= 4.0), однако:
  Пакет cups-filters пока не настроен.
  Пакет foomatic-filters не установлен.
  Версия foomatic-filters в системе, предоставляемая cups-filters:amd64 — <нет>.

dpkg: ошибка при обработке пакета foomatic-db-engine (--configure):
 проблемы зависимостей — оставляем не настроенным
dpkg: зависимости пакетов не позволяют настроить пакет cups:
 cups зависит от cups-filters (>= 1.0.24-3~), однако:
  Пакет cups-filters пока не настроен.

dpkg: ошибка при обработке пакета cups (--configure):
 проблемы зависимостей — оставляем не настроенным
dpkg: зависимости пакетов не позволяют настроить пакет printer-driver-hpcups:
 printer-driver-hpcups зависит от cups-filters (>= 1.0.36) | ghostscript-cups, однако:
  Пакет cups-filters пока не настроен.
  Пакет ghostscript-cups не установлен.
  Пакет cups-filters, предоставляющий ghostscript-cups, пока не настроен.
 printer-driver-hpcups зависит от cups (>= 1.4.0) | cupsddk, однако:
  Пакет cups пока не настроен.
  Пакет cupsddk не установлен.
 printer-driver-hpcups зависит от cups, однако:
  Пакет cups пока не настроен.

dpkg: ошибка при обработке пакета printer-driver-hpcups (--configure):
 проблемы зависимостей — оставляем не настроенным
dpkg: зависимости пакетов не позволяют настроить пакет hplip:
 hplip зависит от printer-driver-hpcups (= 3.14.6-1+b3), однако:
  Пакет printer-driver-hpcups пока не настроен.
 hplip зависит от cups (>= 1.1.20), однако:
  Пакет cups пока не настроен.

dpkg: ошибка при обработке пакета hplip (--configure):
 проблемы зависимостей — оставляем не настроенным
dpkg: зависимости пакетов не позволяют настроить пакет task-print-server:
 task-print-server зависит от cups, однако:
  Пакет cups пока не настроен.

dpkg: ошибка при обработке пакета task-print-server (--configure):
 проблемы зависимостей — оставляем не настроенным
При обработке следующих пакетов произошли ошибки:
 imagemagick:i386
 cups-filters
 printer-driver-foo2zjs
 foomatic-db-engine
 cups
 printer-driver-hpcups
 hplip
 task-print-server
E: Sub-process /usr/bin/dpkg returned an error code (1)
root@localhost:/home/reedych# 
Дебианом пользоваться начал недавно, в чем проблема? Я просто перешел со stable на testing...

Я просто перешел со stable на testing...

А действия по апгрейду согласно букваря все выполнили?

Belen ★★ ()

Лучше aptitude, как альтернативы apt-get, я не встречал. Если не может справиться первая, всегда можно попробовать решить проблему второй.

rmu ★★ ()
Вы не можете добавлять комментарии в эту тему. Тема перемещена в архив.