LINUX.ORG.RU

Пакеты «застрявшие в пространстве». (E: Sub-process /usr/bin/dpkg returned an error code (1))

 , , , ,


0

2

Проблема с пакетами которые даже при удалении остаются. (их ошибка уж точно) Так же не позволяют ничего устанавливать, да и вообще хоть как-то действовать с apt-get, так же пробовал aptitude (так же и им пытался их выковырять). Читал разные решения этой проблемы, но к сожалению ничего не помогло, а может просто упустил что, в общем надеюсь на вашу помощь.

Linux com512 3.16.0-4-amd64 #1 SMP Debian 3.16.7-ckt20-1+deb8u4 (2016-02-29) x86_64 GNU/Linux

root@com512:~# apt-get -f install 
Чтение списков пакетов… Готово
Построение дерева зависимостей       
Чтение информации о состоянии… Готово
Исправление зависимостей… Готово
обновлено 0, установлено 0 новых пакетов, для удаления отмечено 0 пакетов, и 17 пакетов не обновлено.
не установлено до конца или удалено 7 пакетов.
Необходимо скачать 0 B/266 kB архивов.
После данной операции, объём занятого дискового пространства возрастёт на 0 B.
debconf: DbDriver "config": /var/cache/debconf/config.dat is locked by another process: Ресурс временно недоступен
Настраивается пакет dictionaries-common (1.23.17) …
debconf: DbDriver "config": /var/cache/debconf/config.dat is locked by another process: Ресурс временно недоступен
dpkg: ошибка при обработке пакета dictionaries-common (--configure):
 подпроцесс установлен сценарий post-installation возвратил код ошибки 1
dpkg: зависимости пакетов не позволяют настроить пакет aspell:
 aspell зависит от dictionaries-common (>> 0.40), однако:
  Пакет dictionaries-common пока не настроен.

dpkg: ошибка при обработке пакета aspell (--configure):
 проблемы зависимостей — оставляем не настроенным
dpkg: ошибка при обработке пакета aspell-en (--configure):
 пакет aspell-en не готов к настройке
 настройка невозможна (текущее состояние: «half-installed»)
dpkg: зависимости пакетов не позволяют настроить пакет libenchant1c2a:amd64:
 libenchant1c2a:amd64 зависит от aspell-en | myspell-dictionary | aspell-dictionary | ispell-dictionary | hunspell-dictionary, однако:
  Пакет aspell-en не установлен.
  Пакет myspell-dictionary не установлен.
  Пакет myspell-ca, предоставляющий myspell-dictionary, не установлен.
  Пакет aspell-dictionary не установлен.
  Пакет aspell-en, предоставляющий aspell-dictionary, не установлен.
  Пакет ispell-dictionary не установлен.
  Пакет hunspell-dictionary не установлен.

dpkg: ошибка при обработке пакета libenchant1c2a:amd64 (--configure):
 проблемы зависимостей — оставляем не настроенным
dpkg: зависимости пакетов не позволяют настроить пакет enchant:
 enchant зависит от libenchant1c2a (>= 1.6.0), однако:
  Пакет libenchant1c2a:amd64 пока не настроен.

dpkg: ошибка при обработке пакета enchant (--configure):
 проблемы зависимостей — оставляем не настроенным
dpkg: зависимости пакетов не позволяют настроить пакет libsexy2:
 libsexy2 зависит от libenchant1c2a, однако:
  Пакет libenchant1c2a:amd64 пока не настроен.

dpkg: ошибка при обработке пакета libsexy2 (--configure):
 проблемы зависимостей — оставляем не настроенным
dpkg: зависимости пакетов не позволяют настроить пакет xchat:
 xchat зависит от libsexy2 (>= 0.1.8), однако:
  Пакет libsexy2 пока не настроен.

dpkg: ошибка при обработке пакета xchat (--configure):
 проблемы зависимостей — оставляем не настроенным
При обработке следующих пакетов произошли ошибки:
 dictionaries-common
 aspell
 aspell-en
 libenchant1c2a:amd64
 enchant
 libsexy2
 xchat
E: Sub-process /usr/bin/dpkg returned an error code (1)
root@com512:~# 

Ещё такая ошибка в синаптике. Но я вроде близок к разгадке.

E: aspell-en: подпроцесс установлен сценарий post-removal возвратил код ошибки 2

anont34 ()

В общем, наткнулся на статейку http://notessysadmin.com/kosyak-dpkg Но по своей глупости командой «sudo rm /var/cache/debconf/*.dat» почистил все, что можно было. (Если что, вместо звездочки вставлять имена не обновляемых пакетов, вроде как). После команда «sudo apt-get -f install» работала как нужно, хотя и пишет, что есть 17 пакетов не обновлено. (при том, что я пытался обновить тот же проблемный пакет xchat и мне выдало, что установлена самая новая версия).

Надеюсь мой опыт пригодиться кому-то в столь странной и (вроде как) редкой ситуации.

anont34 ()
Вы не можете добавлять комментарии в эту тему. Тема перемещена в архив.