LINUX.ORG.RU

dpkg ошибки при попытках установить что-либо

 , ,


0

1

Решила установить php. Сперва sudo apt-get install php5.6

Мне в ответ пришло вот это:

dpkg: ошибка при обработке пакета libapache2-mod-php5.6 (--configure):
 installed libapache2-mod-php5.6 package post-installation script subprocess returned error exit status 1
dpkg: зависимости пакетов не позволяют настроить пакет php5.6:
 php5.6 зависит от libapache2-mod-php5.6 | php5.6-fpm | php5.6-cgi, однако:
  Пакет libapache2-mod-php5.6 пока не настроен.
  Пакет php5.6-fpm не установлен.
  Пакет php5.6-cgi не установлен.

dpkg: ошибка при обработке пакета php5.6 (--configure):
 проблемы зависимостей — оставляем не настроенным
Отчёты apport не записаны, так как сообщение об ошибке указывает на повторную ошибку от предыдущего отказа.
                                                                                                           При обработке следующих пакетов произошли ошибки:
 libapache2-mod-php5.6
 php5.6
E: Sub-process /usr/bin/dpkg returned an error code (1)

Перед этим был долгий список того, что устанавливается. Потом выполнила sudo apt-get install php5.6-mbstring php5.6-mcrypt php5.6-mysql php5.6-xml . В конце списка были те же ошибки от dpkg. Команда sudo a2enmod php5.6 возвращает

Considering dependency mpm_prefork for php5.6:
Considering conflict mpm_event for mpm_prefork:
Considering conflict mpm_worker for mpm_prefork:
ERROR: Module mpm_prefork not properly enabled: /etc/apache2/mods-enabled/mpm_prefork.load is a real file, not touching it
ERROR: Could not enable dependency mpm_prefork for php5.6, aborting

 

/etc/apache2/mods-enabled/mpm_prefork.load is a real file

И что тут тебе не понятно? У тебя там вместо симлинка копия файлы.

Radjah ★★★★★ ()
Вы не можете добавлять комментарии в эту тему. Тема перемещена в архив.