LINUX.ORG.RU

Debian Stable, sources.list — как записать бакпорты?

 , , , ,


0

2

Здравствуйте. В сабже немного неправильно написано…

Так вот, в /etc/apt/sources.list можно написать как buster main ..., так и stable main .... И со stable-updates такая штука тоже проходит. Но stable-backports система не понимает:

W: Skipping acquire of configured file 'stable-backports/...' as repository 'http://deb.debian.org/debian stable InRelease' doesn't have the component 'stable-backports' (component misspelt in sources.list?)

Если я запишу стабильную версию как stable, то когда Bullseye станет Stable, я на него незаметно обновлюсь. А если написать buster, то я так и останусь на Buster, который станет Oldstable. Нет, я могу заменить весь buster на bullseye, когда он выйдет, но я об этом могу и не узнать, думая, что он – еще тестинг.

Вопрос. Как записать бакпорты по аналогии с stable-updates?

Простите за простыню и тупняк, если что-то непонятно, скажите, пожалуйста.

Ответ на: комментарий от Vsevolod-linuxoid

А если написать buster, то я так и останусь на Buster, который станет Oldstable. Нет, я могу заменить весь buster на bullseye, когда он выйдет, но я об этом могу и не узнать, думая, что он – еще тестинг.

tongubin ()
Ответ на: комментарий от Vsevolod-linuxoid

Но stable-backports система не понимает:

W: Skipping acquire of configured file 'stable-backports/...' as repository 'http://deb.debian.org/debian stable InRelease' doesn't have the component 'stable-backports' (component misspelt in sources.list?)

tongubin ()
Последнее исправление: tongubin (всего исправлений: 1)

У меня всё работает, только выдаёт

W: Противоречивый выпуск: http://deb.debian.org/debian stable-backports InRelease (ожидался stable-backports, но получен buster-backports)

cat /etc/apt/sources.list.d/backports.list 
deb http://deb.debian.org/debian stable-backports main contrib non-free
gremlin_the_red ★★★★ ()
Ответ на: комментарий от gremlin_the_red

У меня тоже deb.debian.org. сорцолист потом дам, пишу с телефона

tongubin ()
Ответ на: комментарий от tongubin

Нет, потому что соответствующий пакет не обновляется для старых выпусков, так что надёжно на один выпуск и более-менее на два.

Elyas ★★★★★ ()
Ограничение на отправку комментариев: только для зарегистрированных пользователей