LINUX.ORG.RU

Debian 10 предупреждение при apt-get update

 


0

2

Добрый день. Когда готовился 10 выпуск я сидел на тестинге, пришло время обновить sources.list

сейчас sources.list выглядит так:

deb http://deb.debian.org/debian/ buster main

deb http://deb.debian.org/debian/ buster-updates main

deb http://security.debian.org/debian-security/ buster/updates main

deb http://ftp.debian.org/debian buster-backports main

при apt-get update выдает следующее:

: Репозиторий «http://security.debian.org/debian-security buster/updates InRelease» изменил значение поля «Version» с «» на «10» E: Репозиторий «http://security.debian.org/debian-security buster/updates InRelease» изменил значение поля «Suite» с «testing» на «stable» N: Требуется явное подтверждение, прежде чем можно будет обновить данный репозиторий. Дополнительную информацию смотрите в справочной странице apt-secure(8).

Подскажите, как исправить, спасибо.

Например, вместо apt-get update использовать apt update, который спросит, принять ли это изменение, и согласиться.

TeopeTuK ★★★ ()
Ответ на: комментарий от TeopeTuK

Тоже наткнулся на эту проблемку. Наверное, это так в Debian пытаются заставить перейти пользователей на apt. Как-то по майкрософтски. Но всё равно обошёлся без него: apt-get --allow-releaseinfo-change update.

gag ★★★★★ ()
Ответ на: комментарий от TeopeTuK

Не то что бы apt-get мог бы тоже спрашивать как и apt. Не обязательно. Но определённо apt-get должен был бы при ошибке выдать рекомендацию по использованию этой опции. Ведь ошибка ожидаемая (для разработчиков Debian). А он отсылает куда подальше, вот и подозрение, что пытались.

gag ★★★★★ ()
Ответ на: комментарий от gag

Чего ты ждешь от людей, выпустивших нерабочее г*овно в релиз? Ска, хорошо, что у меня были резервные копии!

anonymous ()
Ответ на: комментарий от gag

Во, поехавшие как всегда на связи.

Как бэ у apt назначение — для человека.

А apt-get для всяких программ сторонних, чтобы они его вызывали.

Поэтому в первом заменяйся, запрашивайся, а во втором надо соблюдать совместимость.

fornlr ★★★★★ ()
Ответ на: комментарий от fornlr

Поэтому в первом заменяйся, запрашивайся, а во втором надо соблюдать совместимость.

Так я же и говорю, что не ломая совместимость вопросами, можно просто выдать полезную инфу.

gag ★★★★★ ()
Ответ на: комментарий от gag

Я не пойму тебя чего не устраивает? Тебе дали инструмент для людей, ты пользуешься чем-то гиковским для программ и требуешь, чтобы тебе там на каждый чих что-то писали.

Да уже это может сломать парсер чтения вывода какой-то программы.

fornlr ★★★★★ ()
Ответ на: комментарий от fornlr

В нормальных дистрибутивах один менеджер пакетов (dnf, pacman...), а не сборная солянка apt, apt-*, aptitude с разным уровнем возможностей (ущербностей).

anonymous ()
Ответ на: комментарий от anonymous

dnf

fedora? dnf, flatpak

В debian и привели к единому вызову apt для пользователя

fornlr ★★★★★ ()
Последнее исправление: fornlr (всего исправлений: 1)
Вы не можете добавлять комментарии в эту тему. Тема перемещена в архив.