LINUX.ORG.RU

Ошибка apt update

 ,


0

1

Вот что выдает

sudo apt update
[sudo] пароль для user: 
Сущ:1 http://deb.debian.org/debian buster InRelease
Сущ:2 http://security.debian.org/debian-security buster/updates InRelease
Пол:3 http://qutim.org/debian/wheezy wheezy InRelease [4 530 B]                
Игн:4 http://ppa.launchpad.net/docky-core/stable/ubuntu focal InRelease        
Игн:5 http://dl.google.com/linux/chrome/deb stable InRelease                   
Сущ:6 http://deb.debian.org/debian buster-updates InRelease                    
Сущ:7 http://dl.google.com/linux/chrome/deb stable Release                     
Сущ:8 http://deb.debian.org/debian experimental InRelease                      
Ошб:3 http://qutim.org/debian/wheezy wheezy InRelease                          
  Следующие подписи неверны: 55F18961F4012F93482093FA755B00F7C90C75EB
Ошб:9 http://ppa.launchpad.net/docky-core/stable/ubuntu focal Release          
  404  Not Found [IP: 91.189.95.83 80]
Сущ:10 https://wire-app.wire.com/linux/debian stable InRelease                 
Сущ:11 http://deb.debian.org/debian stretch-backports InRelease                
Чтение списков пакетов… Готово            
W: Ошибка GPG: http://qutim.org/debian/wheezy wheezy InRelease: Следующие подписи неверны: 55F18961F4012F93482093FA755B00F7C90C75EB
E: Репозиторий «http://qutim.org/debian/wheezy wheezy InRelease» не подписан.
N: Обновление из этого репозитория нельзя выполнить безопасным способом, поэтому по умолчанию он отключён.
N: Информацию о создании репозитория и настройках пользователя смотрите в справочной странице apt-secure(8).
E: Репозиторий «http://ppa.launchpad.net/docky-core/stable/ubuntu focal Release» не содержит файла Release.
N: Обновление из этого репозитория нельзя выполнить безопасным способом, поэтому по умолчанию он отключён.
N: Информацию о создании репозитория и настройках пользователя смотрите в справочной странице apt-secure(8).
Но некоторых их этих строк нет в source.list. Откуда они берутся?
# 

# deb cdrom:[Debian GNU/Linux 10.1.0 _Buster_ - Official amd64 NETINST 20190908$

# deb cdrom:[Debian GNU/Linux 10.1.0 _Buster_ - Official amd64 NETINST 20190908$

deb http://deb.debian.org/debian/ buster main
deb-src http://deb.debian.org/debian/ buster main

deb http://security.debian.org/debian-security buster/updates main
deb-src http://security.debian.org/debian-security buster/updates main

# buster-updates, previously known as 'volatile'
deb http://deb.debian.org/debian/ buster-updates main
deb-src http://deb.debian.org/debian/ buster-updates main

# This system was installed using small removable media
# (e.g. netinst, live or single CD). The matching "deb cdrom"
# entries were disabled at the end of the installation process.
# For information about how to configure apt package sources,
# see the sources.list(5) manual.
# new line of text

Могу ошибаться, но вроде они берутся /etc/apt/apt.source.d/тут каждый файл - репозиторий. Путь по памяти.

Boogerman ()

Откуда они берутся?

cat /etc/apt/sourse.list

И тут отдельные, смотри каждый файл

ls -la /etc/apt/sourse.list.d/

И вообще:

Ошб:3 http://qutim.org/debian/wheezy wheezy InRelease
Следующие подписи неверны: 55F18961F4012F93482093FA755B00F7C90C75EB

https://www.qutim.org/download

Debian Wheezy

buster

Ни чего странным не кажется? Оно вообще там живо?

Ошб:9 http://ppa.launchpad.net/docky-core/stable/ubuntu focal Release
404 Not Found [IP: 91.189.95.83 80]

404 это 404. Ну и пихать PPA от убунты тоже плохая идея.

mandala ★★★★ ()
Ответ на: комментарий от Boogerman

Файл /etc/apt/sourse.list глобальный. А тут /etc/apt/apt.source.d/ уже хорошей практикой считается добавлять отдельные репозитории в каждом отдельном файле, касается в основном сторонних.

Собственно, все описано тысячу раз, можно начать отсюда:

https://wiki.debian.org/ru/SourcesList

https://debian-handbook.info/browse/ru-RU/stable/apt.html

mandala ★★★★ ()
Ответ на: комментарий от Boogerman

Ну не знаю, можно попробовать собрать из исходников, но зачем, если оно умерло?

mandala ★★★★ ()
Ответ на: комментарий от mandala

Спасибо за советы. Вроде поправил. Посмотрите, что получилось. Надо еще что-то править?

# apt update
Игн:1 http://dl.google.com/linux/chrome/deb stable InRelease                   
Сущ:2 http://deb.debian.org/debian buster InRelease                            
Сущ:3 http://security.debian.org/debian-security buster/updates InRelease      
Сущ:4 http://dl.google.com/linux/chrome/deb stable Release                     
Сущ:5 http://deb.debian.org/debian buster-updates InRelease                    
Сущ:6 http://deb.debian.org/debian experimental InRelease                      
Сущ:8 https://wire-app.wire.com/linux/debian stable InRelease                  
Сущ:9 http://deb.debian.org/debian stretch-backports InRelease                 
Чтение списков пакетов… Готово            
Построение дерева зависимостей       
Чтение информации о состоянии… Готово
Может быть обновлено 3 пакета. Запустите «apt list --upgradable» для их показа.
И что значит Игн и Сущ?

mark-v ()
Ответ на: комментарий от mark-v

Игн означает, что соответствующий файл не может быть загружен, но это не является ошибкой.

Сущ означает, что файл на сервере не изменился, и потому не будет загружен.

Сущ:9 http://deb.debian.org/debian stretch-backports InRelease

Зачем вам stretch-backports в buster?

Rootlexx ★★ ()
Ответ на: комментарий от Rootlexx

Зачем вам stretch-backports в buster?

Не моя система. Я только настройкой занимаюсь. Считаете, что нужно удалить?

mark-v ()
Вы не можете добавлять комментарии в эту тему. Тема перемещена в архив.