LINUX.ORG.RU

Нужна помощь в установке Libre office

 ,


0

1

Моя система: Linux Mint 18.3 Sylvia

Я удалял LO, затем пробовал WPS-office. Спустя продолжительное время решил вернуться обратно на LO. Удалил WPS-office, начал ставить LO При установке LO, обнаружились неудовлетворимые зависимости. Я решил их удовлетворить:

and@and-work ~ $ sudo apt install -f
Чтение списков пакетов… Готово
Построение дерева зависимостей       
Чтение информации о состоянии… Готово
Исправление зависимостей… Готово
Будут установлены следующие дополнительные пакеты:
  libreoffice-common
НОВЫЕ пакеты, которые будут установлены:
  libreoffice-common
обновлено 0, установлено 1 новых пакетов, для удаления отмечено 0 пакетов, и 38 пакетов не обновлено.
не установлено до конца или удалено 14 пакетов.
Необходимо скачать 35,6 MБ архивов.
После данной операции, объём занятого дискового пространства возрастёт на 81,0 MB.
Хотите продолжить? [Д/н] y
Пол:1 http://ppa.launchpad.net/libreoffice/ppa/ubuntu xenial/main amd64 libreoffice-common all 1:6.1.3~rc2-0ubuntu0.16.04.1 [35,6 MB]
Получено 35,6 MБ за 1мин 52с (317 kБ/c)                                                                          
(Чтение базы данных … на данный момент установлен 362221 файл и каталог.)
Подготовка к распаковке …/libreoffice-common_1%3a6.1.3~rc2-0ubuntu0.16.04.1_all.deb …
Распаковывается libreoffice-common (1:6.1.3~rc2-0ubuntu0.16.04.1) …
dpkg: ошибка при обработке архива /var/cache/apt/archives/libreoffice-common_1%3a6.1.3~rc2-0ubuntu0.16.04.1_all.deb (--unpack):
 попытка перезаписать «/usr/bin/soffice», который уже имеется в пакете openoffice-debian-menus 4.1.5-9789
rmdir: не удалось удалить '/var/lib/libreoffice/share/prereg/': Нет такого файла или каталога
rmdir: не удалось удалить '/var/lib/libreoffice/share/': Нет такого файла или каталога
rmdir: не удалось удалить '/var/lib/libreoffice/program/': Нет такого файла или каталога
rmdir: не удалось удалить '/var/lib/libreoffice': Нет такого файла или каталога
rmdir: не удалось удалить '/var/lib/libreoffice': Нет такого файла или каталога
Обрабатываются триггеры для shared-mime-info (1.5-2ubuntu0.2) …
Обрабатываются триггеры для gnome-icon-theme (3.12.0-1ubuntu3) …
Обрабатываются триггеры для hicolor-icon-theme (0.15-0ubuntu1.1) …
Обрабатываются триггеры для man-db (2.7.5-1) …
Обрабатываются триггеры для gnome-menus (3.13.3-6ubuntu3.1) …
Обрабатываются триггеры для desktop-file-utils (0.22+linuxmint1) …
Обрабатываются триггеры для mime-support (3.59ubuntu1) …
При обработке следующих пакетов произошли ошибки:
 /var/cache/apt/archives/libreoffice-common_1%3a6.1.3~rc2-0ubuntu0.16.04.1_all.deb
E: Sub-process /usr/bin/dpkg returned an error code (1)
and@and-work ~ $ 

Пробовал удалять этот проблемный пакет вручную, менять зеркало, снова install -f => та же самая проблема. Как решить куда копать?

Ответ на: комментарий от Deleted

Пробовал я apt clean, ничего не дало.

Там кстати ругается ещё на это:

dpkg: ошибка при обработке архива /var/cache/apt/archives/libreoffice-common_1%3a6.1.3~rc2-0ubuntu0.16.04.1_all.deb (--unpack):
 попытка перезаписать «/usr/bin/soffice», который уже имеется в пакете openoffice-debian-menus 4.1.5-9789

Пробовал удалить этот пакет, не получается:

and@and-work ~ $ sudo apt remove openoffice-debian-menus 
Чтение списков пакетов… Готово
Построение дерева зависимостей       
Чтение информации о состоянии… Готово
Возможно, для исправления этих ошибок вы захотите воспользоваться «apt-get -f install»:
Пакеты, имеющие неудовлетворённые зависимости:
 libreoffice-core : Зависит: libreoffice-common (> 1:6.1.3~rc2) но он не будет установлен
 libreoffice-gtk : Зависит: libreoffice-common (= 1:6.1.3~rc2-0ubuntu0.16.04.1) но он не будет установлен
 libreoffice-style-colibre : Зависит: libreoffice-common (= 1:6.1.3~rc2-0ubuntu0.16.04.1) но он не будет установлен
 libreoffice-style-tango : Зависит: libreoffice-common (= 1:6.1.3~rc2-0ubuntu0.16.04.1) но он не будет установлен
E: Неудовлетворённые зависимости. Попытайтесь выполнить «apt-get -f install», не указывая имени пакета, (или найдите другое решение).

andman ()
Ответ на: комментарий от znavko

В общем разобрался.

Для либры установилась часть пакетов, оставшейся части мешали пакеты опенофиса. При удалении пакетов опенофиса мешались неудовлетворённые зависимости либры. Снёс все пакеты либры, тогда удалились пакеты опенофиса, после чего либра встала без проблем. Как то так.

andman ()