LINUX.ORG.RU

Установка Skype на Debian 7 amd64


0

1

Установил Debian 7, решил поставить skype. Способ отсюда: https://wiki.debian.org/skype не помог.

dpkg -i skype-debian_4.3.0.37-1_i386.deb 
Выбор ранее не выбранного пакета skype.
(Чтение базы данных … на данный момент установлено 168008 файлов и каталогов.)
Распаковывается пакет skype (из файла skype-debian_4.3.0.37-1_i386.deb) …
dpkg: зависимости пакетов не позволяют настроить пакет skype:
 skype зависит от libc6 (>= 2.3.6-6~).
 skype зависит от libc6 (>= 2.7).
 skype зависит от libgcc1 (>= 1:4.1.1).
 skype зависит от libqt4-dbus (>= 4:4.5.3).
 skype зависит от libqt4-network (>= 4:4.8.0).
 skype зависит от libqt4-xml (>= 4:4.5.3).
 skype зависит от libqtcore4 (>= 4:4.7.0~beta1).
 skype зависит от libqtgui4 (>= 4:4.8.0).
 skype зависит от libqtwebkit4 (>= 2.1.0~2011week13).
 skype зависит от libstdc++6 (>= 4.2.1).
 skype зависит от libx11-6.
 skype зависит от libxext6.
 skype зависит от libxss1.
 skype зависит от libxv1.
 skype зависит от libssl1.0.0.
 skype зависит от libpulse0.
 skype зависит от libasound2-plugins.

dpkg: ошибка при обработке параметра skype (--install):
 проблемы зависимостей — оставляем не настроенным
Обрабатываются триггеры для desktop-file-utils …
Обрабатываются триггеры для gnome-menus …[br]
Обрабатываются триггеры для hicolor-icon-theme …
При обработке следующих пакетов произошли ошибки:
 skype

Если после этого запустить apt-get -f install, то происходит следующее:

apt-get -f install
Чтение списков пакетов… Готово
Построение дерева зависимостей       
Чтение информации о состоянии… Готово
Исправление зависимостей… Готово
Пакеты, которые будут УДАЛЕНЫ:
  skype:i386
обновлено 0, установлено 0 новых пакетов, для удаления отмечено 1 пакетов, и 0 пакетов не обновлено.
не установлено до конца или удалено 1 пакетов.
После данной операции, объём занятого дискового пространства уменьшится на 44,3 MB.
Хотите продолжить [Д/н]? Д
(Чтение базы данных … на данный момент установлено 168155 файлов и каталогов.)
Удаляется пакет skype …
Обрабатываются триггеры для hicolor-icon-theme …
Обрабатываются триггеры для desktop-file-utils …
Обрабатываются триггеры для gnome-menus …
Неужели нет выхода?

Ответ на: комментарий от Polugnom

Кажется да. Вот, сделал еще раз чтобы продемонстрировать вывод. И да, диски дебиана я храню распакованные, и соответственно отредактировал sources.list, до включения multiarch все работало без ошибок.

dpkg --add-architecture i386
root@XXXX:/# apt-get update
Игн file: wheezy Release.gpg
Игн file: wheezy Release.gpg                     
Игн file: wheezy Release.gpg                     
Игн file: wheezy Release.gpg                     
Игн file: wheezy Release.gpg                     
Получено:1 file: wheezy Release [18,6 kB]        
Получено:2 file: wheezy Release [17,7 kB]                                   
Получено:3 file: wheezy Release [14,2 kB]                                   
Получено:4 file: wheezy Release [4 092 B]                                   
Получено:5 file: wheezy Release [4 092 B]                                    
Ош  file: wheezy/contrib i386 Packages                                       
  Файл не найден
Ош  file: wheezy/main i386 Packages                                        
  Файл не найден
Ош  file: wheezy/contrib i386 Packages                                     
  Файл не найден
Ош  file: wheezy/main i386 Packages                                        
  Файл не найден
Ош  file: wheezy/contrib i386 Packages                                     
  Файл не найден
Ош  file: wheezy/main i386 Packages                                        
  Файл не найден
Ош  file: wheezy/contrib i386 Packages                                     
  Файл не найден
Ош  file: wheezy/main i386 Packages                                        
  Файл не найден
Ош  file: wheezy/non-free i386 Packages                                    
  Файл не найден
Игн file: wheezy/contrib Translation-ru_RU                                 
Игн file: wheezy/contrib Translation-ru                                    
Игн file: wheezy/contrib Translation-en                                    
Игн file: wheezy/main Translation-ru_RU                                    
Игн file: wheezy/main Translation-ru                                       
Игн file: wheezy/main Translation-en                                       
Игн file: wheezy/non-free Translation-ru_RU                                
Игн file: wheezy/non-free Translation-ru                                   
Игн file: wheezy/non-free Translation-en                                   
Ош  file: wheezy/contrib i386 Packages                                     
  Файл не найден
Ош  file: wheezy/main i386 Packages                                        
  Файл не найден
Ош  file: wheezy/non-free i386 Packages                                    
  Файл не найден
Игн file: wheezy/contrib Translation-ru_RU                                 
Игн file: wheezy/contrib Translation-ru                                    
Игн file: wheezy/contrib Translation-en                                    
Игн file: wheezy/main Translation-ru_RU                                    
Игн file: wheezy/main Translation-ru                                       
Игн file: wheezy/main Translation-en                                       
Игн file: wheezy/non-free Translation-ru_RU                                
Игн file: wheezy/non-free Translation-ru                                   
Игн file: wheezy/non-free Translation-en                                   
В кэше http://security.debian.org wheezy/updates Release.gpg                   
В кэше http://security.debian.org wheezy/updates Release                       
В кэше http://security.debian.org wheezy/updates/main Sources  
В кэше http://security.debian.org wheezy/updates/contrib Sources
В кэше http://security.debian.org wheezy/updates/non-free Sources
В кэше http://security.debian.org wheezy/updates/main amd64 Packages
В кэше http://security.debian.org wheezy/updates/contrib amd64 Packages
В кэше http://security.debian.org wheezy/updates/non-free amd64 Packages
В кэше http://security.debian.org wheezy/updates/main i386 Packages
В кэше http://security.debian.org wheezy/updates/contrib i386 Packages
В кэше http://security.debian.org wheezy/updates/non-free i386 Packages
В кэше http://security.debian.org wheezy/updates/contrib Translation-en
В кэше http://security.debian.org wheezy/updates/main Translation-en
В кэше http://security.debian.org wheezy/updates/non-free Translation-en
W: Не удалось получить file:/deb-dvd/debian-7.6.0-amd64-DVD-1/dists/wheezy/contrib/binary-i386/Packages  Файл не найден

W: Не удалось получить file:/deb-dvd/debian-7.6.0-amd64-DVD-1/dists/wheezy/main/binary-i386/Packages  Файл не найден

W: Не удалось получить file:/deb-dvd/debian-7.6.0-amd64-DVD-2/dists/wheezy/contrib/binary-i386/Packages  Файл не найден

W: Не удалось получить file:/deb-dvd/debian-7.6.0-amd64-DVD-2/dists/wheezy/main/binary-i386/Packages  Файл не найден

W: Не удалось получить file:/deb-dvd/debian-7.6.0-amd64-DVD-3/dists/wheezy/contrib/binary-i386/Packages  Файл не найден

W: Не удалось получить file:/deb-dvd/debian-7.6.0-amd64-DVD-3/dists/wheezy/main/binary-i386/Packages  Файл не найден

W: Не удалось получить file:/deb-dvd/debian-update-7.6.0-amd64-DVD-1/dists/wheezy/contrib/binary-i386/Packages  Файл не найден

W: Не удалось получить file:/deb-dvd/debian-update-7.6.0-amd64-DVD-1/dists/wheezy/main/binary-i386/Packages  Файл не найден

W: Не удалось получить file:/deb-dvd/debian-update-7.6.0-amd64-DVD-1/dists/wheezy/non-free/binary-i386/Packages  Файл не найден

W: Не удалось получить file:/deb-dvd/debian-update-7.6.0-amd64-DVD-2/dists/wheezy/contrib/binary-i386/Packages  Файл не найден

W: Не удалось получить file:/deb-dvd/debian-update-7.6.0-amd64-DVD-2/dists/wheezy/main/binary-i386/Packages  Файл не найден

W: Не удалось получить file:/deb-dvd/debian-update-7.6.0-amd64-DVD-2/dists/wheezy/non-free/binary-i386/Packages  Файл не найден

E: Некоторые индексные файлы не скачались. Они были проигнорированы или вместо них были использованы старые версии.

Soyfer ()
Ответ на: комментарий от teamfighter
#

# deb cdrom:[Debian GNU/Linux 7.6.0 _Wheezy_ - Official amd64 DVD Binary-1 20140712-14:11]/ wheezy contrib main

#deb cdrom:[Debian GNU/Linux 7.6.0 _Wheezy_ - Official amd64 DVD Binary-1 20140712-14:11]/ wheezy contrib main
#deb cdrom:[Debian GNU/Linux 7.6.0 _Wheezy_ - Official amd64 DVD Binary-2 20140712-14:11]/ wheezy contrib main
#deb cdrom:[Debian GNU/Linux 7.6.0 _Wheezy_ - Official amd64 DVD Binary-3 20140712-14:11]/ wheezy contrib main
#deb cdrom:[Debian GNU/Linux 7.6.0 Update DVD 20140712: amd64 DVD 1]/ wheezy contrib main non-free
#deb cdrom:[Debian GNU/Linux 7.6.0 Update DVD 20140712: amd64 DVD 2]/ wheezy contrib main non-free

deb file:/deb-dvd/debian-7.6.0-amd64-DVD-1/ wheezy contrib main
deb file:/deb-dvd/debian-7.6.0-amd64-DVD-2/ wheezy contrib main
deb file:/deb-dvd/debian-7.6.0-amd64-DVD-3/ wheezy contrib main
deb file:/deb-dvd/debian-update-7.6.0-amd64-DVD-1/ wheezy contrib main non-free
deb file:/deb-dvd/debian-update-7.6.0-amd64-DVD-2/ wheezy contrib main non-free


deb http://security.debian.org/ wheezy/updates main contrib non-free
deb-src http://security.debian.org/ wheezy/updates main contrib non-free

# wheezy-updates, previously known as 'volatile'
# A network mirror was not selected during install.  The following entries
# are provided as examples, but you should amend them as appropriate
# for your mirror of choice.
#
 deb http://ftp.debian.org/debian/ wheezy-updates main contrib non-free
 deb-src http://ftp.debian.org/debian/ wheezy-updates main contrib non-free





Возможно, мне нужно скачать диски для i386 и так же добавить их?

Soyfer ()
Ответ на: комментарий от Soyfer

Именно. Для скайпика нужна куча i386 пакетов, которых на дисках нету.

roman77 ★★★★★ ()
Ответ на: комментарий от Soyfer

Нет, не надо. Попробуй после установки skype с помощью dpkg выполнить aptitude update а потом aptitude install. Если первым вариантом aptitude предложит удалить skype (как и apt-get) просто нажми «n» и посмотри другие решения.

Polugnom ★★★★★ ()
Ответ на: комментарий от Polugnom

Думаешь скайп после уговоров заработает без необходимых пакетов?

gstreamer1.0-plugins-base:i386 libaudio2:i386 libavahi-client3:i386 libavahi-common-data:i386 libavahi-common3:i386 libcdparanoia0:i386 libcups2:i386 libfontconfig1:i386 libfreetype6:i386
  libglib2.0-0:i386 libglu1-mesa:i386 libgmp10:i386 libgnutls-deb0-28:i386 libgssapi-krb5-2:i386 libgstreamer-plugins-base1.0-0:i386 libgstreamer1.0-0:i386 libhogweed2:i386 libjpeg62:i386
  libjpeg8:i386 libk5crypto3:i386 libkeyutils1:i386 libkrb5-3:i386 libkrb5support0:i386 liblcms2-2:i386 libmng1:i386 libnettle4:i386 libp11-kit0:i386 libpng12-0:i386 libqt4-dbus:i386
  libqt4-network:i386 libqt4-opengl:i386 libqt4-xml:i386 libqt4-xmlpatterns:i386 libqtcore4:i386 libqtdbus4:i386 libqtgui4:i386 libqtwebkit4:i386 libsqlite3-0:i386 libssl1.0.0:i386
  libtasn1-6:i386 libtiff5:i386 libvisual-0.4-0:i386 libvisual-0.4-plugins:i386 libxrender1:i386 libxss1:i386 libxt6:i386 libxv1:i386 skype:i386
roman77 ★★★★★ ()
Ответ на: комментарий от roman77

Так у него что, интернета нет? В sources.list вполне присутствует

deb http://ftp.debian.org/debian/ wheezy-updates main contrib non-free
Если есть интернет, никакие диски не нужны.

Polugnom ★★★★★ ()
Последнее исправление: Polugnom (всего исправлений: 1)
Ответ на: комментарий от Polugnom

Мб оно там изначально было. Никогда не ставил дистр с диска без инета.

roman77 ★★★★★ ()
Ответ на: комментарий от Soyfer

Возможно, мне нужно скачать диски для i386 и так же добавить их?

Конечно, DLBD используя Jigdo.

vinignik ()
Ответ на: комментарий от Polugnom
aptitude install
Следующие НОВЫЕ пакеты будут установлены:        
  libcurl4-gnutls-dev{b} 
Следующие частично установленные пакеты будут настроены:
  skype:i386{b} 
0 пакетов обновлено, 1 установлено новых, 0 пакетов отмечено для удаления, и 0 пакетов не обновлено.
Необходимо получить 0 B/1 261 kB архивов. После распаковки 2 664 kB будет занято.
Следующие пакеты имеют неудовлетворённые зависимости:
 libcurl4-openssl-dev : Конфликтует: libcurl-dev который является виртуальным пакетом.
                        Конфликтует: libcurl4-gnutls-dev но устанавливается 7.26.0-1+wheezy10.
 skype:i386 : Зависит: libc6:i386 (>= 2.3.6-6~) но его установка не запланирована.
              Зависит: libc6:i386 (>= 2.7) но его установка не запланирована.
              Зависит: libgcc1:i386 (>= 1:4.1.1) который является виртуальным пакетом.
              Зависит: libqt4-dbus:i386 (>= 4:4.5.3) который является виртуальным пакетом.
              Зависит: libqt4-network:i386 (>= 4:4.8.0) который является виртуальным пакетом.
              Зависит: libqt4-xml:i386 (>= 4:4.5.3) который является виртуальным пакетом.
              Зависит: libqtcore4:i386 (>= 4:4.7.0~beta1) который является виртуальным пакетом.
              Зависит: libqtgui4:i386 (>= 4:4.8.0) который является виртуальным пакетом.
              Зависит: libqtwebkit4:i386 (>= 2.1.0~2011week13) который является виртуальным пакетом.
              Зависит: libstdc++6:i386 (>= 4.2.1) который является виртуальным пакетом.
              Зависит: libx11-6:i386 но его установка не запланирована.
              Зависит: libxext6:i386 но его установка не запланирована.
              Зависит: libxss1:i386 который является виртуальным пакетом.
              Зависит: libxv1:i386 но его установка не запланирована.
              Зависит: libssl1.0.0:i386 но его установка не запланирована.
              Зависит: libpulse0:i386 который является виртуальным пакетом.
              Зависит: libasound2-plugins:i386 который является виртуальным пакетом.
 libcurl4-gnutls-dev : Конфликтует: libcurl-dev который является виртуальным пакетом.
                       Конфликтует: libcurl4-openssl-dev но установлен 7.26.0-1+wheezy10 
Следующие действия разрешат зависимости:

     Удалить следующие пакеты:
1)     libcurl4-openssl-dev   
2)     skype:i386             



Принять данное решение? [Y/n/q/?] n
Следующие действия разрешат зависимости:

     Удалить следующие пакеты:                         
1)     skype:i386                                      

     Сохранить для следующих пакетов их текущие версии:
2)     libcurl4-gnutls-dev [Не установлен]             



Принять данное решение? [Y/n/q/?] n

*** Больше решений нет ***

Следующие действия разрешат зависимости:

     Удалить следующие пакеты:                         
1)     skype:i386                                      

     Сохранить для следующих пакетов их текущие версии:
2)     libcurl4-gnutls-dev [Не установлен]             



Принять данное решение? [Y/n/q/?] 

Похоже что действительно придется качать i386 диски

Soyfer ()
Ответ на: комментарий от Soyfer

Так нет интернета? Ну да, качать диски. Хотя можешь просто скачать все пакеты из списка и установить их с помощью dpkg.

Polugnom ★★★★★ ()
Последнее исправление: Polugnom (всего исправлений: 1)
Ответ на: комментарий от Polugnom

Есть интернет, но в репозиториях он видимо эти пакеты не находит.

Soyfer ()
Ответ на: комментарий от Soyfer

Такиум тебя репа не полностью прописана. Гугли sources list generator.

roman77 ★★★★★ ()

Установил Debian 7, решил поставить skype.

Поставь убунточку и не мучайся.

w1nner ★★★★★ ()
Ответ на: комментарий от Soyfer

Диски 64 битные, в апдейтах нужных пакетов нет. Добавь main

chg ★★★★★ ()
Ответ на: комментарий от yoghurt

Вот тебе мой sources.list как есть. Хотя у меня jessie.

# 

# deb cdrom:[Debian GNU/Linux testing _Jessie_ - Official Snapshot amd64 NETINST Binary-1 20140609-06:30]/ jessie main

#deb cdrom:[Debian GNU/Linux testing _Jessie_ - Official Snapshot amd64 NETINST Binary-1 20140609-06:30]/ jessie main

deb http://mirror.yandex.ru/debian/ jessie main contrib non-free
deb-src http://mirror.yandex.ru/debian/ jessie main

deb http://security.debian.org/ jessie/updates main
deb-src http://security.debian.org/ jessie/updates main

# jessie-updates, previously known as 'volatile'
deb http://mirror.yandex.ru/debian/ jessie-updates main contrib non-free
deb-src http://mirror.yandex.ru/debian/ jessie-updates main

# jessie-backports, previously on backports.debian.org
deb http://mirror.yandex.ru/debian/ jessie-backports main contrib non-free
deb-src http://mirror.yandex.ru/debian/ jessie-backports main
yoghurt ★★★★★ ()
Вы не можете добавлять комментарии в эту тему. Тема перемещена в архив.