LINUX.ORG.RU

Неудовлетворённые зависимости Ubuntu 18.04

 , ,


0

1
$ sudo apt-get update && sudo apt-get upgrade -y
Сущ:1 http://ppa.launchpad.net/kubuntu-ppa/backports/ubuntu bionic InRelease
Сущ:2 http://ru.archive.ubuntu.com/ubuntu bionic InRelease                                                                                         
Пол:3 http://security.ubuntu.com/ubuntu bionic-security InRelease [83,2 kB]                                                                        
Сущ:4 http://ru.archive.ubuntu.com/ubuntu bionic-updates InRelease                                                                                 
Игн:5 http://dl.google.com/linux/chrome/deb stable InRelease                                                                                       
Сущ:6 http://ru.archive.ubuntu.com/ubuntu bionic-backports InRelease                                                                               
Сущ:7 http://dl.google.com/linux/chrome/deb stable Release                                                                                         
Сущ:8 http://archive.canonical.com/ubuntu bionic InRelease                                                                                         
Сущ:9 http://ppa.launchpad.net/papirus/papirus/ubuntu bionic InRelease                                                                         
Получено 83,2 kB за 2с (48,1 kB/s)                                                                     
Чтение списков пакетов… Готово
Чтение списков пакетов… Готово
Построение дерева зависимостей       
Чтение информации о состоянии… Готово
Возможно, для исправления этих ошибок вы захотите воспользоваться «apt-get -f install».
Пакеты, имеющие неудовлетворённые зависимости:
 libgl1-mesa-dev : Зависит: libglvnd-dev но он не установлен
E: Неудовлетворённые зависимости. Попытайтесь выполнить «apt --fix-broken install», не указывая имени пакета, (или найдите другое решение).
$ sudo apt-get -f install 
Чтение списков пакетов… Готово
Построение дерева зависимостей       
Чтение информации о состоянии… Готово
Исправление зависимостей… Готово
Будут установлены следующие дополнительные пакеты:
  libgles1 libglvnd-dev
НОВЫЕ пакеты, которые будут установлены:
  libgles1 libglvnd-dev
Обновлено 0 пакетов, установлено 2 новых пакетов, для удаления отмечено 0 пакетов, и 0 пакетов не обновлено.
Установлено или удалено не до конца 1 пакетов.
Необходимо скачать 14,6 kB архивов.
После данной операции, объём занятого дискового пространства возрастёт на 91,1 kB.
Хотите продолжить? [Д/н] 
Пол:1 http://ru.archive.ubuntu.com/ubuntu bionic-updates/main amd64 libgles1 amd64 1.0.0-2ubuntu2.2 [11,2 kB]
Пол:2 http://ru.archive.ubuntu.com/ubuntu bionic-updates/main amd64 libglvnd-dev amd64 1.0.0-2ubuntu2.2 [3 408 B]
Получено 14,6 kB за 0с (109 kB/s)    
(Чтение базы данных … на данный момент установлено 306534 файла и каталога.)
Подготовка к распаковке …/libgles1_1.0.0-2ubuntu2.2_amd64.deb …
Распаковывается libgles1:amd64 (1.0.0-2ubuntu2.2) …
dpkg: ошибка при обработке архива /var/cache/apt/archives/libgles1_1.0.0-2ubuntu2.2_amd64.deb (--unpack):
 попытка перезаписать «/usr/lib/x86_64-linux-gnu/libGLESv1_CM.so.1», который уже имеется в пакете nvidia-340 340.106-0ubuntu3
Подготовка к распаковке …/libglvnd-dev_1.0.0-2ubuntu2.2_amd64.deb …
Распаковывается libglvnd-dev:amd64 (1.0.0-2ubuntu2.2) …
dpkg: ошибка при обработке архива /var/cache/apt/archives/libglvnd-dev_1.0.0-2ubuntu2.2_amd64.deb (--unpack):
 попытка перезаписать «/usr/lib/x86_64-linux-gnu/libGLESv1_CM.so», который уже имеется в пакете nvidia-340 340.106-0ubuntu3
При обработке следующих пакетов произошли ошибки:
 /var/cache/apt/archives/libgles1_1.0.0-2ubuntu2.2_amd64.deb
 /var/cache/apt/archives/libglvnd-dev_1.0.0-2ubuntu2.2_amd64.deb
E: Sub-process /usr/bin/dpkg returned an error code (1)

Ответ на: комментарий от ya-betmen
# deb cdrom:[Ubuntu 18.04.1 LTS _Bionic Beaver_ - Release amd64 (20180725)]/ bionic main restricted

# See http://help.ubuntu.com/community/UpgradeNotes for how to upgrade to
# newer versions of the distribution.
deb http://ru.archive.ubuntu.com/ubuntu/ bionic main restricted
# deb-src http://ru.archive.ubuntu.com/ubuntu/ bionic main restricted

## Major bug fix updates produced after the final release of the
## distribution.
deb http://ru.archive.ubuntu.com/ubuntu/ bionic-updates main restricted
# deb-src http://ru.archive.ubuntu.com/ubuntu/ bionic-updates main restricted

## N.B. software from this repository is ENTIRELY UNSUPPORTED by the Ubuntu
## team. Also, please note that software in universe WILL NOT receive any
## review or updates from the Ubuntu security team.
deb http://ru.archive.ubuntu.com/ubuntu/ bionic universe
# deb-src http://ru.archive.ubuntu.com/ubuntu/ bionic universe
deb http://ru.archive.ubuntu.com/ubuntu/ bionic-updates universe
# deb-src http://ru.archive.ubuntu.com/ubuntu/ bionic-updates universe

## N.B. software from this repository is ENTIRELY UNSUPPORTED by the Ubuntu 
## team, and may not be under a free licence. Please satisfy yourself as to 
## your rights to use the software. Also, please note that software in 
## multiverse WILL NOT receive any review or updates from the Ubuntu
## security team.
deb http://ru.archive.ubuntu.com/ubuntu/ bionic multiverse
# deb-src http://ru.archive.ubuntu.com/ubuntu/ bionic multiverse
deb http://ru.archive.ubuntu.com/ubuntu/ bionic-updates multiverse
# deb-src http://ru.archive.ubuntu.com/ubuntu/ bionic-updates multiverse

## N.B. software from this repository may not have been tested as
## extensively as that contained in the main release, although it includes
## newer versions of some applications which may provide useful features.
## Also, please note that software in backports WILL NOT receive any review
## or updates from the Ubuntu security team.
deb http://ru.archive.ubuntu.com/ubuntu/ bionic-backports main restricted universe multiverse
# deb-src http://ru.archive.ubuntu.com/ubuntu/ bionic-backports main restricted universe multiverse

## Uncomment the following two lines to add software from Canonical's
## 'partner' repository.
## This software is not part of Ubuntu, but is offered by Canonical and the
## respective vendors as a service to Ubuntu users.
deb http://archive.canonical.com/ubuntu/ bionic partner
# deb-src http://archive.canonical.com/ubuntu/ bionic partner

deb http://security.ubuntu.com/ubuntu/ bionic-security main restricted
# deb-src http://security.ubuntu.com/ubuntu/ bionic-security main restricted
deb http://security.ubuntu.com/ubuntu/ bionic-security universe
# deb-src http://security.ubuntu.com/ubuntu/ bionic-security universe
deb http://security.ubuntu.com/ubuntu/ bionic-security multiverse
# deb-src http://security.ubuntu.com/ubuntu/ bionic-security multiverse
# deb-src http://ftp.ru.debian.org/debian/ squeeze main contrib non-free
[1/8] /etc/apt/sources.list.d/gnome3-team-ubuntu-gnome3-bionic.list 
# deb http://ppa.launchpad.net/gnome3-team/gnome3/ubuntu/ bionic main
# deb-src http://ppa.launchpad.net/gnome3-team/gnome3/ubuntu/ bionic main

[1/6] /etc/apt/sources.list.d/google-chrome.list 
### 
### 
### THIS FILE IS AUTOMATICALLY CONFIGURED ### 
# You may comment out this entry, but any other modifications may be lost. 
deb [arch=amd64] http://dl.google.com/linux/chrome/deb/ stable main

[1/4] /etc/apt/sources.list.d/kubuntu-ppa-ubuntu-backports-bionic.list 
deb http://ppa.launchpad.net/kubuntu-ppa/backports/ubuntu/ bionic main 
# deb-src http://ppa.launchpad.net/kubuntu-ppa/backports/ubuntu/ bionic main

[1/2] /etc/apt/sources.list.d/papirus-ubuntu-papirus-bionic.list 
deb http://ppa.launchpad.net/papirus/papirus/ubuntu/ bionic main 
# deb-src http://ppa.launchpad.net/papirus/papirus/ubuntu/ bionic main
RutileGryphon ()
Ответ на: комментарий от RutileGryphon

То то я гляжу с виду всё вроде как нормально. Кажется оно https://bugs.launchpad.net/ubuntu/ source/libglvnd/ bug/1793853

Ну снеси пока блоб. Чё делать то.

ya-betmen ★★★★★ ()
Последнее исправление: ya-betmen (всего исправлений: 1)
Ответ на: комментарий от RutileGryphon

Хз, наверняка где-то выхлоп должен быть, но я по зеленым не спе. Создавай тред как вернуть нуво, кастуй нвидивцев. Ну или подожди так пока не пофиксят.

ya-betmen ★★★★★ ()
Ответ на: комментарий от LongLiveUbuntu
$ cat /etc/modprobe.d/blacklist.conf
# This file lists those modules which we don't want to be loaded by
# alias expansion, usually so some other driver will be loaded for the
# device instead.

# evbug is a debug tool that should be loaded explicitly
blacklist evbug

# these drivers are very simple, the HID drivers are usually preferred
blacklist usbmouse
blacklist usbkbd

# replaced by e100
blacklist eepro100

# replaced by tulip
blacklist de4x5

# causes no end of confusion by creating unexpected network interfaces
blacklist eth1394

# snd_intel8x0m can interfere with snd_intel8x0, doesn't seem to support much
# hardware on its own (Ubuntu bug #2011, #6810)
blacklist snd_intel8x0m

# Conflicts with dvb driver (which is better for handling this device)
blacklist snd_aw2

# causes failure to suspend on HP compaq nc6000 (Ubuntu: #10306)
blacklist i2c_i801

# replaced by p54pci
blacklist prism54

# replaced by b43 and ssb.
blacklist bcm43xx

# most apps now use garmin usb driver directly (Ubuntu: #114565)
blacklist garmin_gps

# replaced by asus-laptop (Ubuntu: #184721)                                                                                                         
blacklist asus_acpi                                                                                                                                 
                                                                                                                                                    
# low-quality, just noise when being used for sound playback, causes
# hangs at desktop session start (Ubuntu: #246969)
blacklist snd_pcsp

# ugly and loud noise, getting on everyone's nerves; this should be done by a
# nice pulseaudio bing (Ubuntu: #77010)
blacklist pcspkr

# EDAC driver for amd76x clashes with the agp driver preventing the aperture
# from being initialised (Ubuntu: #297750). Blacklist so that the driver
# continues to build and is installable for the few cases where its
# really needed.
blacklist amd76x_edac
RutileGryphon ()
Ответ на: комментарий от RutileGryphon

Не имеет значения. Можешь переименовать его в xorg.conf.old, например, или перенести к себе в домашнюю директорию. Это же просто текстовый файл, и если путь до него не /etc/X11/xorg.conf, то он не выполняет никакой функции в системе.

Vsevolod-linuxoid ★★★★★ ()
Ответ на: комментарий от RutileGryphon

Нашёл я решение этой проблемы!

sudo dpkg -i --force-overwrite /var/cache/apt/archives/libglvnd-dev_1.0.0-2ubuntu2.2_amd64.deb sudo dpkg -i --force-overwrite /var/cache/apt/archives/libgles1_1.0.0-2ubuntu2.2_amd64.deb sudo apt -f install

Выполните всё по порядку!

rixxar ()