LINUX.ORG.RU

Как починить зависимости

 ,


0

2

Pandora ~ # apt-get update

Сущ:1 http://ppa.launchpad.net/deluge-team/ppa/ubuntu xenial InRelease

Пол:2 http://security.ubuntu.com/ubuntu xenial-security InRelease [102 kB] Сущ:3 http://archive.canonical.com/ubuntu xenial InRelease Сущ:4 http://archive.ubuntu.com/ubuntu xenial InRelease

Сущ:5 http://ppa.launchpad.net/embrosyn/cinnamon/ubuntu xenial InRelease

Игн:6 http://dl.google.com/linux/chrome-remote-desktop/deb stable InRelease

Игн:7 http://packages.linuxmint.com serena InRelease

Сущ:8 http://archive.ubuntu.com/ubuntu xenial-updates InRelease

Игн:9 http://dl.google.com/linux/chrome/deb stable InRelease

Сущ:10 http://ppa.launchpad.net/flexiondotorg/youtube-dl-gui/ubuntu xenial InRelease

Пол:11 http://archive.ubuntu.com/ubuntu xenial-backports

InRelease [102 kB]

Сущ:12 http://dl.google.com/linux/chrome-remote-desktop/deb stable Release

Сущ:13 http://ppa.launchpad.net/notepadqq-team/notepadqq/ubuntu xenial InRelease

Сущ:14 http://packages.linuxmint.com serena Release

Сущ:15 http://dl.google.com/linux/chrome/deb stable Release

Сущ:17 http://ppa.launchpad.net/teejee2008/ppa/ubuntu xenial InRelease

Игн:20 https://mega.nz/linux/MEGAsync/xUbuntu_16.04 ./ InRelease

Пол:21 https://mega.nz/linux/MEGAsync/xUbuntu_16.04 ./ Release [988 B]

Получено 205 kБ за 3с (61,7 kБ/c)

Чтение списков пакетов… Готово

Pandora ~ # apt-get upgrade

Чтение списков пакетов… Готово

Построение дерева зависимостей

Чтение информации о состоянии… Готово

Расчёт обновлений… Готово

обновлено 0, установлено 0 новых пакетов, для удаления отмечено 0 пакетов, и 0 пакетов не обновлено.

Pandora ~ # apt-get install sqlitebrowser

Чтение списков пакетов… Готово

Построение дерева зависимостей

Чтение информации о состоянии… Готово

Некоторые пакеты невозможно установить. Возможно, вы просите невозможного,или же используете нестабильную версию дистрибутива, где запрошенные вамипакеты ещё не созданы или были удалены из Incoming. Следующая информация, возможно, поможет вам:

Пакеты, имеющие неудовлетворённые зависимости:

sqlitebrowser : Зависит: libqt5scintilla2-12v5 (>= 2.8.4) но он не будет установлен

E: Невозможно исправить ошибки, у вас отложены (held) битые пакеты.

Pandora ~ #

apt-get -f install не помогает

Что за дистрибутив?

А так, что-то здесь намешано репозиториев, xenial, serena, xenial-backports. Вестимо проблема в этом.

kostik87 ★★★★★ ()

У тебя, как раз, нет сломанных зависимостей. И apt тебя нежно и ласково уберегает от того, чтобы ты их не сломал.

v9lij ★★★★★ ()

apt-cache show libqt5scintilla2-12v5
В студию!

redgremlin ★★★★★ ()
Ответ на: комментарий от v9lij

Не знаю правильно или нет, но починил вот так вот:

sudo add-apt-repository -y ppa:linuxgndu/sqlitebrowser

apt update

apt install sqlitebrowser

kotov666 ()
Ответ на: комментарий от kostik87

Linux Mint 18.1

Намешано, может потому что дополнительные репы подключал?

kotov666 ()
Ответ на: комментарий от v9lij

Дак вот и спрашивал здесь

А то если попытаться установить через aptitube то он вы итоге предлагал откатить около 180 пакетов, чет как боязно.

В итоге добавил свежий реп этой программы

kotov666 ()
Вы не можете добавлять комментарии в эту тему. Тема перемещена в архив.