LINUX.ORG.RU

Проблема с зависимостями zypper

 ,


0

1

Пардон, если не в ту тему или непонятно пишу. Есть openSUSE 42.3, установлен пакет wine20 из Emulators:Wine:STABLE (требуется для одной игры). Делаю zypper dup, он предлагает мне опять установить пакеты wine в дополнение к установленному wine20 и заодно еще удаленные ранее amarok и digikam. Пока решил эту проблему отключив installRecommends в zypper.conf, но хотелось бы в идеале разобраться как решать такие вопросы. Заранее спасибо.

Перемещено leave из talks

Я решаю такие проблемы в YaST2 (интерфейс Qt). Открываю YAST, открываю «Сводку установки». Он мне сразу предлагает установить что-нибудь по рекомендуемым зависимостям. Тык правой кнопкой, «Никогда не устанавливать», завершить работу.

ZenitharChampion ★★★★★ ()
Ответ на: комментарий от dinn

А зачем? 15.1 ещё не вышел

Бывает подключишь какой-нибудь репозиторий, потом удалишь, и нужно восстановить статус-кво, zypper dup помогает.

pyatachet ()
Ответ на: комментарий от kott

запускать с --no-recommends

Это понятно, хотелось бы понять какой паттерн или зависимости тянут при zypper dup эти пакеты

Будут установлены 8 НОВЫХ пакетов:
  amarok amarok-lang digikam digikam-lang libSDL2-2_0-0-32bit wine wine-32bit wine-mono
И как это правильно разрешить.

pyatachet ()

В случае вайна поможет lutris.

takino ★★★★ ()
Ответ на: комментарий от Darth_Revan

Спасибо, добрый человек Darth_Revan! Как я понял у wine20 в зависимости wine-mono, а он уже тянет wine и wine-32bit. Заблокировал wine-mono, проблема решилась.

pyatachet ()
Вы не можете добавлять комментарии в эту тему. Тема перемещена в архив.