LINUX.ORG.RU

opengl glx extension not supported by display (part2)

 , , , ,


0

1

При себе:

ubuntu 16.04 + i7 3630Qm + geforce 730M

драйвера установленные с офф сайта

Ранее данную проблему решал таким образом: apt install bumblebee bumblebee-nvidia primus

Но теперь bumblebee-nvidia тащит такое добро:

nvidia-304 nvidia-current nvidia-opencl-icd-304 libcuda1-304

Как теперь быть?

★★

> драйвера установленные с офф сайта

> opengl glx extension not supported by display

Драйвер с официального сайта затирает системные «libGL.so.1» и «libglx.so». А если запустить инсталлятор с ключом --uninstall, то он вернёт их обратно из резервной копии.

В твоём случае, инсталлятор не подходит. Bumblebee использует специально установленный драйвер, который не затирает системные библиотеки. Bumblebee использует одновременно и интеловский OpenGL, и нвидиевский.

Есть ещё вариант с отключением Intel вообще. Но это плохо скажется на времени работы от батарей: NVIDIA Prime на не-Ubuntu У тебя Ubuntu, и такой способ в ней включается одним кликом мышью, и никакой настройки из командной строки не требуется.

ZenitharChampion ★★★★★ ()
Ответ на: комментарий от ZenitharChampion

Драйвера с офф. сайта планировал попробовать исключительно для того, что бы понять есть ли пррблемы с фризами в некоторых приложениях или нет.

BitSum ★★ ()
Ответ на: комментарий от ZenitharChampion

А что если эти либы куда-то копирнуть, а потом обратно подсунуть?

BitSum ★★ ()
Ответ на: комментарий от BitSum

Это умеют делать только шаманы, которые создавали Bumblebee. Лучше просто запусти инсталлятор снова, с ключом --uninstall, а потом установи новый драйвер NVIDIA из PPA-репозитория.

http://vasilisc.com/ppa-proprietary-nvidia-gpu-driver

ZenitharChampion ★★★★★ ()
Последнее исправление: ZenitharChampion (всего исправлений: 1)
Вы не можете добавлять комментарии в эту тему. Тема перемещена в архив.