LINUX.ORG.RU

Ubuntu nvidia driver

 , ,


0

1

Чтобы упростить себе жизнь решил поставить драйвера на nvidia с репозиториев, но как оказалось, в отличии от nvidia-304, все что выше имеет в зависимостях какой-то бред: nautilus, network-manager, cheese, lightdm, gnome-*, uniti-*... Это что рекламный довес? Драйверу они нафиг не нужны... Может можно как-то выбрать нужное?

Ubuntu 16.04

(Причина такого желание: официальный драйвер не всегда правильно пересобирается с новыми ядрами и приходится переустанавливать в ручную)

все что выше имеет в зависимостях какой-то бред: nautilus, network-manager, cheese, lightdm, gnome-*, uniti-*

Нет, не имеет.

root@akamanah-PC:/home/akamanah# apt show nvidia-390
Package: nvidia-390
Version: 390.12-0ubuntu0~gpu17.10.2
Priority: optional
Section: misc
Source: nvidia-graphics-drivers-390
Maintainer: Ubuntu Core Developers <ubuntu-devel-discuss@lists.ubuntu.com>
Installed-Size: 307 MB
Provides: nvidia-driver-binary, nvidia-persistenced, nvidia-smi, xorg-driver-binary, xorg-driver-video
Depends: x11-common (>= 1:7.0.0), make, sed (>> 3.0), dkms, linux-libc-dev, libc6-dev, patch, acpid, lib32gcc1, libc6-i386, passwd, adduser, xserver-xorg-legacy, libc6 (>= 2.2.5), libgl1, libwayland-client0 (>= 1.3.92), libwayland-server0 (>= 1.2.0), libx11-6, libxext6, xorg-video-abi-11 | xorg-video-abi-12 | xorg-video-abi-13 | xorg-video-abi-14 | xorg-video-abi-15 | xorg-video-abi-18 | xorg-video-abi-19 | xorg-video-abi-20 | xorg-video-abi-23, xserver-xorg-core
Akamanah ★★★★★ ()
Ответ на: комментарий от Akamanah

Нет, не имеет.

Потому что не существует :)

apt show nvidia-390
N: Unable to locate package nvidia-390
N: Unable to locate package nvidia-390
E: No packages found

И да apt install и apt show показывает разные зависимости :)

LinuxDebian ★★★★ ()
Последнее исправление: LinuxDebian (всего исправлений: 1)

sudo apt-get install --no-install-recommends

Aceler ★★★★★ ()
Ответ на: комментарий от Aceler

Точно! Спасибо. Сначала испугался что он не поставит необходимых зависимостей, а потом понял что они стоят так как установлен 304й...

LinuxDebian ★★★★ ()
Ответ на: комментарий от LinuxDebian

Сначала испугался что он не поставит необходимых зависимостей

Поставит. Он не поставит рекомендуемые, но поставит обязательные.

Aceler ★★★★★ ()

В пакете nvidia-384 нету.

 aptitude show nvidia-384
Пакет: nvidia-384                                
Состояние: установлен
Автоматически установлен: нет
Версия: 384.111-0ubuntu0.16.04.1
Приоритет: необязательный
Раздел: restricted/misc
Сопровождающий: Ubuntu Core Developers <ubuntu-devel-discuss@lists.ubuntu.com>
Архитектура: amd64
Размер в распакованном виде: 312 M
Зависимости: x11-common (>= 1:7.0.0), make, sed (> 3.0), dkms, linux-libc-dev, libc6-dev, patch, acpid, lib32gcc1, libc6-i386,
             passwd, adduser, xserver-xorg-legacy, libc6 (>= 2.2.5), libgl1, libwayland-client0 (>= 1.3.92), libwayland-server0
             (>= 1.2.0), libx11-6, libxext6, xorg-video-abi-11 | xorg-video-abi-12 | xorg-video-abi-13 | xorg-video-abi-14 |
             xorg-video-abi-15 | xorg-video-abi-18 | xorg-video-abi-19 | xorg-video-abi-20 | xorg-video-abi-23,
             xserver-xorg-core
Рекомендует: nvidia-settings (>= 331.20), nvidia-prime (>= 0.5) | bumblebee, libcuda1-384, nvidia-opencl-icd-384
Конфликтует: nvidia-persistenced, nvidia-persistenced:i386, nvidia-smi, xorg-driver-binary, xorg-driver-binary:i386,
             nvidia-smi:i386, nvidia-384:i386
Заменяет: nvidia-persistenced, nvidia-persistenced:i386, nvidia-smi, xorg-driver-binary, xorg-driver-binary:i386,
          nvidia-smi:i386
Предоставляет: nvidia-driver-binary, nvidia-persistenced, nvidia-smi, xorg-driver-binary, xorg-driver-video
Описание: NVIDIA binary driver - version 384.111
 The binary driver provide optimized hardware acceleration of OpenGL applications via a direct-rendering X Server. AGP, PCIe,
 SLI, TV-out and flat panel displays are also supported. 
 
 This package also includes the source for building the kernel module required by the Xorg driver, and provides NVIDIA's
 implementation of the Video Decode and presentation API. The latter enables acceleration for GeForce 8 and later series cards
 for h264 video. 
 
 Release Notes and supported GPUs: http://www.nvidia.com/object/linux-display-amd64-384.111-driver.html

rumgot ★★★★★ ()
Вы не можете добавлять комментарии в эту тему. Тема перемещена в архив.