LINUX.ORG.RU

Ответ на: комментарий от Thero

openSUSE Leap 42.3 R7-260x установка amdgpu-pro

К сожалению не получилось, иксы зависают намертво не реагирует клавиатура. Только после правки grub2 singlemod удается загрузится без иксов и вернуть все как было.

AlexGan ()
Ответ на: комментарий от Thero

openSUSE Leap 42.3 R7-260x установка amdgpu-pro

# sh amdgpu-pro-preinstall_v1.4.sh --check
The amdgpu-pro driver requires access to specific RPMs from opensuse installation 
media as well as access to Bumblebee Repository for DKMS

Checking if the prerequisite files and repositories are available in order to 
successfully install the amdgpu-pro driver. 
No changes will be made to the system.

WARNING: Bumblebee repository is required to install DKMS and will need to be setup

WARNING: All prerequisite repositories have not been set up.
	 Please rerun the script without --check to set up required repositories.
No changes were made to the system.
AlexGan ()
Ответ на: openSUSE Leap 42.3 R7-260x установка amdgpu-pro от AlexGan

openSUSE Leap 42.3 R7-260x установка amdgpu-pro

DKMS установлен при этом из репозитория Packman. Установил DKMS из репозитория для openSUSE Leap 42.3, вывод amdgpu-pro-preinstall_v1.4.sh --check тот же. Выполнил

# sh amdgpu-pro-preinstall_v1.4.sh
The amdgpu-pro driver requires access to specific RPMs from opensuse installation 
media as well as access to Bumblebee Repository for DKMS

This script will confirm that all required prerequisite files and repositories
are available in order to successfully install the amdgpu-pro driver.  
Press ENTER to continue . . ."
 
[Bumblebee-Project]
Name=Bumblebee-Project for DKMS
baseurl=http://download.opensuse.org/repositories/home:/Bumblebee-Project:/Bumblebee3/SLE_12/
enabled=1
gpgcheck=0

Checking if repositories were set up successfully...
Something went wrong and the install media repository was not set up successfully.
Try running the script with root priviledges. 
The required repositories have been set up.
Please run amdgpu-pro-install to install the amdgpu-pro driver.
без --check Установился репозиторий Bumlebee-Ploject для SLE_12. И только после этого получил:
sh amdgpu-pro-preinstall_v1.4.sh --check
The amdgpu-pro driver requires access to specific RPMs from opensuse installation 
media as well as access to Bumblebee Repository for DKMS

Checking if the prerequisite files and repositories are available in order to 
successfully install the amdgpu-pro driver. 
No changes will be made to the system.

The required repositories have been set up.
Please run amdgpu-pro-install to install the amdgpu-pro driver.
No changes were made to the system.
Далее установил DKMS 2.3-2.1 хотя из Packman стоял 2.3.8.2. Попробую установить драйвер.

AlexGan ()

я наверно год назад ставиш на 42.1 и в общем оно работало и просто с ядром из гита, а если нужен просто вулан и опенкл то это вообще лд прелодом делается, с минимальным насилием над иксами и системой в целом.

Novell-ch ★★★★★ ()
Ответ на: openSUSE Leap 42.3 R7-260x установка amdgpu-pro от AlexGan

openSUSE Leap 42.3 R7-260x установка amdgpu-pro

Попытка установить закончилась этим:

Дополнительный вывод rpm:
Loading new amdgpu-pro-17.30-465504 DKMS files...
Building for 4.4.87-25-default
Building initial module for 4.4.87-25-default
Error! Bad return status for module build on kernel: 4.4.87-25-default (x86_64)
Consult /var/lib/dkms/amdgpu-pro/17.30-465504/build/make.log for more information.
warning: %post(amdgpu-pro-dkms-0:17.30-465504.noarch) scriptlet failed, exit status 10

AlexGan ()
Ответ на: комментарий от Novell-ch

openSUSE Leap 42.3 R7-260x установка amdgpu-pro

Расскажите по подробней пожалуйста. В ядре по умолчанию выключена CONFIG_DRM_AMDGPU_CIK= может по этому у Вас работало на ядре из гита?

AlexGan ()
Ответ на: openSUSE Leap 42.3 R7-260x установка amdgpu-pro от AlexGan

разве, помоему в сесу давно его включили, ну у меня то ядроа были самосборные, но помню приходили дистрибутивные уже с модулем

Novell-ch ★★★★★ ()
Ответ на: комментарий от AlexGan

хотя я думаю мы увидим что-то вроде вот этой пасты из аналогичного случая.. https://paste.opensuse.org/78197197

тут нужно либо собирать с более свежим ядром или более старой версией amdgpu-pro(например 16.50)

Thero ★★★★★ ()
Ответ на: комментарий от Thero

openSUSE Leap 42.3 R7-260x установка amdgpu-pro

да Вы правы тоже самое.

AlexGan ()
Ответ на: комментарий от Thero

openSUSE Leap 42.3 R7-260x установка amdgpu-pro

На попытку установить amdgpu-pro 16.50 получил

# ./amdgpu-pro-install
Unsupported RedHat derivative OS
Какое новое ядро нужно поставить и откуда чтобы стал amdgpu-pro 17.30?

AlexGan ()
Ответ на: комментарий от Thero

ещё тут вычитал что в сусе как-то хитро забэкпортили графический стэк от ядра 4.9 пакетом drm-kmp-default, вероятно он и конфликтует с хаками в коде амд что не даёт драйверу 17.30 собраться.. есть вероятность что после удаления drm-kmp-default 17.30 правильно соберётся на стеке 4.4

Thero ★★★★★ ()
Ответ на: комментарий от Thero

При сборке вот такое сообщение drm-kmp-default удален

Error! Bad return status for module build on kernel: 4.4.87-25-default (x86_64)
Consult /var/lib/dkms/amdgpu-pro/17.30-465504/build/make.log for more information.
warning: %post(amdgpu-pro-dkms-0:17.30-465504.noarch) scriptlet failed, exit status 10
Тоже самое.

AlexGan ()

на openSUSE (42.2, 42.3) и SLED 12 sp3 amdgpu-pro поставить не удалось. Нормально поставился только на SLED 12 sp2. После правки amdgpu-pro-dkms-17.30-465504.noarch.rpm удалось поставить, но после перезагрузки - чёрный экран с курсором мышки.

anonymous ()
Ответ на: комментарий от AlexGan

я думаю проще сейчас подождать 17.40 сидя на amdgpu-mesa там может поддержку опенсусе завезут в амдгпу-про( сейчас только sles и sled официально поддерживаются)

кажется сейчас для успешной сборки нужно ещё и прикинуться sled( как-то поправив в /etc/os-release наверное, тут не знаю может Novell-ch подскажет) и возможно что-то ещё..

Thero ★★★★★ ()

А что тебе от проприетарного драйвера нужно?

BceM_IIpuBeT ★★ ()
Ответ на: комментарий от Thero

ну я на 42.1 ставил и работало как нужно, только 32 битных либ не было, так что толку от опенгл почти не было, ни вайн ни стим нормально не поюзать, а вот вулкан и опенкл вполне юзал, вместе с месой

Novell-ch ★★★★★ ()
Ответ на: комментарий от BceM_IIpuBeT

Мне бы видеокарту нормально поюзать. Не рендерит ничего.

AlexGan ()
Ответ на: комментарий от AlexGan

openSUSE Leap 42.3 R7-260x установка amdgpu-pro

После обновления ядра до 4.4.90-28-default графика стала немного лучше. Некоторые графические утилиты стали запускаться нормально.

AlexGan ()
Ответ на: комментарий от Thero

openSUSE Leap 42.3 R7-260x установка amdgpu-pro

Дождался 17.40 загрузил новое ядро 4.4.92-31-default. Попробовал собрать

Loading new amdgpu-17.40-492261 DKMS files...
Building for 4.4.92-31-default
Building initial module for 4.4.92-31-default
Error! Bad return status for module build on kernel: 4.4.92-31-default (x86_64)
Consult /var/lib/dkms/amdgpu/17.40-492261/build/make.log for more information.
warning: %post(amdgpu-pro-dkms-0:17.40-492261.noarch) scriptlet failed, exit status 10
Все те же грабли. Вопрос остается открытым.

AlexGan ()
Ответ на: openSUSE Leap 42.3 R7-260x установка amdgpu-pro от AlexGan

Я не знаю.. в опенсусе похоже вообще не очень чешутся за то чтоб амдгпу-про заводилась не только в SLE*.. надо конечно посмотреть, может сообщество что-то придумало..

Thero ★★★★★ ()
Ответ на: комментарий от Thero

R7 260X

Здравствуйте! Прошло 4 месяца с момента последнего сообщения в этой теме. Может быть есть какие-то успехи в установке закрытого драйвера. Я приобрел такую видяху и у меня чешутся руки на закрытый драйвер.

bitchevar ()
Ответ на: R7 260X от bitchevar

Re: R7 260X

Не чеши, открытый лучше в играх.

anonymous ()
Ответ на: R7 260X от bitchevar

ну.. с одной стороны она прекрасно заводится в арче или убунте, а в сусе как-то неочень, не думаю что до выхода leap 15 что-то поменяется.

Thero ★★★★★ ()
Вы не можете добавлять комментарии в эту тему. Тема перемещена в архив.