LINUX.ORG.RU

Не устанавливается amdgpu-pro на Debian 10.10

 , ,


0

1

Облазил весь интернет, но толкового решения не нашел. Суть, не устанавливаются драйвера amdgpu-pro Терминал выдает следующее:

Некоторые пакеты не могут быть установлены. Возможно, то, что вы просите, неосуществимо, или же вы используете нестабильную версию дистрибутива, где запрошенные вами пакеты ещё не созданы или были удалены из Incoming. Следующая информация, возможно, вам поможет:

Следующие пакеты имеют неудовлетворённые зависимости: amdgpu : Зависит: amdgpu-lib (= 21.30-1290604) но он не будет установлен amdgpu-lib32 : Зависит: amdgpu-lib (= 21.30-1290604) но он не будет установлен или amdgpu-lib-hwe (= 21.30-1290604) но он не может быть установлен Зависит: libllvm12.0-amdgpu:i386 (= 1:12.0-1290604) Зависит: libwayland-amdgpu-client0:i386 (= 1.18.0-1290604) Зависит: libwayland-amdgpu-server0:i386 (= 1.18.0-1290604) Зависит: libxatracker2-amdgpu:i386 (= 1:21.2.0-1290604) Зависит: libgbm1-amdgpu:i386 (= 1:21.2.0-1290604) Зависит: libegl1-amdgpu-mesa:i386 (= 1:21.2.0-1290604) Зависит: libegl1-amdgpu-mesa-drivers:i386 (= 1:21.2.0-1290604) Зависит: libgl1-amdgpu-mesa-glx:i386 (= 1:21.2.0-1290604) Зависит: libgl1-amdgpu-mesa-dri:i386 (= 1:21.2.0-1290604) Зависит: mesa-amdgpu-va-drivers:i386 (= 1:21.2.0-1290604) Зависит: mesa-amdgpu-vdpau-drivers:i386 (= 1:21.2.0-1290604) amdgpu-pro : Зависит: libgl1-amdgpu-pro-glx (= 21.30-1290604) но он не будет установлен Зависит: libgl1-amdgpu-pro-ext (= 21.30-1290604) но он не будет установлен Зависит: libgl1-amdgpu-pro-dri (= 21.30-1290604) но он не будет установлен amdgpu-pro-lib32 : Зависит: libgl1-amdgpu-pro-glx:i386 (= 21.30-1290604) Зависит: libgl1-amdgpu-pro-dri:i386 (= 21.30-1290604) vulkan-amdgpu-pro : Зависит: libgcc-s1 (>= 3.3.1) но он не может быть установлен Зависит: libwayland-amdgpu-client0 но он не будет установлен vulkan-amdgpu-pro:i386 : Зависит: libgcc-s1:i386 (>= 3.3.1) но он не может быть установлен Зависит: libwayland-amdgpu-client0:i386 но он не будет установлен E: Невозможно исправить ошибки: у вас зафиксированы сломанные пакеты.

З.Ы я особо не шарю, так как пришел с окон

С ним всё время какие-то проблемы. Пробовал пару раз с наскока ставить, глубоко вникать лень. Недостатчность мотивации в виде вопроса «а нафехуа, а главное зачем» тратить на это время и силы, привела к решению: положить болт ввиду беспроблемности обычного, нормального amdgpu.

erfea ★★★★★ ()
Ответ на: комментарий от erfea

да вот, с обычным amdgpu похожая лажа выходит:

Некоторые пакеты не могут быть установлены. Возможно, то, что вы просите, неосуществимо, или же вы используете нестабильную версию дистрибутива, где запрошенные вами пакеты ещё не созданы или были удалены из Incoming. Следующая информация, возможно, вам поможет:

Следующие пакеты имеют неудовлетворённые зависимости: amdgpu : Зависит: amdgpu-lib (= 21.30-1290604) но он не будет установлен amdgpu-lib32 : Зависит: amdgpu-lib (= 21.30-1290604) но он не будет установлен или amdgpu-lib-hwe (= 21.30-1290604) но он не может быть установлен Зависит: libllvm12.0-amdgpu:i386 (= 1:12.0-1290604) Зависит: libwayland-amdgpu-client0:i386 (= 1.18.0-1290604) Зависит: libwayland-amdgpu-server0:i386 (= 1.18.0-1290604) Зависит: libxatracker2-amdgpu:i386 (= 1:21.2.0-1290604) Зависит: libgbm1-amdgpu:i386 (= 1:21.2.0-1290604) Зависит: libegl1-amdgpu-mesa:i386 (= 1:21.2.0-1290604) Зависит: libegl1-amdgpu-mesa-drivers:i386 (= 1:21.2.0-1290604) Зависит: libgl1-amdgpu-mesa-glx:i386 (= 1:21.2.0-1290604) Зависит: libgl1-amdgpu-mesa-dri:i386 (= 1:21.2.0-1290604) Зависит: mesa-amdgpu-va-drivers:i386 (= 1:21.2.0-1290604) Зависит: mesa-amdgpu-vdpau-drivers:i386 (= 1:21.2.0-1290604) E: Невозможно исправить ошибки: у вас зафиксированы сломанные пакеты.

crystalshard ()

У вас просто дебиан, где данных версий пакетов нет. Нужно либо перейти на unstable или где там есть данные версии пакетов, либо выбрать дистрибутив, где это всё и так работает. Советую Manjaro, а AMDGPU-PRO установить только для OpenCL. У меня так уже 2 года работает с 18.0.2 версии и ядра 5.0 вроде.

OpenMind ★★★★ ()
Последнее исправление: OpenMind (всего исправлений: 1)
Ответ на: комментарий от crystalshard

Плохая идея. Лучше поставить какую-нибудь бубунту. Там даже на стабильной 20.04 всё в порядке с дровами из коробки.

erfea ★★★★★ ()

толкового решения не нашел.
пришел с окон

Ты поставил старую версию, где нет поддержки твоего железа.

Выбери нужную тебе архитектуру и формат iso отсюда:

https://cdimage.debian.org/cdimage/unofficial/non-free/cd-including-firmware/...

Например:

https://cdimage.debian.org/cdimage/unofficial/non-free/cd-including-firmware/...

LamerOk ★★★★★ ()
Ответ на: комментарий от crystalshard

Выбор получается невелик. Либо ставить другой образ дебиана, либо сносить его и искать другой дистрибутив

Выбор совсем другой: нужно поставить один из дистрибутивов, перечисленных на странице загрузки драйвера. Зачем тебе лишние проблемы с совместимостью, ты же явно не играть на нем собираешься.

annulen ★★★★★ ()
Ответ на: комментарий от crystalshard

с обычным amdgpu

Нужен только mesa. Так как он скорее всего подтянут в качестве зависимости уже, ничего делать не требуется.

Какую проблему хотите решить установкой -pro варианта?

xDShot ★★★★★ ()
Ответ на: комментарий от crystalshard

Если тебе не нужны проприетарные реализации OpenGL и Vulkan, то прошка тебе нахрен не нужна. OpenCL из неё накатывается при необходимости по другому, без установки всего стека. В остальном открытый драйвер ничем не хуже (кроме того, модуль ядра один и для про и для открытого). Закрытый драйвер он не для всех, а для тех, кто понимает, зачем он нужен.

anonymous ()
Ответ на: комментарий от anonymous

Спасибо учту. Но тем не менее, я так и не понял, что мне делать с открытыми драйверами если они тоже ошибку выдают?

З.Ы прошу прощения, за тупость

crystalshard ()
Ответ на: комментарий от crystalshard

Рядом с открытыми дровами можно поставить официальные дрова с OpenCL. Я на подобном девайсе просто юзаю Manjaro KDE, ибо там это решает в 2 клика буквально.

 ██████████████████  ████████     madness@ThinkpadX140E
 ██████████████████  ████████     OS: Manjaro 21.1.0 Pahvo
 ██████████████████  ████████     Kernel: x86_64 Linux 5.10.53-1-MANJARO
 ██████████████████  ████████     Uptime: 6h 31m
 ████████            ████████     Packages: 1713
 ████████  ████████  ████████     Shell: bash
 ████████  ████████  ████████     Resolution: 1366x768
 ████████  ████████  ████████     DE: KDE 5.84.0 / Plasma 5.22.4
 ████████  ████████  ████████     WM: KWin
 ████████  ████████  ████████     GTK Theme: Breath-Dark [GTK2/3]
 ████████  ████████  ████████     Icon Theme: breeze-dark
 ████████  ████████  ████████     Disk: 217G / 287G (80%)
 ████████  ████████  ████████     CPU: AMD E1-2500 APU with Radeon HD Graphics @ 2x 1.4GHz
 ████████  ████████  ████████     GPU: AMD KABINI (DRM 3.40.0, 5.10.53-1-MANJARO, LLVM 12.0.1)
                                  RAM: 5062MiB / 7223MiB
Graphics:  Device-1: AMD Kabini [Radeon HD 8240 / R3 Series] driver: amdgpu v: kernel 
Display: x11 server: X.Org 1.20.11 driver: loaded: amdgpu,ati unloaded: modesetting 
OpenGL: renderer: AMD KABINI (DRM 3.40.0 5.10.53-1-MANJARO LLVM 12.0.1) v: 4.6 Mesa 21.1.5 
Vulkan Instance Version: 1.2.185
GPU id : 0 (AMD RADV KABINI (ACO))
Установлены пакеты amd-ucode, mhwd-amdgpu, amdvlk, xf86-video-amdgpu, opencl-amd. Последний скачивает этот самый AMDGPU-PRO последней версии и устанавливает только OpenCL. Моё барахло может использовать все возможности, которые в него запиханы.

OpenMind ★★★★ ()

Расскажите подробнее, как пытаетесь установить.

И осильте разметку уже — читать такую мешанину текста очень неприятно.

Rootlexx ★★★ ()
Ответ на: комментарий от crystalshard

с обычным amdgpu похожая лажа выходит

anon@nymous:~# apt-cache search amdgpu
libdrm-amdgpu1 - Userspace interface to amdgpu-specific kernel DRM services -- runtime
ricks-amdgpu-utils - AMD GPU performance adjustment and monitoring
xserver-xorg-video-amdgpu - X.Org X server -- AMDGPU display driver
firmware-amd-graphics - Binary firmware for AMD/ATI graphics chips
anon@nymous:~# apt-cache show libdrm-amdgpu1 xserver-xorg-video-amdgpu 
Package: libdrm-amdgpu1
Source: libdrm
Version: 2.4.104-1
Installed-Size: 83
Maintainer: Debian X Strike Force <debian-x@lists.debian.org>
Architecture: amd64
Depends: libc6 (>= 2.28), libdrm2 (>= 2.4.101)
Description-en: Userspace interface to amdgpu-specific kernel DRM services -- runtime
 This library implements the userspace interface to the kernel DRM
 services.  DRM stands for "Direct Rendering Manager", which is the
 kernelspace portion of the "Direct Rendering Infrastructure" (DRI).
 The DRI is currently used on Linux to provide hardware-accelerated
 OpenGL drivers.
Description-md5: 61a9b44d2a8366ec01d27d9e105f5ecb
Multi-Arch: same
Homepage: https://cgit.freedesktop.org/mesa/drm/
Tag: role::shared-lib
Section: libs
Priority: optional
Filename: pool/main/libd/libdrm/libdrm-amdgpu1_2.4.104-1_amd64.deb
Size: 28516
MD5sum: 14c8004d3888b5d5f38dd770fa2b3d82
SHA256: 0005f21e342925bd26a25185289ae035aa931ced8f6fd9e3d4deade36d272ecd

Package: xserver-xorg-video-amdgpu
Version: 19.1.0-2
Installed-Size: 253
Maintainer: Debian X Strike Force <debian-x@lists.debian.org>
Architecture: amd64
Provides: xorg-driver-video
Depends: libc6 (>= 2.17), libdrm-amdgpu1 (>= 2.4.73), libgbm1 (>= 8.1~0), libudev1 (>= 183), xorg-video-abi-24, xserver-xorg-core (>= 2:1.18.99.901)
Suggests: firmware-amd-graphics
Description-en: X.Org X server -- AMDGPU display driver
 This package provides the 'amdgpu' driver for the AMD Radeon cards. The
 following chip families should be supported: Bonaire, Hawaii, Kaveri, Kabini
 Mullins, Iceland, Tonga, Carrizo, Fiji, Stoney.
 .
 More information about X.Org can be found at:
 <URL:http://www.X.org>
 .
 This package is built from the X.org xf86-video-amdgpu driver module.
Description-md5: e2b193b8ecbf0f4c08a535d8f9541c51
Section: x11
Priority: optional
Filename: pool/main/x/xserver-xorg-video-amdgpu/xserver-xorg-video-amdgpu_19.1.0-2_amd64.deb
Size: 136472
MD5sum: a912f2b8e3fbd70f34d8427cda2e25f2
SHA256: d06a0dfde48c705364ec326bf6a5bf0936d6074a32802731516018c33436e0b4

anon@nymous:~# cat /etc/debian_version 
11.0
anon@nymous:~#
LamerOk ★★★★★ ()

прошу прощения, что долго не отвечал. Проблема решилась установкой не всего драйвера, а только определенных его частей. А именно amdgpu-core, xserver-xorg-video-amdgpu и микрокода для AMD карт.

crystalshard ()
Ответ на: комментарий от crystalshard

Зависимости с версией для Ubuntu 18.04 у меня разрешились нормально. Так что если что, попробуйте эту.

Rootlexx ★★★ ()
Для того чтобы оставить комментарий войдите или зарегистрируйтесь.