LINUX.ORG.RU

Удаление xfce4-pulseaudio-plugin

 ,


1

1

Изначально заикался звук в debian, поэтому поставил alsa и удалил pulseaudio, но тем не менее от pulseaudio осталась иконка в меню и еще ~4 пакета. Решил удалить все это дело, но меня смутило то, что после команды

sudo apt-get purge xfce4-pulseaudio-plugin

предлагает удалить task-xfce-desktop и xfce4.

После

 sudo aptitude purge xfce4-pulseaudio-plugin

предлагает удалить эти пакеты и еще пол гига других, не имеющих к пульсу никакого отношения (типо xfce4-weather-plugin и xfce4-session).

Вопрос такой: как удалить этот pulseaudio полностью так, чтобы все не поломать?

ivan@debian:~$ dpkg -l | grep -i pulse
ri  gstreamer1.0-pulseaudio:amd64         1.10.4-1                          amd64        GStreamer plugin for PulseAudio
ri  libpulse-mainloop-glib0:amd64         10.0-1+deb9u1                     amd64        PulseAudio client libraries (glib support)
ri  libpulse0:amd64                       10.0-1+deb9u1                     amd64        PulseAudio client libraries
ri  pavucontrol                           3.0-3.1                           amd64        PulseAudio Volume Control
ri  xfce4-pulseaudio-plugin:amd64         0.2.4-1                           amd64        Xfce4 panel plugin to control pulseaudio

ты используешь бинарный дистрибутив в котором зависимости прописаны мейнтейнерами. они за тебя всё решили.
не нравится — чемодан, вокзал, source-based distributions
смысла в остальном просто нет.

system-root ★★★★ ()

Слушайся умных мейнтейнеров и используй пульсу.

entefeed ☆☆☆ ()

Как бы все верно: от xfce4-pulseaudio-plugin зависит метапакет xfce4. Удаление последнего тянет за собой еще зависимости.

https://packages.debian.org/stretch/xfce4

Но удалить, я думаю, все же можно. Вариант тут только один - все пакеты, которые зависят от xfce4 сделать как бы установленными вручную, потом удалить pulseaudio-plugin. Но это как бы если он тебе серьезно мешает.

Zubok ★★★★★ ()
Ответ на: комментарий от Zubok

Найти установленные пакеты, которые зависят от xfce4, можно так:

$ sudo aptitude search ~R^xfce4$~i

Пометить из как установленные вручную так:

$ sudo aptitude unmarkauto ~R^xfce4$~i

Дальше можно удалять плагин. Он должен уйти вместе с xfce4 и task-xfce-desktop.

Disclamer: я не несу ответственности за твои действия и за свои советы :)

Zubok ★★★★★ ()
Последнее исправление: Zubok (всего исправлений: 3)
Ответ на: комментарий от Zubok

Спасибо, конечно, но я думаю, что все таки он не слишком мне мешает)

butylka ()

Хотя... попробуй еще вариант сбить флаг только у xfce4-pulseaudio-plugin:

$ sudo aptitude unmarkauto xfce4-pulseaudio-plugin

Дальше попробуй удалить его. Я уже просто забыл, будет ли метапакет в этом случае считаться поломанным (broken). Скорее всего, да. Тогда уже сделать, как в предыдущем сообщении.

Zubok ★★★★★ ()
Последнее исправление: Zubok (всего исправлений: 1)
Ответ на: комментарий от butylka

А, ну тогда и хорошо. Вернуть флаг назад - aptitude markauto, если неудачно что-то будет. Все обратимо.

Zubok ★★★★★ ()
Последнее исправление: Zubok (всего исправлений: 1)

Удалил pulseaudio и хватит, зачем удалять этот плагин? Тебе мегабайт жалко? Ты еще пересобери все пакеты что-бы отключить поддержку пульсы.

tm4 ()

А зачем удалять если звук работает?

Ygor ★★★★★ ()

Просто из ~/.config/autostart (или из /etc/xdg/autostart, смотря где он лежит) вынеси pulseaudio.desktop и будет тебе счастье без пульсы. А вместо него положи xfce4-mixer.desktop. Правда, придется сначала этот самый xfce4-mixer собрать.

yars068 ★★★★ ()
Последнее исправление: yars068 (всего исправлений: 1)
Вы не можете добавлять комментарии в эту тему. Тема перемещена в архив.