LINUX.ORG.RU

emerge: Прописать версию пакета, используемую при дальнейших обновлениях

 , ,


0

1

У меня проблема: xfce4-xkb-plugin не ставится, так как не находит libxklavier:

# emerge xfce4-xkb-plugin
Calculating dependencies... done!

emerge: there are no ebuilds to satisfy ">=x11-libs/libxklavier-5.4:=".
(dependency required by "xfce-extra/xfce4-xkb-plugin-0.8.0::desktop-kit" [ebuild])
(dependency required by "xfce4-xkb-plugin" [argument])

Вопрос с зависимостями решен использованием предыдущей версии xfce4-xkb-plugin

# emerge "=xfce-extra/xfce4-xkb-plugin-0.7.1-r1"

Но при обновлении мира, вероятно, я опть получу ошибку: Как решить вопрос с зависимостями?

Как прописать в системе использовать для пакета xfce4-xkb-plugin не последнюю версию, а заданную: 0.7.1-r1 ?

★★

# man portage
# echo ">xfce-extra/xfce4-xkb-plugin-0.7.1-r1" >> /etc/portage/package.mask
LeshaInc ()

Или если ты не смог файлом, делай директорией


# echo ">xfce-extra/xfce4-xkb-plugin-0.7.1-r1" > /etc/portage/package.mask/xfce4-xkb-plugin

LeshaInc ()

где ты эти траблы постоянно умудряешся ловить? буквально вчера собирал себе xfce (захотелось чего то более отзывчивого) все красиво собралось. у тебя ~ ?

xaTa ★★★ ()
Вы не можете добавлять комментарии в эту тему. Тема перемещена в архив.