LINUX.ORG.RU

Debian 9: в иксах напрочь «отваливается» мышь с клавиатурой. Как побороть?

 , ,


1

2

Здравствуйте, господа. Сегодня установил на Debian 9 новенькие пятокеды:

aptitude install kde-l10n-ru kde-runtime kwin-x11 plasma-desktop sddm xorg xserver-xorg-video-intel

Перезагрузка и... О ужас! В иксах (на приветственном экране с выбором пользователя и вводом пароля) мышь с клавиатурой напрочь перестают отзываться, будто их и нет вовсе. Даже не удаётся перейти в другую текстовую консоль посредством CTRL-ALT-<цифра>. В текстовой консоли до установки KDE, в UEFI Setup и в Windows 7 мышь и клавиатура бегают исправно. Существует ли противоядие для Клавы и её Грызуна в Debian?


О, у меня такое было с Xfce.

Попробуй загрузиться в single, убрать автозапуск графики, загрузись в текстовый режим и снеси все пакеты, что поставил, потом установи самый минимум.

Vsevolod-linuxoid ★★★★★ ()
Ответ на: комментарий от Sferg

Вообще, лучше бы ты на pastebin это все выложил. Короче. у тебя, как мне кажется, не стоит драйвер xserver-xorg-input-evdev.

7.671] (II) config/udev: Adding input device Power Button (/dev/input/event5)
[     7.671] (II) No input driver specified, ignoring this device.

Zubok ★★★★★ ()

используй apt вместо aptittude.
поставь intel микрокод.
напиши модель бука.
выпили libinput, поставь xserver-xorg-input-evdev xserver-xorg-input-mouse xserver-xorg-input-synaptics

Deleted ()
Ответ на: комментарий от logon

Так теперича libinput во все поля.

У кого как. У меня стоит evdev. Кому-то и libinput подойдет.

Zubok ★★★★★ ()
Ответ на: комментарий от Zubok

Установил xserver-xorg-input-evdev и всё заработало! Спасибо!

Sferg ()

Не могу понять одного: почему в Debian у него нет xserver-xorg-input-evdev и xserver-xorg-input-mouse :-/

Gonzo ★★★★★ ()
Ответ на: комментарий от Gonzo

Не могу понять одного: почему в Debian у него нет xserver-xorg-input-evdev и xserver-xorg-input-mouse :-/

Да он, наверное, ставил по какой-то инструкции, которая описывала минимальную установку иксов. Если поставить xserver-xorg-core и видеодрайвер, то вот такая ситуация и получится. При этом драйвера -input в систему по зависимостям не приходят, все можно вручную выбрать. Если бы он ставил xserver-xorg или тем более xorg, то ему бы все драйвера прибежали.

Zubok ★★★★★ ()
Последнее исправление: Zubok (всего исправлений: 2)

Вообще, для минимальных кед достаточно сделать так:

apt install kde-l10n-ru kde-plasma-desktop

Всё остальное поставится само (рекомендованные зависимости)

//Возможно, придётся доставить только kwin-x11 (не уверен, ставятся ли они по умолчанию)

xserver-xorg-video-intel ставить не рекомендуется для видеокарт, выпущенными позднее 2007 года.

Zomba444ok ()
Ответ на: комментарий от Zubok

Если бы он ставил xserver-xorg или тем более xorg, то ему бы все драйвера прибежали.

Дык я и ставил xorg (см. моё первое сообщение). При установке Jessie, пакет xserver-xorg-input-evdev сам подтягивался вместе с xorg. А вот при установке Stretch его нужно явно указывать.

Sferg ()
Ответ на: комментарий от Zomba444ok

Возможно, придётся доставить только kwin-x11 (не уверен, ставятся ли они по умолчанию)

Скорее всего ставится по умолчанию, однако у меня стоит запрет на установку Recommends и Suggests-пакетов. Поэтому указываю явно установку пакета, ибо без него у окон не будет заголовков и их нельзя будет двигать.

xserver-xorg-video-intel ставить не рекомендуется для видеокарт, выпущенными позднее 2007 года.

У меня интегрированная видюшка - Intel HD Graphics 4000, поэтому приходится ставить сей пакет. Или у Вас есть иное предложение?

Sferg ()
Ответ на: комментарий от Sferg

Дык я и ставил xorg (см. моё первое сообщение).

Отследил по зависимостям. У него зависимости интересные сейчас.

Он зависит (xserver-xorg-input-all | xorg-driver-input).

Первый тащит только xserver-xorg-input-libinput, а второй кучу драйверов. В том числе и evdev, и libinput тоже (https://packages.debian.org/stretch/xserver-xorg). Кто-то из них у тебя обязательно должен был поставиться: libinput или evdev. А -libinput у тебя стоит сейчас? Может, он все же поставился?

Zubok ★★★★★ ()
Последнее исправление: Zubok (всего исправлений: 2)
Ответ на: комментарий от Sferg

однако у меня стоит запрет на установку Recommends и Suggests-пакетов

Тогда тебе нужна слака, а не Debian

У меня интегрированная видюшка - Intel HD Graphics 4000, поэтому приходится ставить сей пакет. Или у Вас есть иное предложение?

Юзай modesetting https://packages.debian.org/ru/sid/xserver-xorg-video-intel

Zomba444ok ()
Вы не можете добавлять комментарии в эту тему. Тема перемещена в архив.