LINUX.ORG.RU

Ответ на: комментарий от Kroz

1.19 версия не стабильная, но я только ее и размаскировал. При попытке замаскировать версию 9999 он в дальнейшем ругается, что логично, ведь он почему то закидывает этот пакет в зависимость при попытке скачать 1.19

Farson1488 ()
Ответ на: комментарий от Farson1488

1.19 версия не стабильная

С какого это перепугу? Она hardmasked, и если ты её себе размаскировал, то ССЗБ.

r3lgar ★★★★★ ()

Замаскируй обратно. Если основное дерево портажа делает хардмаск, то это «ж-ж-ж» неспроста.

Bfgeshka ★★★★★ ()
Ответ на: комментарий от Farson1488

1.19 версия не стабильная, но я только ее и размаскировал.

Ну, тогда вполне логично, что она может требовать более новых зависимостей.

Зачем она тебе?

Kroz ★★★★★ ()
Ответ на: комментарий от Kroz

Ну, заставить работать разные дистрибутивы линукса со своей интегрированной в skylake графикой я пытаюсь уже около месяца. А в новый xorg добавили поддержку флага i965. Вот я и подумал что может хотя бы он решит мои проблемы

Farson1488 ()
Ответ на: комментарий от Bfgeshka

Хз что там «неспроста» у гентомантейнеров

$ pacman -Q xorg-server
xorg-server 1.19.1-1

Всё нормально работает. Вангую, у них просто человеко-часов не хватает, как обычно.

Deleted ()
Ответ на: комментарий от Deleted

Думаю, что дело не только в халатности мейнтейнеров Гендоо. У меня, к примеру, на 1.19.х появляются артефакты и прочие глитчи, когда на стабильном 1.17.х всё в норме.

HashDerpy ()
Ответ на: комментарий от Deleted

Если где-то проявляются малейшие регрессии, даже если далеко не у всех, то пакет легко и просто замаскируют.

Bfgeshka ★★★★★ ()
Последнее исправление: Bfgeshka (всего исправлений: 1)
Ответ на: комментарий от Farson1488

1.19 замаскирована даже в тестинговой ветке. Значит, либо там всё плохо, либо её еще не оттестировали.

А в новый xorg добавили поддержку флага i965.

Ок, убедил. Тогда смотри:

xorg-1.19 тянет за собой какую-то зависимость с версией выше любой из тех, которые размаскированы. Вот оно и «скатывается» в -9999.
Чтобы это решить, нужно понять что это за зависимость.

Если грубо, то можно посмотреть все -9999 пакеты которые оно пытается установить, наверняка среди них есть такие, у которых есть замаскированная «нормальная» версия. По идее будет несколько итераций. Но так можешь размаскировать больше, чем нужно, что не есть гуд.

Более правильно будет запустить emerge с ключем -t, и там будет понятно какой пакет тянет какой, и тогда уже размаскировывать по пакету и перезапускать emerge -t. Долго, кропотливо, но правильно.

И еще. Не исключено, что некоторые пакеты и правда нужно брать -9999. Ничего ужасного в этом нет. Просто все риски на тебе :) . У меня были такие кейсы, когда ставил новые KDE5; ничего, жив остался.

Если нужна помощь с анализом - говори.

Kroz ★★★★★ ()
Последнее исправление: Kroz (всего исправлений: 1)
Ответ на: комментарий от Deleted

конечно гонит .. причём с самого первого своего поста :)

anonymous ()

package.unmask:

<x11-base/xorg-server-9999
<x11-base/xorg-drivers-9999

Lavos ★★★★★ ()
Вы не можете добавлять комментарии в эту тему. Тема перемещена в архив.