LINUX.ORG.RU

xorg-drivers


0

0

надо поставить мне xorg-drivers, emerge орёт что заблокировано из-за xorg-server-1.7.0. делаю eMerge --unmerge xorg-server, в ответ полуЧаю что пакета не существует. как исправить? при установке xorG-server тоже говорит что версия 1.7.0 мешАет


Ответ на: комментарий от leviu

Есть несколько решений:

1) Использовать x11-drivers/xf86-video-ati (opensource)

2) Доунгрейдиться до x11-base/xorg-server-1.6.5-r1 и использовать x11-drivers/ati-drivers-10.3

3) Наиболее интересный вариант, стянуть из оверлеев 10.4 http://forums.gentoo.org/viewtopic-t-820893.html

ezoteric ()
Ответ на: комментарий от ezoteric

та же проблема

тоже самое, с дровами вроде как разобрался, но дело такое что иксы не ставятся) xorg-x11 и xorg-server 1.7.6 чтоли там доступен, всё блокируется 1.7.0. не могу разобраться. поставил опен соурс драйвер xf86-video-radeonhd. не запускается Xorg --configure, как я понял из-за того что иксов вообще нет. что из этого можно извлечь?

PornGroove ()
Ответ на: комментарий от PornGroove

> замаскировал пакет 1.7.0 теперь хорг-сервер 1.6.5 -р1 не может собраться.

В зависимостях тоже некоторые версии надо маскировать, на forums.gentoo.org проскакивал список

xf86-video-radeonhd.

xf86-video-ati используй лучше

//вообще лучше попробуй третий вариант, если заработает будет идеальный вариант

ezoteric ()
Ответ на: комментарий от ezoteric

/etc/portage/package.mask/x11

>=x11-apps/xinput-1.5.0
=x11-base/xorg-drivers-1.7
>=x11-base/xorg-server-1.7.0
>=x11-libs/libdmx-1.0.99.0
>=x11-libs/libX11-1.2.99.0
>=x11-libs/libXext-1.0.99.0
>=x11-libs/libXi-1.2.99.0
>=x11-libs/libXinerama-1.0.99.0
>=x11-libs/libXScrnSaver-1.2.0
>=x11-libs/libXtst-1.0.99.0
>=x11-libs/libXxf86dga-1.1
>=x11-libs/libXxf86vm-1.0.99.0
>=x11-proto/bigreqsproto-1.1
>=x11-proto/dmxproto-2.2.99
>=x11-proto/fixesproto-4.1
>=x11-proto/inputproto-1.9.99
>=x11-proto/recordproto-1.13.99.0
>=x11-proto/scrnsaverproto-1.2.0
>=x11-proto/xcmiscproto-1.2.0
>=x11-proto/xextproto-7.1.1
>=x11-proto/xf86bigfontproto-1.2.0
>=x11-proto/xf86dgaproto-2.1
>=x11-proto/xf86vidmodeproto-2.3
>=x11-proto/xineramaproto-1.2
>=media-libs/mesa-7.7

я вот только другое понять не могу как установился 1.7 если он замаскирован ati-drivers?

если кто найдет рабочий ебилд для ati-driver-installer-10-4 отпишитесь

deity ★★★★ ()
Ответ на: комментарий от ezoteric

Да сегфол во все поля hd 3300 с разными вариациями radeon hd

deity ★★★★ ()
Вы не можете добавлять комментарии в эту тему. Тема перемещена в архив.