LINUX.ORG.RU

lsmod |grep nvidia

Что пишет

irton ★★★★★ ()
Ответ на: комментарий от dmtrge

Секцию device убирай из конфига, xorg сам найдёт карты.

А потом гугли насчёт prime или bumblebee

irton ★★★★★ ()
Ответ на: комментарий от irton

А потом гугли насчёт prime или bumblebee

Но ведь это не optimus.

dmtrge ()
Ответ на: комментарий от dmtrge

Как узнал?

Ну тогда в device конкретно надо прописать адрес на шине для видеокарты. Типа там pci0.0.0.1 не помню точно

irton ★★★★★ ()
Ответ на: комментарий от dmtrge

не optimus

С чего взял? Такое делать давно перестали.

anonymous ()
Ответ на: комментарий от dmtrge

Ну вот и впиши его в секцию правильно, и все будет.

irton ★★★★★ ()
Ответ на: комментарий от irton

С иксового opengl kde стартует с разрешением 864х486, а от nvidia вообще не стартует.

dmtrge ()
Ответ на: комментарий от dmtrge

3D controller

А должно быть VGA controller. Не взлетит.

anonymous ()
Ответ на: комментарий от dmtrge

ну так ясно дело optimus во все поля жеж.

заводи для intel сначала, потом уже определишься с нвидией

irton ★★★★★ ()
Последнее исправление: irton (всего исправлений: 1)
Ответ на: комментарий от irton

Если удалить конфиг xorg, переключить eselect и в efi переключиться на intel, то все нормально работает.

dmtrge ()

В Gentoo Wiki написано, как запустить Optimus. Нужно использовать кастомный (не сгенерированный автоматически) файл xorg.conf, и внести правку в конфигурационный файл XDM, GDM, KDM, SDDM, LightDM или что там у тебя.

ZenitharChampion ★★★★★ ()
Ответ на: комментарий от ZenitharChampion

внести правку в конфигурационный файл XDM, GDM, KDM, SDDM

Как раз таки нужного мне sddm там нет

dmtrge ()
Ответ на: комментарий от dmtrge

Как раз таки нужного мне sddm там нет

/usr/share/sddm/scripts/Xsetup

Выполнил- черный экран.

eselect opengl set nvidia
anonymous ()
Ответ на: комментарий от irton
 /etc/X11/xorg.conf.d/20-nvidia.conf
Section "Module"
    Load "modesetting"
EndSection

Section "Device"
    Identifier "nvidia"
    Driver "nvidia"
    BusID "3:0:0"
    Option "AllowEmptyInitialConfiguration"
EndSection

В .xinitrc добавил

 xrandr --setprovideroutputsource modesetting NVIDIA-0
xrandr --auto
И eselect opengl set nvidia.

dmtrge ()
Ответ на: комментарий от dmtrge

Для sddm добавь команды xrandr в /usr/share/sddm/scripts/Xsetup. Да и еще проверь собран xrandr у тебя или нет.

anonymous ()
Вы не можете добавлять комментарии в эту тему. Тема перемещена в архив.