LINUX.ORG.RU

Срок поддержки macOS

 ,


0

2

Всем привет! Такой вот вопрос, на который гугл ответа не дал: каков средний срок поддержки одной версии macOS? Скажем Mavericks вышла в 2013. 3 года назад. Стоит ли юзать её или новое ПО поголовно требует последнюю версию макоси?

Когда-то стандартом была версия 10.6, в последнее время замечаю программы, поддерживающие 10.8+ (например, iTerm2).

Deleted ()

новое ПО поголовно требует последнюю версию макоси
Apple

Не намекает?

Стоит ли юзать её

Юзай генту/арч/macOS 10.last.

awesomebuntu ()
Ответ на: комментарий от fornlr

Mavericks уже официально всё.

Жаль, мне нравится эта версия. Ну, хоть 3 года. Я уже начал думать что они вообще рандомно объявляют о прекращении поддержки.

Sunderland93 ★★★★★ ()
Ответ на: комментарий от Sunderland93

к капитанскому виду быстро привыкаешь, а уже множество приложений не работает на 10.8, только йосемити+; но внешний вид внешним видом, капитан (но не дальше 10.11.3) загружается и работает существенно быстрее нежели всё, что было до того (я начал с 10.6, ранее не в курсе), система в разы отзывчивее, масса оптимизаций и прочего по сравнению с 10.8.

Мне тоже очень нравился маверик, пока я не попробовал капитан.

slon ()

Стоит ли юзать её или новое ПО поголовно требует последнюю версию макоси?

Все работает, ничего не тормозит, обновления до сих пор выходят. И Mavericks — это 10.9.

Jayrome ★★★★★ ()
Последнее исправление: Jayrome (всего исправлений: 1)
Ответ на: комментарий от fornlr

А что ровного на твоём скрине? По-моему от кед недалеко ушло. Но плоскота у них приятнее, ИМХО. Но самый красивый интерфейс, на мой взгляд, именно в Mavericks

Sunderland93 ★★★★★ ()
Ответ на: комментарий от Sunderland93

Слышал что Siera жутко кривой вышла. Это правда?

Нечего ставить то, к чему первый сервис пак не вышел (нет исключений)

10.12.0 - это просто пипец. Текущая 10.12.1 - почти нормально.

fornlr ★★★★★ ()
Ответ на: комментарий от Sunderland93

Мне сиерра с её политикой якобы безопасности не нужна, там и патч просто так не запустишь, куча проблем с установкой стороннего софта, короче еще тот адок от яблока.

Мне тяжело поверить, что какая-либо система будет работать лучше чем 10.11.3, я пожалуй останусь на ней, ее еще поддерживать будут долго.

slon ()
Ответ на: комментарий от slon

куча проблем с установкой стороннего софта

Ну-ка поясни, что там за ДичЪ? Теперь либра просто с пол-оборота не ставится? Или что?

bookman900 ★★★★★ ()

Согласно homebrew, выходит, что Apple поддерживает последние три версии. Т.е. после выхода 10.12 (Sierra) поддержка 10.9 (Mavericks) прекращена:

~ $ brew upgrade
Warning: You are using macOS 10.9.
We (and Apple) do not provide support for this old version.
You may encounter build failures or other breakages.
Please create pull-requests instead of filing issues.

Issue: Warning: You are using macOS 10.9

gag ★★★★★ ()

можно сидеть и на мавериксе, но иногда придется ограничиваться прошлыми/позапрошлыми версиями софта

waker ★★★★★ ()

Сейчас большинство ПО требуют 10.10-11

Deleted ()
Ответ на: комментарий от slon

но не дальше 10.11.3

А что дальше случилось? Не заметил никакой разницы.

Deleted ()
Ответ на: комментарий от bookman900

Ну видать речь об этом http://appleinsider.ru/mac-os-x/macos-sierra-ne-daet-ustanovit-prilozheniya-e...

Теперь либра

Разработчики LO являются «установленными» разработчиками. Поэтому с ними проблем нет.

Вообще проблема надумана, и разве что будет актуальна, если пользователь каждую неделю переставляет сомнительные программы с поррентов.

fornlr ★★★★★ ()
Ответ на: комментарий от fornlr

Вообще проблема надумана

Кстати, яббл в настольном магазине проявляет чудеса идиотизма. Тут и комиссия 30% и требования к софту и еще много разного. В общем мало там нужных программ, много чего даже бесплатного нужно руками скачивать. А вопрос такой: что сферическому разработчику/тестировщику может понадобиться, чего на новую макось не поставить из-за новой политики безопасности?

Lordwind ★★★★★ ()
Ответ на: комментарий от Lordwind

чего на новую макось не поставить из-за новой политики безопасности

Ну вообще поставится всё - только надо тупо затратить на это этак шесть кликов (сначала Ok, потом поход до раздел безопасностей в настройках) и ввести пароль

PS: для меня вообще ничего не поменялось, ибо я и раньше использовал настройку безопасности по середине

fornlr ★★★★★ ()
Последнее исправление: fornlr (всего исправлений: 2)
Ответ на: комментарий от fornlr

Ну вообще поставится всё - только надо тупо затратить на это этак шесть кликов (сначала Ok, потом поход до раздел безопасностей в настройках) и ввести пароль

эмм... это вы щас про что? разрешение ставить софт без подписи?

waker ★★★★★ ()
Ответ на: комментарий от fornlr

Типа у несертифицированных разработчиков софта хорошего нет или просто всем сертификаты раздали? Просто хочу ощутить пример, когда или кому нужен софт без подписи (сертификата).

Lordwind ★★★★★ ()
Последнее исправление: Lordwind (всего исправлений: 1)
Ответ на: комментарий от fornlr

чет не заметил. по-моему он это сам придумал

куча проблем с установкой стороннего софта,

я не заметил никаких изменений. что за проблемы?

waker ★★★★★ ()

Mavericks, несомненно, лучший macOS по дизайну. Ибо основывается на принципах того самого великого Стива Джобса. А после него уже начинаются эксперименты заднеприводного с плоскотой и детскими светофорами.

Но лучше юзать El Capitan сейчас. Всё течёт, всё меняется и актуальный софт начинает работать только с 10.10+ Only.

Но я до сих пор держу в виртуалочке Mavericks, ибо GUI там — оргазм для глаз.

EXL ★★★★★ ()
Ответ на: комментарий от slon

куча проблем с установкой стороннего софта

Примеры пожалуйста

Lordwind ★★★★★ ()
Ответ на: комментарий от Lordwind

Типа у несертифицированных разработчиков софта хорошего нет или просто всем сертификаты раздали?

И не то, и не то.

Я вот прям сейчас скачал MLE (совершенно левые, не имеют серитифкатов, хотя код открыт) и поставил http://www.equestriandreamers.com/downloads/game/ Да, потребуется несколько несложных действий, но не требуется же это постоянно.

fornlr ★★★★★ ()
Последнее исправление: fornlr (всего исправлений: 2)
Ответ на: комментарий от Lordwind

Просто хочу ощутить пример, когда или кому нужен софт без подписи (сертификата).

сертификаты выдаются за бабло. есть немало популярного софта без подписи. взять хоть тот же mercurial.

но ставится все элементарно.

waker ★★★★★ ()
Ответ на: комментарий от fornlr

Да, потребуется несколько несложных действий, но не требуется же это постоянно.

ага, нажать правый клик -> open -> OK это ппц как много действий...

waker ★★★★★ ()
Ответ на: комментарий от waker

Да, это и есть несколько несложных действий (хотя я чуть сложнее знал способ)

Ну вопросы к человку выше. Я так подумал что он хочет тупо одним кликом. (как это вообще отключить я кстате привел ссылку выше)

sudo spctl --master-disable

fornlr ★★★★★ ()
Ответ на: комментарий от waker

я не заметил никаких изменений

Вот последнюю строчку из гуев про «Хочу ставить что хочу» убрали https://twitter.com/alexmak/status/742519216323108864?ref_src=twsrc^tfw

ЗЫ: у тех кто обновлялся она могла остаться, и её самому можно включить (см. выше)

fornlr ★★★★★ ()
Последнее исправление: fornlr (всего исправлений: 1)
Ответ на: комментарий от fornlr

Если правая кнопка работает, то всё правильно сделали. Балбесы проверку отключат, а потом вирусы запускают.

Legioner ★★★★★ ()
Ответ на: комментарий от fornlr

правильно сделали, что убрали, потому что находились идиоты которые ее включали перманентно.

те, кому надо, давно знают, что защита от идиота обходится через контекстное меню.

waker ★★★★★ ()
Ответ на: комментарий от Sunderland93

Имхо Горный Лев лучше в этом плане.

Deleted ()

Как только выйдет срок поддержки macOS, переходи на Линукс, не позорься.

anonymous ()
Ответ на: комментарий от Legioner

Нельзя там просто так вирусы пускануть, их можно пустить и через правую кнопку. Просто решили подсадить на стор, где за блокнот за отдать 899 рублей, мля.

bookman900 ★★★★★ ()
Ответ на: комментарий от bookman900

Нельзя там просто так вирусы пускануть, их можно пустить и через правую кнопку.

Не очень понял мысль, но правой кнопкой догадаются пускать только опытные пользователи, которые предположительно знают, что делают, а глупые барашки потыкают левой, не смогут запустить и уйдут дальше читать контактик.

Просто решили подсадить на стор, где за блокнот за отдать 899 рублей, мля.

Пока правая кнопка работает — не решили. Когда решат — отключат все варианты. Но вряд ли смелости хватит.

Legioner ★★★★★ ()
Ответ на: комментарий от bookman900

Просто решили подсадить на стор, где за блокнот за отдать 899 рублей

Ага, распространенные сказки. Самая дорогая программа у меня SublimeText (блокнот, ага), и то она покупалась не в AppStore (в виду её отсутствия там), да и используется на мной на нескольких ПК с разными ОС (лицензия позволяет).

А в Apple Store заходишь с мыслью, ну ка чего бы полезного прикупить «За хороший продукт любых денег не жалко» - и с огнем чего то полезного трудно найти. Где-то наверно все купленные программы в Apple Store за несколько лет (Dropzone, DrawnStrips, DaisyDisk, наверно ещё парочку забыл) и будут стоить те самые 899 рублей.

anonymous ()
Ответ на: комментарий от fornlr

Боже, какое все розовенькое на скриншоте у вас, вы здоровы?)). А по поводу макоси, там совсем гайки завертели, как она нынче в продакшене? Ибо яблофонами я не пользуюсь со времен крутейшего 4s, но там софт не обновить, прям конвеером хе*ачат эти телефоны и говнооси к ним. Я с тех пор пересел на xperia z и проблем не знаю. Про макось тоже можно забыть, старые макбуки и десктопы еще могут работать? (я не слежу, если что, но надумывал прикупить себе макбук к новому году, актуально)

Rockon ()
Ответ на: комментарий от Deleted

Что-то сомневаюсь. Насколько я понимаю, нужно ещё платить $99 в год за «Apple Developer Program membership»

anonymous ()
Ответ на: комментарий от Rockon

старые макбуки и десктопы еще могут работать?

А как же. Новая macOS поддерживает железо этак 2010 года и далее.

У меня вот старичок 2013 года. Облизываюсь на новый макбук про, который даже по портавнивости с Air не так плохо выглядит. Тяжелее на 20 грамм, на 2 часа меньше работы от батареи. Вполне фапабельная модель вышла.

Но как-то старый работает пока. Хотя и ронял его много раз.

fornlr ★★★★★ ()
Последнее исправление: fornlr (всего исправлений: 1)
Ответ на: комментарий от fornlr

Вполне фапабельная модель вышла.

Говно.

Новая клавиатура — говно. Тачбар — ненужное говно. Магсейф убрали — стало большим говном. Памяти больше не подкинули — опять больше говна. Цену повысили — утопили в говне.

У меня вот старичок 2013 года.

Я планирую еще пяток лет на нем прожить.

anonymous ()
Ответ на: комментарий от fornlr

мне наплевать, если честно на эти 20 грамм и внешний вид, я раньше пользовался макосью по работе и многие вещи мне в ней нравились, макбук хочу - ибо линукс линуксом, но тратить время на допиливание ядра и ос, с последующим тестированием я не хочу, оно того не стоит (ну не с виндой же сидеть там). Беру его для деловых поездок и прочего, дабы все работало из коробки, ну и фотошопчиком, да играми побаловаться в поездках.

Rockon ()
Вы не можете добавлять комментарии в эту тему. Тема перемещена в архив.