LINUX.ORG.RU

конфликт версий  setuptools

 


0

2

При попытке запустить bin/pserve etc/openprocurement.api.ini
Получаю конфликт:

Traceback (most recent call last):
  File "bin/chaussette", line 93, in <module>
    sys.exit(chaussette.server.main())
  File "/var/www/openprocurement.buildout/eggs/chaussette-1.2-py2.7.egg/chaussette/server.py", line 151, in main
    app = paste_app(application.split(':')[-1])
  File "/var/www/openprocurement.buildout/eggs/chaussette-1.2-py2.7.egg/chaussette/_paste.py", line 25, in paste_app
    return loadapp('config:%s%s%s' % (os.path.abspath(path), hsh, app))
  File "/usr/lib/python2.7/site-packages/paste/deploy/loadwsgi.py", line 247, in loadapp
    return loadobj(APP, uri, name=name, **kw)
  File "/usr/lib/python2.7/site-packages/paste/deploy/loadwsgi.py", line 271, in loadobj
    global_conf=global_conf)
  File "/usr/lib/python2.7/site-packages/paste/deploy/loadwsgi.py", line 296, in loadcontext
    global_conf=global_conf)
  File "/usr/lib/python2.7/site-packages/paste/deploy/loadwsgi.py", line 320, in _loadconfig
    return loader.get_context(object_type, name, global_conf)
  File "/usr/lib/python2.7/site-packages/paste/deploy/loadwsgi.py", line 450, in get_context
    global_additions=global_additions)
  File "/usr/lib/python2.7/site-packages/paste/deploy/loadwsgi.py", line 559, in _pipeline_app_context
    APP, pipeline[-1], global_conf)
  File "/usr/lib/python2.7/site-packages/paste/deploy/loadwsgi.py", line 454, in get_context
    section)
  File "/usr/lib/python2.7/site-packages/paste/deploy/loadwsgi.py", line 476, in _context_from_use
    object_type, name=use, global_conf=global_conf)
  File "/usr/lib/python2.7/site-packages/paste/deploy/loadwsgi.py", line 406, in get_context
    global_conf=global_conf)
  File "/usr/lib/python2.7/site-packages/paste/deploy/loadwsgi.py", line 296, in loadcontext
    global_conf=global_conf)
  File "/usr/lib/python2.7/site-packages/paste/deploy/loadwsgi.py", line 328, in _loadegg
    return loader.get_context(object_type, name, global_conf)
  File "/usr/lib/python2.7/site-packages/paste/deploy/loadwsgi.py", line 620, in get_context
    object_type, name=name)
  File "/usr/lib/python2.7/site-packages/paste/deploy/loadwsgi.py", line 640, in find_egg_entry_point
    pkg_resources.require(self.spec)
  File "build/bdist.linux-x86_64/egg/pkg_resources.py", line 741, in require
    def require(self, *requirements):
  File "build/bdist.linux-x86_64/egg/pkg_resources.py", line 632, in resolve
    
pkg_resources.VersionConflict: setuptools 7.0 is installed but setuptools==8.0 is required by ['openprocurement.api']
судя из ошибки, ругается на то, что установлен setuptools, 7.0 а требуется 8.0, хотя установлен все же 8.0 Oo
[root@epu-sandbox openprocurement.buildout]# pip show setuptools
---
Metadata-Version: 2.0
Name: setuptools
Version: 8.0
Summary: Easily download, build, install, upgrade, and uninstall Python packages
Home-page: https://bitbucket.org/pypa/setuptools
Author: Python Packaging Authority
Author-email: distutils-sig@python.org
Installer: pip
License: PSF or ZPL
Location: /usr/lib/python2.7/site-packages

★★★

Думаю что у тебя каким-то образом оказалось два setuptools в системе.

Начни жизнь с чистого листа с virtualenv, если там заработает то ищи ошмётки setuptools 7 в системе.

true_admin ★★★★★ ()

Сноси весь setuptools и ставь заново, чисти все каталоги вручную после удаления системных пакетов. Потом ставь из пакетов, ставь pip, и уже им ставь библиотеки.

menangen ★★★★★ ()
Вы не можете добавлять комментарии в эту тему. Тема перемещена в архив.