LINUX.ORG.RU
ФорумAdmin

Ansible «pysphere module required»

 


0

1

При попытки по управлять ESXi, через Ansible вываливает «pysphere module required»

но

find / -name *pysphere*
/usr/local/lib/python2.7/dist-packages/pysphere-0.1.7-py2.7.egg-info
/usr/local/lib/python2.7/dist-packages/pysphere
/usr/local/lib/python3.4/dist-packages/pysphere-0.1.7-py3.4.egg-info
/usr/local/lib/python3.4/dist-packages/pysphere

без vsphere vcenter половина api и всего заблочено, например сферы нельзя бэкапы от вим юзать и ещё кучу всего, может и модуль для ансибл тоже заблочен?

erzenntd ()

может для работы ansible нужен vcenter? они любят всё блочить, всё таки ансибл иначе заменит кучу их дорого софта для управления

erzenntd ()
Ответ на: комментарий от erzenntd

ну я так понял, что pysphere - это просто либа для питона типо imap и тд. Ansible по ssh конекстится к ESXi, далее передает в pysphere переменные с *.yaml и что-то выполняет. Я это так понимаю.

ilovemoney ()
Ответ на: комментарий от erzenntd

щас поставлю проверю, просто ругается, что модуля нету, но он есть=(

ilovemoney ()
Вы не можете добавлять комментарии в эту тему. Тема перемещена в архив.