LINUX.ORG.RU

Не могу установить bitten-slave 0.7dev на openbsd и freebsd

 , ,


0

1

Не могу поставить bitten ни из svn, ни через easy_install (логи ниже), нет ли у кого идей? Рабочий Порт для Bitten 0.6 вижу, но мне нужен 0.7dev, а порты изучать не очень бы хотелось..

Логи от OpenBSD, в FreeBSD такие же ошибки.

easy_install-2.7 Bitten
....
File "/usr/local/lib/python2.7/site-packages/setuptools/package_index.py", line 475, in fetch_distribution
    return dist.clone(location=self.download(dist.location, tmpdir))
AttributeError: 'NoneType' object has no attribute 'clone'

cd bitten-trunk/ && python2.7 setup.py --without-master install
...
  File "/usr/local/lib/python2.7/site-packages/setuptools/command/egg_info.py", line 85, in finalize_options
    self.vtags = self.tags()
  File "/usr/local/lib/python2.7/site-packages/setuptools/command/egg_info.py", line 185, in tags
    ):  version += '-r%s' % self.get_svn_revision()
  File "/usr/local/lib/python2.7/site-packages/setuptools/command/egg_info.py", line 233, in get_svn_revision
    dirurl = data[0][3]
IndexError: list index out of range

Сообщать, что под *BSD никто ничего не собирает, не нужно.

★★★★★

--- setup.cfg~  2012-12-13 13:44:38.000000000 +0400
+++ setup.cfg   2012-12-13 13:59:34.000000000 +0400
@@ -1,6 +1,5 @@
 [egg_info]
 tag_build = dev
-tag_svn_revision = true
 
 [unittest]
 xml_output = build/test-results.xml
hizel ★★★★★ ()
Вы не можете добавлять комментарии в эту тему. Тема перемещена в архив.