LINUX.ORG.RU

Зачем в General, почему не в Development?

А?

Virtuos86 ★★★★★ ()

Забудь, руби слишком динамичен для нормального автокомплита. Да и зачем оно надо? Тренируй память, используй онлайн- документацию - у них там хороший быстрый поиск, используй отладочную консоль с irb/pry для исследования кода - там годный автокомплит.

anonymous ()

vim autocomplate ruby

плагин для вима для автокомплита под ruby/rails девелоп))

Сразу видно идиот. Рубисты видимо все такие.

Siado ★★★★★ ()
Последнее исправление: Siado (всего исправлений: 1)
Ответ на: комментарий от Siado

Сразу видно идиот.

Типа в vim нет автокомплита?)) Да, сразу видно.

special-k ★★★ ()
Ответ на: комментарий от special-k

гуглится

Рабисты умеют гуглить? Да еще на ангельском? Не думаю.

entefeed ☆☆☆ ()
Ответ на: комментарий от special-k

Как бы гуглится...

А что гуглится? Там только omnifunc. Это совсем уж примитивно. Может я что-то пропустил, и придумали таки умный автокомплит для руби?

Hjorn ()
Ответ на: комментарий от special-k

А тебе какое надо?

Как у жабакодеров )) Вимовский омни - это всего лишь дополнение по тегам. Ну он пытается конечно угадывать контекст как может, в основном же тупит и иногда подвисает. Нафиг надо. Я лучше в доках поищу, как анонимус предлагал.

Hjorn ()
Ответ на: комментарий от special-k

Типа в vim нет автокомплита?)) Да, сразу видно.

Типа куча ошибок и построение предложения уровня первого класса. Рабисты такие обезьянки которые считают это нормой.

Siado ★★★★★ ()
Ответ на: комментарий от Siado

А пистономакакам видимо от упоминания языка, который на голову выше пистона люто припекает, вот они и изливают желчь на все сообщество вражеского языка.

anonymous ()
Ответ на: комментарий от Siado

построение предложения уровня первого класса

«Речь уровня первоклассника» - ты, наверно, это пытался сказать?) Мне кажется, у меня, в первом классе речь была уровнем по-выше))

special-k ★★★ ()

Как выше отметили, на сегодняшний день нет ничего лучше связки neocomplete + vim-monster, но при этом конечно должен быть дополнительно установлен vim-ruby и vim-rails, + по желанию vim-rake, vim-bundler.

YCM для вима+руби — не нужен.

slon ()
Вы не можете добавлять комментарии в эту тему. Тема перемещена в архив.