LINUX.ORG.RU

Помогите, пожалуйста, разобраться с конфликтом при установке ebuild

 ,


0

1

А можно ли вообще разрешить этот конфликт при установке Rust:

alculate demas # emerge dev-lang/rust                            

Local copy of remote index is up-to-date and will be used.
Calculating dependencies... done!
[ebuild     U ~] sys-devel/llvm-3.6.0 [3.5.0] USE="multitarget*" 
[ebuild  N    ~] app-eselect/eselect-rust-0.3_pre20150428 
[ebuild  N    ~] dev-lang/rust-1.0.0_beta3  USE="system-llvm -clang -debug -doc -libcxx" 

!!! Multiple package instances within a single package slot have been pulled
!!! into the dependency graph, resulting in a slot conflict:

sys-devel/llvm:0

  (sys-devel/llvm-3.6.0:0/3.6::gentoo, ebuild scheduled for merge) pulled in by
    >=sys-devel/llvm-3.6.0[multitarget(-)] required by (dev-lang/rust-1.0.0_beta3:1.0/1.0::gentoo, ebuild scheduled for merge)
    ^^               ^^^^^                                                                                                                                                           

  (sys-devel/llvm-3.5.0:0/3.5::gentoo, installed) pulled in by
    >=sys-devel/llvm-3.3-r3:0/3.5=[abi_x86_32(-),abi_x86_64(-)] required by (media-libs/mesa-10.3.7-r1:0/0::gentoo, installed)
                           ^^^^^^^                                                                                                                                
    <sys-devel/llvm-3.6 required by (media-libs/mesa-10.3.7-r1:0/0::gentoo, installed)
    ^               ^^^                                                                                                                

Я правильно понимаю, что rust-у нужен llvm-3.6.0. А поставить llvm-3.6.0 нельзя, так как mesa требует llvm больше чем 3.3, но меньше, чем 3.6. Так ?

Это можно как то разрулить и Rust все таки поставить?

★★

либо раст либо меса

deity ★★★★ ()
Вы не можете добавлять комментарии в эту тему. Тема перемещена в архив.