LINUX.ORG.RU

драйвер для wi-fi адаптера broadcom

 ,


0

3

здравствуйте!ребят сразу скажу кто хочет по язвить не отвечайте...я только знакомлюсь с линуксом по этому прошу понимания...в познавательных целях установил kali...wi-fi нету...wi-fi адаптер broadcom bcm43142...проблема в установке драйвера на этот адаптер...устанавливал по этой статье http://www.http://www.sakryukin.ru/?module=articles&c=articles&b=6&a=17...скриншот терминала не могу здесь выложить/Снимок экрана от 2015-02-17 18:45:39.png

Ответ на: комментарий от alozovskoy

описание подробнее

вот по той ссылке что сверху по установке там всё доходчиво вроде написано но я где то делаю ошибку что ли....терминал выдаёт что E:не удалось найти пакет linux-headers-3.18.0-kali1-amd64 E:не удалось найти пакет по регулярному выражению linux-headers-3.18.0-kali1-amd64....этот драйвер я скачал распаковал и в домашнюю папку и в загрузки но при повторном установлении терминал пишет опять не удалось найти....я не знаю как здесь скрин шот выложить

andrey874 ()
Ответ на: описание подробнее от andrey874

E:не удалось найти пакет linux-headers-3.18.0-kali1-amd64

Это значит что пакетный менеджер не нашел хедеров (а без них драйвер не соберется) для твоего ядра, возможно из-за того, что твоя инструкция писалась под Debian, а у тебя все-таки немного другая система. Покажи вывод команд

uname -a

и

aptitude search linux-headers

я не знаю как здесь скрин шот выложить

Его нужно выложить на какой-нибудь сторонний хостинг картинок и тут в сообщении просто указать ссылку, но лучше скопировать результат выполнения команды из терминала и написать здесь (предварительно прочитай описание разметки, а то парсер все в кашу свалит) или на какой-нибудь pastebin выложить и сюда кинуть ссылку.

alozovskoy ★★★★★ ()
Ответ на: комментарий от alozovskoy

# aptitude search linux-headers v linux-headers - p linux-headers-2.6-amd64 - Header files for Linux amd64 configuration p linux-headers-3.2.0-4-all - All header files for Linux 3.2 (meta-packa p linux-headers-3.2.0-4-all-amd64 - All header files for Linux 3.2 (meta-packa i A linux-headers-3.2.0-4-amd64 - Header files for Linux 3.2.0-4-amd64 i A linux-headers-3.2.0-4-common - Common header files for Linux 3.2.0-4 p linux-headers-3.2.0-4-common-rt - Common header files for Linux 3.2.0-4-rt p linux-headers-3.2.0-4-rt-amd64 - Header files for Linux 3.2.0-4-rt-amd64 i A linux-headers-amd64 - Header files for Linux amd64 configuration p linux-headers-rt-amd64 - Header files for Linux rt-amd64 configurat root@kali:~#

andrey874 ()
Ответ на: комментарий от alozovskoy

могу сейчас повторить установку скопировать всё выложить

andrey874 ()
Ответ на: комментарий от andrey874

Ну я же просил прочитать про разметку.

Как ядро ставил? У тебя ядро из тестовой ветки, а хедеры - из стабильной.

alozovskoy ★★★★★ ()
Ответ на: комментарий от andrey874

File exists

Такой каталог уже есть значит, сначала нужно удалить.

Пока хедер не поставишь нет смысла что-то еще делать, без хедера драйвер не соберется

alozovskoy ★★★★★ ()
Ответ на: комментарий от andrey874

как удалить этот каталог

Ну уж с этим - в Google.

какой хедер нужно установить

Той же версии что и ядро. Ядро у тебя 3.18.0 amd64

alozovskoy ★★★★★ ()
Ответ на: комментарий от andrey874

Да, должен соответствовать. Нужно просто установить нужную версию.

Проверь в файле /etc/apt/sources.list должно быть что-то вроде

deb http://http.kali.org/kali kali main non-free contrib

Если что-то в этом файле изменяешь, то потом нужно выполнить

aptitude update

Дальше опять ищешь хедеры нужной версии (чтоб с ядром совпадали).

Вот еще «статья» на эту тему под твой Kali - http://pantuts.com/2013/03/14/how-to-install-kernel-headers/ .

alozovskoy ★★★★★ ()
Ответ на: этот подойдёт? от andrey874

Возможно подойдет, попробуй. Но точно с твоим ядром не совпадает, так что гарантий нет. В любом случае лишние пакеты ты всегда сможешь удалить.

Вообще почему именно этот дистрибутив выбрал?

alozovskoy ★★★★★ ()
Ответ на: комментарий от alozovskoy

первым делом я знаешь чего не пойму ну почему synaptic не находит пакетов которые я качаю и распаковываю

.........так ....разобраться хочу

andrey874 ()
Ответ на: комментарий от alozovskoy

/root/Downloads/linux-headers-3.18.0-kali1-all-amd64_3.18.3-1~kali4_amd64 (1).deb-вот один пакет.../root/Downloads/linux-headers-3.18.0-trunk-amd64_3.18-0tanglu1_amd64.deb-вот второй но почему то synaptic их не находит

andrey874 ()
Ответ на: комментарий от Deleted

ну как

я его начал но не закончил ....мне надо сначала начинать

andrey874 ()
Ответ на: комментарий от Deleted

что думаешь я не искал....ну ладно спасибо вам на сегодня всё перестаю усваивать

andrey874 ()
Ответ на: комментарий от andrey874

Потому что synaptic ищет в репозиториях, а если пакет руками скачал, то его нужно ставить так: dpkg -i путь_к_пакету (хотя может и в синаптик его как-то можно впихнуть, не знаю - не пользовался).

alozovskoy ★★★★★ ()
Вы не можете добавлять комментарии в эту тему. Тема перемещена в архив.