LINUX.ORG.RU

здравствуйте!

 , ,


0

2

ребят помогите кто понимает...я вроде на верном пути...но опять что то не так-где ошибка?суть проблемы установка драйвера на вай-фай адаптер ....устанавливаю по этой статье http://www.sakryukin.ru/?module=articles&c=articles&b=6&a=17 вроде всё толково написано но у меня опять где то ошибка... ну вообщем ввожу команду root@kali:~/build# apt-get install linux-headers-'uname -r' build-essential make wpasupplicant iw wavemon -y............терминал выдаёт что E:не удалось найти пакет linux-headers-3.18.0-kali1-amd64.....E:не удалось найти пакет по регулярному выражению <<linux-headers-3.18.0-kali1-amd64>....далее автор мне ответил-Доброго здоровья! Вам нужно подключить официальный репозиторий кали-линукс. Т.е. в файле /etc/apt/sources.list должны быть строки:

deb http://http.kali.org/kali kali main non-free contrib deb http://secu...li-security kali/updates main contrib non-free

Сохраните изменения и дайте команду apt-get update А за тем уже пробуйте ставить linux-headers..... и всё остальное по списку.....я внёс эти изменения ...терминал выдал-Получено 8 685 kБ за 47с (183 kБ/c) Чтение списков пакетов… Готово W: Не удалось получить http://secu...Release.gpg Не удалось найти IP-адрес для «secu...li-security»

W: Некоторые индексные файлы не скачались. Они были проигнорированы или вместо них были использованы старые версии. root@kali:~# посмотрите результат пожалуйста....но я всё же повторно решил попробовать установить...но на этапе распаковки ответ был такой- root@kali:~/build# tar -xvf hybrid-v35* tar: hybrid-v35*: Функция open завершилась с ошибкой: No such file or directory tar: Error is not recoverable: exiting now root@kali:~/build#

Ответ на: комментарий от andrey874

Ссылку на вики я дал, твой кали есть модифицированный дебиан. Там по русски, что не понятно — есть гугл. Пока не разберешься как работает ос хотя бы примерно и поверхностно, так и будешь тыркаться и пыркаться на ровном месте.

mandala ★★★★ ()
Последнее исправление: mandala (всего исправлений: 1)
Ответ на: комментарий от andrey874

Научись пользоваться знаками препинания и форумной разметкой текста!

intelfx ★★★★★ ()

здравствуйте!

досвидания. Научись выбирать правильный заголовок.

kali linux

зачем ты ставишь этот дистрибутив? Тыб про него хоть в вики почитал:

Предназначен прежде всего для проведения тестов на безопасность.

Во первых - это не дистрибутив для повседневной работы, а во вторых - он требует знаний в linux.

Deleted ()
Последнее исправление: nepank (всего исправлений: 1)
Ответ на: комментарий от andrey874

да я второй день на этой системе...

Я так понимаю, что ты не только второй день на Kali, но вообще второй день на Линуксе. Зачем ты выбрал Kali? Поставь себе Linux Mint и не мучайся с маргинальными дистрибутивами.

Вообще в этой статье не сказано главного: почему вообще нужно собирать этот драйвер из исходников?

Если у тебя не работает Wi-Fi, то лучше бы так и спросил: «Как заставить Wi-Fi-адаптер Broadcom работать под Kali Linux». И сказал бы, какой именно у тебя адаптер (что ты узнал из "lspci -nn"), работал ли он перед установкой, когда ты загрузился с LiveDVD, работал ли он под другими ОС или под другими дистрибутивами Linux (если ты пробовал его под ними использовать) и показал бы вывод команд

uname -a
и
lsb_release -a

proud_anon ★★★★★ ()
Ответ на: комментарий от proud_anon

Если у тебя не работает Wi-Fi, то лучше бы так и спросил: «Как заставить Wi-Fi-адаптер Broadcom работать под Kali Linux». И сказал бы, какой именно у тебя адаптер (что ты узнал из «lspci -nn»), работал ли он перед установкой, когда ты загрузился с LiveDVD, работал ли он под другими ОС или под другими дистрибутивами Linux (если ты пробовал его под ними использовать) и показал бы вывод команд

анон дело говорит

Deleted ()
Ответ на: комментарий от dhameoelin

ТС - безопасник.

наврятли. Но я хз, один фиг его псто не читал, ибо в мусоре из текста и консольного вывода рыться не хочу.

Deleted ()
Ответ на: комментарий от Deleted

наврятли.

Ну, почему же. Стереотипам соответствует.

Но я хз, один фиг его псто не читал, ибо в мусоре из текста и консольного вывода рыться не хочу.

Аналогично. Тем более, что это не первый его тред.

Я за бан ТС.

dhameoelin ★★★★★ ()

А вообще, спроси на форуме ксакеп ру - там должны быть серьёзные спецы в этом деле.

FedyaPryanichkov ★★ ()
Ответ на: комментарий от andrey874

Broadcom Corporation BCM43142 802.11b/g/n [14e4:4365] (rev 01)

Покажи вывод команд:

uname -a
lsb_release -a
dpkg-query -l 'linux-firmware*'
nmcli --pretty device list
Оберни вывод этих команд в тег [code] (а то читать будет невозможно), не забудь включить режим TeX Paragraphs (а то [code] не будет работать).

proud_anon ★★★★★ ()
Ответ на: комментарий от andrey874

сейчас сетей не видит на этой ос...понимаю что нужно установить драйвер

От «не видит сетей» до «нужно установить драйвер» дистанция как от Москвы до Питера, а до «нужно установить драйвер из исходников» — как до Нью-Йорка по поверхности.

proud_anon ★★★★★ ()
Ответ на: комментарий от proud_anon

root@kali:~# uname -a Linux kali 3.18.0-kali1-amd64 #1 SMP Debian 3.18.3-1~kali4 (2015-01-22) x86_64 GNU/Linux root@kali:~# lsb_release -a No LSB modules are available. Distributor ID: Kali Description: Kali GNU/Linux 1.1.0 Release: 1.1.0 Codename: moto root@kali:~# dpkg-query -l 'linux-firmware*' dpkg-query: шаблону linux-firmware* не соответствует ни один пакет root@kali:~# nmcli --pretty device list Ошибка: неизвестный объект «device». Попробуйте выполнить «nmcli help». root@kali:~#

andrey874 ()
Ответ на: комментарий от andrey874

БЛДЖАД!!!

root@kali:~# uname -a Linux kali 3.18.0-kali1-amd64 #1 SMP Debian 3.18.3-1~kali4 (2015-01-22) x86_64 GNU/Linux 

root@kali:~# lsb_release -a No LSB modules are available. Distributor ID: 
Kali Description: Kali GNU/Linux 1.1.0 
Release: 1.1.0 
Codename: moto 

root@kali:~# dpkg-query -l 'linux-firmware*' 
dpkg-query: шаблону linux-firmware* не соответствует ни один пакет 

root@kali:~# nmcli --pretty device list 
Ошибка: неизвестный объект «device». Попробуйте выполнить «nmcli help». 

root@kali:~#

Я за andrey874

mandala ★★★★ ()
Последнее исправление: mandala (всего исправлений: 2)
Ответ на: комментарий от andrey874

глаза уже не видят

Какое удивительное явление: посты ТСа настолько вырвиглазные, что у него самого глаза уже не видят

...хотя это, в целом, понятно. Либо ты настолько слепой, что не видишь, какие у тебя вырвиглазные посты, либо это карма.

шаблону linux-firmware* не соответствует ни один пакет

Да, я забыл, что в Debian это называется, скорее всего, firmware-linux-nonfree. Хотя в Kali могут вообще по-другому поставлять ядро.

nmcli --pretty device list Ошибка: неизвестный объект «device». Попробуйте выполнить «nmcli help».

Вот это совсем странно. Может, на старой версии nmcli это по-другому было... Попробуй 'nmcli dev list' или 'nmcli d list'

proud_anon ★★★★★ ()
Ответ на: комментарий от andrey874

А теперь сравни свой выхлоп и то что я причесал? Разницу видишь? А всего надо было поставить перед выхлопом [code] и после [/code]. Сложно?

С таким отношением к форумчанам ты вызываешь лишь раздражение, а никак не желание тебе помочь.

mandala ★★★★ ()
Последнее исправление: mandala (всего исправлений: 1)
Ответ на: комментарий от Deleted

а во вторых - он требует знаний в linux.

не более чем любой другой линукс

или если нет, давай ответь за базар, что там такого «не такого», что нужно иметь знания линукса более чем в дебиане или арче

stevejobs ★★★★☆ ()
Ответ на: комментарий от proud_anon

Поставь себе Linux Mint

чем Linux Mint отличается от Debian, Ubuntu или Kali?

красивыми обоями зелеными? вот это что ли знания линукса - знание как поставить зеленые обои?

просто песец какой-то, ЛОР превратился в сообщество для блондинок, ради обоев другой дистр рекомендуют

stevejobs ★★★★☆ ()
Ответ на: комментарий от stevejobs

Я сейчас сходил на их сайт и поржал с документации для новичков: по одному убогому примеру: а что, почему и как вообще не освящается. Если реальная ситуация отличается от типовой из инструкции, пользователь теряется и даже не знает что почитать для решения задачи.

Намного полезней дока от того же дебиана, но она же подробная, скучная и без веб2.0, картинок и прочих ништяковв.

mandala ★★★★ ()
Последнее исправление: mandala (всего исправлений: 1)
Ответ на: комментарий от stevejobs

чем Linux Mint отличается от Debian, Ubuntu или Kali?

От Debian и Kali — тем же, чем Ubuntu. От Ubuntu — наличием Cinnamon (в Убунте он теперь есть, но через жопу) и MATE. Ну а также присутствием в стандартной сборке различных компонентов, которые в Убунту боятся включать по умолчанию из-за особенностей законодательства США. И нового набора фортунок.

proud_anon ★★★★★ ()
Последнее исправление: proud_anon (всего исправлений: 1)
Ответ на: комментарий от proud_anon

имхо вот что важно - иметь доступ к интернету и консоль (терминал с табами). И мочь вызывать из нее нужные проги. Всякие john the reaper, aircrack, reaver, итп Нужно какое-нибудь иксовое DE (совершенно неважно какое) с браузером, чтобы запускать гуёвый Wireshark, OWASP ZAP, Metasploit, итп, тысячи их

вот это - компоненты, «присутствие которых в стандартной сборке» действительно нужно.

можно вообще коннектиться к серверу с линуксом из винды, и тогда из «гуевого» софта нужен только Putty. Но тут будут проблемы с иксовыми программами типа Ваершарка. Метасплойт например с веб-интерфейсом, можно и по сети открыть.

еще для новичка нужны разумные туториалы в интернете, как этим всем пользоваться. Чтобы даже если ты ничего не знаешь, мог копипастом накопипастить рабочее решение.

часть из этого софта нужно предварительно настраивать, и нужно иметь разумные дефолты. Кое-какое говнецо (встречаемое в туториалах) такое древнее, что его вообще пришлось бы собирать из исходников. Чтобы сразу начинать пользоваться, а не тратить месяц на настройку. Если среди ночи тебя разбудят и попросят покопаться с проблемой, чтобы ты мог как автомат калашникова за 25 секунд собрать-разобрать ноут с комплектом софта.

а всякие Cinnamon, Mate, несвободные кодеки и прочая муть нафиг не нужна, вместе с законодательством США (которое мы вообще-то собираемся грубо нарушать совершенно по всем пунктам какие там есть xD).

Выбирать дистрибутив из-за свистелок-перделок (и зеленых обоев) вместо важных вещей, это имхо какое-то ССЗБ

stevejobs ★★★★☆ ()
Последнее исправление: stevejobs (всего исправлений: 1)
Ответ на: комментарий от mandala

так Kali это и есть дебиан визи с дополнительными пакетами, не? xD

нужны инструкции - гугли инструкции сначала к кали, не нашел - к дебиану

на это какбе красноречиво намякивает содержимое репозитория: http://http.kali.org/kali/dists/

там даже где-то firmware-linux-nonfree лежит, который proud_anon советовал, точный путь лень искать

stevejobs ★★★★☆ ()
Последнее исправление: stevejobs (всего исправлений: 1)
Ответ на: комментарий от stevejobs

Всякие john the reaper, aircrack, reaver, итп Нужно какое-нибудь иксовое DE (совершенно неважно какое) с браузером, чтобы запускать гуёвый Wireshark, OWASP ZAP, Metasploit, итп, тысячи их

Если речь о дистре для безопасников, то может быть. Но зачем ТСу именно Kali, никто не знает. Я думаю, даже ТС. Петруччо занял телеграф и не знал об этом. Петруччо не мог понять, зачем он занял его, пока ему не сказал Ежи.

еще для новичка нужны разумные туториалы в интернете, как этим всем пользоваться. Чтобы даже если ты ничего не знаешь, мог копипастом накопипастить рабочее решение.

Так «ничего не знаешь» или «john the ripper, aircrack, reaver и т.п.»?

а всякие Cinnamon, Mate, несвободные кодеки и прочая муть нафиг не нужна

Да, конечно, окружение рабочего стола — это совершенно неважный компонент дистрибутива, плюнуть и растереть, как обои фактически...

proud_anon ★★★★★ ()
Ответ на: комментарий от proud_anon

Так «ничего не знаешь» или «john the ripper, aircrack, reaver и т.п.»?

ну так надо же человеку с чего-то начинать? Обычные некрасноглазые люди ставят Линукс как запускалку вполне конкретных программ, а не потому что захотелось потрахаться с линуксом. Чтобы изучить какую-то конкретную тему. Он не будет изучать, как играть в линуксе музыку или читать книжки, всё это совершенно нафиг не нужно. Для фильмов и книжек можно вообще винду поставить. Гораздо важнее, например, разобраться как разломать необновленный апач+пхп к чертям готовыми эксплоитами (пока сам не умеешь ничего - надо пользоваться готовым). Ты точно уверен, что замена Kali на Debian ему действительно поможет? Что туториалов «как ломать форум Invision Power Board» для Debian в сети намного больше, чем для какого-то другого дистра, что они дистроспецифичные?

Если речь о дистре для безопасников, то может быть.

хм, ты думаешь что человек так упорствует совершенно без цели? может быть. но тогда это не лору, это к психиатру

stevejobs ★★★★☆ ()
Последнее исправление: stevejobs (всего исправлений: 1)
Ответ на: комментарий от mandala

Я знаю что такое кали. А вот ТС не знает. И именно я его отправил в дебиановские доки.

Ты его другие темы смотрел?

Он либо из тех тендерных мартышек, которые, например, обслуживают «очень серьёзное» железо у наших безов, либо идиот. Впрочем, в первом случае он тоже не гений.

dhameoelin ★★★★★ ()
Ответ на: комментарий от dhameoelin

Да видел. У меня надежда что это просто школьник, решивший осилить линукс с наскока.

mandala ★★★★ ()

Ты просто зря тратишь время, у блобов от broadcom нет ap, не injection.
А если тебе просто, нужен рабочий Wi-Fi то лучше пользоваться другим дистрибутивом.
Если что, то вот тебе линк на firmware: http://www.lwfinger.com/b43-firmware/

anonymous_sama ★★★★★ ()
Последнее исправление: anonymous_sama (всего исправлений: 1)

господи, да поставь ты себе ubuntu и не мучайся уже...

krang ★★ ()
Ответ на: комментарий от dhameoelin

Вангую, что ТС - безопасник.

По мне так школьник. Тоже неплохо.

turtle_bazon ★★★★★ ()

Шокирующий и удивляющий LOR

Deleted ()
Ответ на: комментарий от dhameoelin

ТС - безопасник

И рядом не валялось.

Deleted ()
Ответ на: комментарий от Deleted

зачем ты ставишь этот дистрибутив?

да его выложили на каком-то хацкерском сайте, с обещанием любому ХСВ. Вот и лезут как тараканы. Можешь заигнорить тег. Мне интересно, попадается смешная еда.

Приятного аппетита, мои зелёные друзья.

emulek ()

детка, хочешь ХСВ?

1. поставь убунту

2. поставь aircrack-ng

3. если не осилил, пиши сюда, тему назови «Помогите протестировать мой WiFi на вопрос безопасности».

emulek ()
Вы не можете добавлять комментарии в эту тему. Тема перемещена в архив.