LINUX.ORG.RU

Отсутсвуют пакеты в репозиториях Debian Wheezy


0

1

Вторая неприятность уже с тех пор как перешёл на Wheezy. Сначала обнаружил, что в репозитории нет acroread, теперь что wine-bin. Или они есть, но собраны не под ту платформу. У меня amd64. Подскажите, что делать, мне нужет Adobe Reader и Wine. Вот мой source.list

## Репозитории Debian
deb ftp://linux.nsu.ru/debian/ wheezy main contrib non-free
deb-src ftp://linux.nsu.ru/debian/ wheezy main contrib non-free
deb ftp://linux.nsu.ru/debian/ wheezy-updates main contrib non-free
deb-src ftp://linux.nsu.ru/debian/ wheezy-updates main contrib non-free
deb ftp://linux.nsu.ru/debian/ wheezy-proposed-updates main contrib non-free
deb-src ftp://linux.nsu.ru/debian/ wheezy-proposed-updates main contrib non-free
deb ftp://linux.nsu.ru/debian-security/ wheezy/updates main contrib non-free
deb-src ftp://linux.nsu.ru/debian-security/ wheezy/updates main contrib non-free
deb ftp://linux.nsu.ru/debian-marillat/ wheezy main non-free
deb-src ftp://linux.nsu.ru/debian-marillat/ wheezy main non-free

# Дополнительные репозитории
deb http://qt-kde.debian.net/debian/ experimental-snapshots main
deb http://deb.opera.com/opera/ wheezy non-free
deb http://qutim.org/debian/wheezy/ wheezy main

★★★★★

amd64

Wine

ставится через мультилиб, при первом запуске wine он пишет что нужно сделать

lazyklimm ★★★★★ ()

у тебя вижу только non-free... это вроде бы не нормально. щас гляну, что у меня

i_gnatenko_brain ★★★★ ()

Вот у меня на сервере:

deb http://mirror.yandex.ru/debian/ squeeze main non-free contrib
deb-src http://mirror.yandex.ru/debian/ squeeze main non-free contrib
deb http://mirror.yandex.ru/debian squeeze-proposed-updates main contrib non-free
deb http://mirror.yandex.ru/debian squeeze-updates main contrib non-free
deb http://security.debian.org/ squeeze/updates main contrib non-free
#deb-src http://security.debian.org/ lenny/updates main contrib non-free
deb http://download.webmin.com/download/repository sarge contrib
deb http://backports.debian.org/debian-backports squeeze-backports main
saturn:~# aptitude show wine
Пакет: wine                                      
Состояние: не установлен
Версия: 1.0.1-3.1
Приоритет: необязательный
Раздел: otherosfs
Сопровождающий: Debian Wine Party <pkg-wine-party@lists.alioth.debian.org>
Размер в распакованном виде: 98,3 k
Зависимости: wine-bin (= 1.0.1-3.1), wine-utils (= 1.0.1-3.1), libwine-alsa (= 1.0.1-3.1) | libwine-oss (= 1.0.1-3.1) | libwine-esd (= 1.0.1-3.1) |
                        libwine-jack (= 1.0.1-3.1) | libwine-nas (= 1.0.1-3.1), libwine-gl (= 1.0.1-3.1), libwine-print (= 1.0.1-3.1), libwine-sane (=
                        1.0.1-3.1), libwine-cms (= 1.0.1-3.1), libwine-gphoto2 (= 1.0.1-3.1), libwine-ldap (= 1.0.1-3.1)
Рекомендуются: ttf-liberation
Предлагаются: wine-doc, binfmt-support, ttf-mscorefonts-installer, winbind, avscan | klamav | clamav
Описание: реализация API Windows (стандартный комплект)
 Это свободная реализация API MS-Windows. Работа над этим проектом ещё ведётся, поэтому многие приложения могут не работать. 
 .
 Этот фиктивный пакет, он зависит от стандартных компонент Wine.
Сайт: http://www.winehq.org/

i_gnatenko_brain ★★★★ ()
Последнее исправление: i_gnatenko_brain (всего исправлений: 1)

Насчет acroread не уверен, вайн только под i386.

sudo dpkg --add-architecture i386 && sudo aptitude update && sudo aptitude install wine

leave ★★★★★ ()
deb [arch=i386,amd64] ftp://linux.nsu.ru/debian/ wheezy main contrib non-free

и та команда что выше написали

sudo dpkg --add-architecture i386 && sudo aptitude update && sudo aptitude install wine

maloi ★★★★★ ()
Ответ на: комментарий от i_gnatenko_brain

i_gnatenko_brain, у тебя sqeeze, а у меня wheezy. Если бы не эта разница, то и вопроса бы не было.

lazyklimm, да пишет при первом запуске wine:

** Debian / Wine: Multiarch Instructions **

This is the wine64-bin helper package, which does not provide wine itself,
but instead exists solely to provide the following information about
enabling multiarch on your system in order to be able to install and run
the 32-bit wine packages.

The following commands should be issued as root or via sudo in order to
enable multiarch (the last command installs 32-bit wine):

  # dpkg --add-architecture i386
  # apt-get update
  # apt-get install wine-bin:i386

Be very careful as spaces matter above.  Note that this package
(wine64-bin) will be removed in the process.  For more information on
the multiarch conversion, see: http://wiki.debian.org/Multiarch/HOWTO

(okay)
Во первых, я использую не apt-get, а aptitude, во вторых что произойдёт после «dpkg --add-architecture i386» У меня архитектура изменится на i386, а amd64 больше не будут устанавливаться?

sunny1983 ★★★★★ ()
Последнее исправление: sunny1983 (всего исправлений: 2)
Ответ на: комментарий от sunny1983

Во первых, я использую не apt-get, а aptitude

кто мешает использовать apt-get?

во вторых что произойдёт после «dpkg --add-architecture i386»

читай документацию

и вообще, прекращай уже глупые вопросы задавать

lazyklimm ★★★★★ ()
Ответ на: комментарий от lazyklimm

читай документацию

--add-architecture architecture Add architecture to the list of architectures for which packages can be installed without using --force-architecture. The architecture dpkg is built for (i.e. the output of --print-architecture) is always part of that list.

В теме, на которую вы ссылку дали, написано про помойку пакетов. Это как-то на стабильность повлияет? amd64 будет иметь больший приоретет или обе архитектуры будут без приоретета?

sunny1983 ★★★★★ ()
Последнее исправление: sunny1983 (всего исправлений: 1)
Ответ на: комментарий от sunny1983

dpkg --add-architecture i386 - apt перестанет ругаться на неподходящую архитектуру.

Programmist11180 ★★★ ()

sunny1983

Вроде взрослый дядька, а словно ребенок.

anonymous ()
Вы не можете добавлять комментарии в эту тему. Тема перемещена в архив.