LINUX.ORG.RU

проблема после обновления libreoffice

 ,


0

1

менеджер обновлений радостно выдает:

Следующие пакеты имеют неудовлетворённые зависимости:

libreoffice-base: Depends: libreoffice-base-core (= 1:4.3.0-0ubuntu1~precise1) но 1:4.3.2~rc2-0ubuntu1~precise2 уже установлен
                  Depends: libreoffice-base-drivers (= 1:4.3.0-0ubuntu1~precise1) но 1:4.3.2~rc2-0ubuntu1~precise2 уже установлен
                  Depends: libreoffice-core (= 1:4.3.0-0ubuntu1~precise1) но 1:4.3.2~rc2-0ubuntu1~precise2 уже установлен
libreoffice-base-drivers: libreoffice-core: 

что делать и как жить дальше?

Ответ на: комментарий от Suntechnic

не могу ждать, нужно срочно работать работу в нем.
мб как-то таки можно снести этот, и поставить что-то стабильное?
(штатными методами не выходит)

MinasFilm ()
Ответ на: комментарий от MinasFilm

Ты не можешь откатить libreoffice-base-core на версию назад? Нет в репах уже? Посмотри в кэше apt. Поставь Synaptic - там через гуй удобно версиями рулить.

Suntechnic ★★★★★ ()
Ответ на: комментарий от MinasFilm

Кстати, если из-за этого не работает у тебя что-то, почему бы просто не снести libreoffice-base? Он же по сути нахрен не нужен.

Suntechnic ★★★★★ ()
Ответ на: комментарий от Suntechnic

сейчас я вообще не могу снести ни часть либрыофиса, ни весь целиком - кажет ошибку
буду рад идеям в этом деле

MinasFilm ()
Ответ на: комментарий от Suntechnic

вот сейчас буквально синаптиком отбрал по фильтру пакеты с ошибками - показало 3 кука либры
выделил все, удалить целиком - долго тупило, потом выдало:
E: libreoffice-base: подпроцесс установлен сценарий post-removal возвратил код ошибки 2

MinasFilm ()
Ответ на: комментарий от petrosyan
maestro@meniac:~$ sudo apt-get -f install
[sudo] password for maestro: 
Чтение списков пакетов… Готово
Построение дерева зависимостей        
Чтение информации о состоянии… Готово
Следующие пакеты устанавливались автоматически и больше не требуются:
  wireless-regdb iw libhsqldb-java liborcus-0.6-0 crda libservlet2.5-java
Для их удаления используйте «apt-get autoremove».
Пакеты, которые будут УДАЛЕНЫ:
  libreoffice-base
обновлено 0, установлено 0 новых пакетов, для удаления отмечено 1 пакетов, и 131 пакетов не обновлено.
не установлено до конца или удалено 1 пакетов.
После данной операции, объём занятого дискового пространства уменьшится на 7 234 kB.
Хотите продолжить [Д/н]? д 
(Чтение базы данных ... на данный момент установлено 290769 файлов и каталогов.)
Удаляется пакет libreoffice-base ...
Нет отклонения «отклонение /usr/lib/libreoffice/share/basic/dialog.xlc в /usr/lib/libreoffice/share/basic/dialog.xlc.noaccess из-за libreoffice-base», ничего не удалено.
Нет отклонения «отклонение /usr/lib/libreoffice/share/basic/script.xlc в /usr/lib/libreoffice/share/basic/script.xlc.noaccess из-за libreoffice-base», ничего не удалено.
/var/lib/dpkg/info/libreoffice-base.postrm: 31: /var/lib/dpkg/info/libreoffice-base.postrm: Syntax error: end of file unexpected (expecting "fi")
dpkg: не удалось обработать параметр libreoffice-base (--remove):
 подпроцесс установлен сценарий post-removal возвратил код ошибки 2
Отчёты apport не записаны, так достигнут MaxReports
                                                   При обработке следующих пакетов произошли ошибки:
 libreoffice-base
E: Sub-process /usr/bin/dpkg returned an error code (1)

что дальше?

MinasFilm ()
Ответ на: комментарий от petrosyan

Тут один -f сделал, уже за три сотни сообщений накалякали...

greenman ★★★★★ ()
Ответ на: комментарий от greenman

llibreoffice-still в этих ваших убунтах не водится?

что имеется в виду? стабильный релиз?
ну вообще в оф.репах идет более старая версия, но я добавлял источники для самой свежей
а теперь ни починить, ни удалить...

MinasFilm ()
Ответ на: комментарий от greenman

а какой смысл?
насколько понимаю, проблема в том, что невозможно удалить пакеты из системы, а не в плохих их источниках...
тем более - почти год работаю с ними, обновляюсь и все такое - полет нормальный был

MinasFilm ()
Ответ на: комментарий от MinasFilm

что дальше?

снова набрать команду нажать «нет» и посмотреть предложит ли апт другие варианты. По идее он должен предложить вариант снести все пакеты от либры.

petrosyan ★★★★★ ()
Вы не можете добавлять комментарии в эту тему. Тема перемещена в архив.