LINUX.ORG.RU

Как правильно настроить PPPoE соединение и его мониторинг в OpenWRT?

 , , ,


0

1

Привет всем! Опишу схему своего подключения к сети: ПК > Роутер TP-Link 740 > ADSL-модем D-Link DSL-2500U/BRU/D (в режиме моста) > Инет.

Прошил роутер (tp-link 740) в openwrt и столкнулся с проблемой поднятия PPPoE-сессии. Конфиг network:

config interface 'loopback'
	option ifname 'lo'
	option proto 'static'
	option ipaddr '127.0.0.1'
	option netmask '255.0.0.0'

config interface 'lan'
	option ifname 'eth0'
	option type 'bridge'
	option proto 'static'
	option ipaddr '192.168.1.1'
	option netmask '255.255.255.0'

config interface 'wan'
	option _orig_ifname 'eth1'
	option _orig_bridge 'false'
	option ifname 'eth1'
	option proto 'pppoe'
	option username 'username'
	option password 'pass'

config interface 'local'
	option proto 'static'
	option ifname 'eth1'
	option ipaddr '10.0.0.2'
	option netmask '255.255.255.0'

config switch
	option name 'eth0'
	option reset '1'
	option enable_vlan '1'

config switch_vlan
	option device 'eth0'
	option vlan '1'
	option ports '0 1 2 3 4'

Проблема состоит в том, что с такими настройками, PPPoE-соединение автоматически не устанавливалось (точнее устанавливалось, но очень-очень редко) и мне приходилось делать «ifup wan». Добавил «ifup wan» в автозагрузку, но этого оказалось недостаточно, т. к. при обрыве связи, PPPoE-соединение самостоятельно не переподключалось... Нашел на этом форуме следующий скрипт:

#!/bin/sh
    if ! ping -q -c 1 -W 10 8.8.8.8 > /dev/null; then
        (ifdown wan; sleep 10; ifup wan) &
    fi
Настроил cron на запуск скрипта каждые 2-е минуты и вроде бы все наладилось. Избавился от ifup`a и радовался жизни до тех пор, пока не включил μTorrent((( Торрент-клиент настолько сильно загружает канал, что пакеты не доходят к/с 8.8.8.8 и скрипт «начинает думать», что связь пропадает, после чего сам же её и рвет. Менял значение опции "-c" (из скрипта) с 1 на 5, но это не дало положительного результата.

Прошу подсказать, как заставить pppd «дозваниваться» к провайдеру до момента установки соединения и в случае, если установленное соединение разорвано, возобновить «дозвон»?

P.S. В linux`е я почти не разбираюсь.

PPPoE-соединение автоматически не устанавливалось (точнее устанавливалось, но очень-очень редко)

Настрой из гуя. По дефолту норм работает. Если не понятно почему рвется, то обратись к прову с просьбой узнать из лога радиуса причину разрыва сессии (AcctTerminate Cause). Может у тебя кстати железо кривое (модем/роутер/патчкорд между ними/сырые прошивки) или у прова железо косячит. Еще попробуй pppoe прямо с модема поднять и посмотри на результат.

andrew667 ★★★★★ ()
Последнее исправление: andrew667 (всего исправлений: 1)
Ответ на: комментарий от andrew667

Настраивал как раз из «гуя» и по дефолту - сессия при включении маршрутизатора подымается редко, а при обрыве вообще не подымается (ждал по 15-20 мин.) По вине провайдера сессия не рвалась еще ни разу (обрывы я симулирую выдергиванием шнурка из роутера). Так что в логах у прова только user request`ы и порт error`ы:). С модема PPPoE не вариант, т.к. он (модем) в режиме маршрутизатора и при запущенном торрент-клиенте начинает «захлебываться» уже на 6-10 Mbps (ну вот такой он у меня старичок). P.S. В μTorrent`е стоит стандартное значение в 200 соединений (это так, для справки).

Myr4ik ()

Если увеличить значение параметра "-с" до 10-20, чтобы скрипт выглядел так:

#!/bin/sh
    if ! ping -q -c 20 -W 10 8.8.8.8 > /dev/null; then
        (ifdown wan; sleep 10; ifup wan) &
    fi
Это может помочь? Будет ли это значить, что при отправке 20-и пакетов на 8.8.8.8 и получении в ответ хотя бы 1-го, соединение будет считаться активным?

Myr4ik ()
Ответ на: комментарий от Myr4ik

С модема PPPoE не вариант

Тебе надо понять почему сессия не поднимается и/или рвется, а не костылями заниматься. Делай в общем что хочешь. Я все рассказал. К провайдеру ты не обращался. С других устройств pppoe не поднимал. И никаких «порт error» в логах радиуса нет.

andrew667 ★★★★★ ()
Ответ на: комментарий от andrew667

К провайдеру я обращался. Сессии действительно рвутся с user request`ами (в момент, когда я перезагружаю роутер программно) и port erorr`ами (когда просто дергаю шнурок). Попробую поставить wireshark на виндовую машину и посмотреть, какие, а главное сколько запросов идет с wan-порта роутера в момент включения.

Myr4ik ()
Ответ на: комментарий от andrew667

lost carrier

И так связался с провайдером и попросил помониторить запросы на моем порту. Сбросил настройки в OpenWRT, настроил PPPoE соединение в гуи по новой.

При обычной загрузке роутера (витая пара НЕ подключена в adsl модем) в логах роутера появляются записи:

Jul 25 09:04:20 OpenWrt daemon.info pppd[2415]: Plugin rp-pppoe.so loaded.
Jul 25 09:04:20 OpenWrt daemon.info pppd[2415]: RP-PPPoE plugin version 3.8p compiled against pppd 2.4.5
Jul 25 09:04:20 OpenWrt daemon.notice pppd[2415]: pppd 2.4.5 started by root, uid 0
Jul 25 09:04:35 OpenWrt daemon.warn pppd[2415]: Timeout waiting for PADO packets
Jul 25 09:04:35 OpenWrt daemon.err pppd[2415]: Unable to complete PPPoE Discovery
Jul 25 09:04:35 OpenWrt daemon.info pppd[2415]: Exit.
Jul 25 09:04:35 OpenWrt daemon.notice netifd: Interface 'wan' is now down
Jul 25 09:04:36 OpenWrt daemon.info pppd[2565]: Plugin rp-pppoe.so loaded.
Jul 25 09:04:36 OpenWrt daemon.info pppd[2565]: RP-PPPoE plugin version 3.8p compiled against pppd 2.4.5
Jul 25 09:04:36 OpenWrt daemon.notice pppd[2565]: pppd 2.4.5 started by root, uid 0
Jul 25 09:04:51 OpenWrt daemon.warn pppd[2565]: Timeout waiting for PADO packets
Jul 25 09:04:51 OpenWrt daemon.err pppd[2565]: Unable to complete PPPoE Discovery
Jul 25 09:04:51 OpenWrt daemon.info pppd[2565]: Exit.
Jul 25 09:04:51 OpenWrt daemon.notice netifd: Interface 'wan' is now down
Jul 25 09:04:51 OpenWrt daemon.info pppd[2619]: Plugin rp-pppoe.so loaded.
Jul 25 09:04:51 OpenWrt daemon.info pppd[2619]: RP-PPPoE plugin version 3.8p compiled against pppd 2.4.5
Jul 25 09:04:51 OpenWrt daemon.notice pppd[2619]: pppd 2.4.5 started by root, uid 0
После этого, подключаю провод из роутера в модем и наблюдаю следующую картину:
Jul 25 09:06:08 OpenWrt daemon.info pppd[669]: RP-PPPoE plugin version 3.8p compiled against pppd 2.4.5
Jul 25 09:06:08 OpenWrt daemon.notice pppd[669]: pppd 2.4.5 started by root, uid 0
Jul 25 09:06:08 OpenWrt kern.info kernel: [  335.370000] eth1: link up (100Mbps/Full duplex)
И все, в логах тишина... Сессия не поднялась и судя по всему больше не пытается подняться.

Провайдер в этот момент тоже не видит никакой активности на моем порту. Делаю несколько раз «ifup wan» и в логе появляется:

Jul 25 09:10:31 OpenWrt daemon.info pppd[2252]: Plugin rp-pppoe.so loaded.
Jul 25 09:10:31 OpenWrt daemon.info pppd[2252]: RP-PPPoE plugin version 3.8p compiled against pppd 2.4.5
Jul 25 09:10:31 OpenWrt daemon.notice pppd[2252]: pppd 2.4.5 started by root, uid 0
Jul 25 09:10:31 OpenWrt daemon.info pppd[2252]: PPP session is 52502
Jul 25 09:10:31 OpenWrt daemon.warn pppd[2252]: Connected to b4:14:89:03:08:00 via interface eth1
Jul 25 09:10:31 OpenWrt daemon.info pppd[2252]: Using interface pppoe-wan
Jul 25 09:10:31 OpenWrt daemon.notice pppd[2252]: Connect: pppoe-wan <--> eth1
Jul 25 09:10:31 OpenWrt daemon.notice pppd[2252]: PAP authentication succeeded
Jul 25 09:10:31 OpenWrt daemon.notice pppd[2252]: peer from calling number B4:14:89:03:08:00 authorized
...
В чем может быть причина столь странного поведения? И как мне более подробно отследить действия pppd в момент, когда я подключаю провод в порт модема?

Myr4ik ()
Ответ на: комментарий от Myr4ik

Проблема разрешилась без моих танцев с бубном) Провайдер переключил меня в другой DSLAM и все заработало как надо. Предыдущий DSLAM был стар и немощен (так мне сказали).

Myr4ik ()

ребят помогите настроить OpenWrt...суть в том что мне нужно чтоб при подключение к wi fi у меня использовался pppoe соединение а точнее...его логин и пароль...кто сталкивался с етой проблемой помогите!!!

vaxa0921 ()
Вы не можете добавлять комментарии в эту тему. Тема перемещена в архив.