LINUX.ORG.RU

А видеокарту указать, нет?

arch
steam

Так гарантируют работу на убунте же.

ritsufag ★★★★★ ()

вангую, что не хватает 32-ух битных библиотек. УМВР

gavlig ★★★ ()

У вас multilib (multi arch) система или только 64 битная ?

Как видите у вас не подгружаются 32 битные библиотеки:

...
ERROR: ld.so: object '/home/denis/.local/share/Steam/ubuntu12_32/gameoverlayrenderer.so' from LD_PRELOAD cannot be preloaded (wrong ELF class: ELFCLASS32): ignored.
...

Заодно можете проверить зависимости этих библиотек:

ldd '/home/denis/.local/share/Steam/ubuntu12_32/gameoverlayrenderer.so'

kostik87 ★★★★★ ()
Ответ на: комментарий от kostik87
[denis@oster ~]$ ldd '/home/denis/.local/share/Steam/ubuntu12_32/gameoverlayrenderer.so'
        linux-gate.so.1 (0xf770c000)
        libGL.so.1 => /usr/lib32/libGL.so.1 (0xf7645000)
        librt.so.1 => /usr/lib32/librt.so.1 (0xf763c000)
        libm.so.6 => /usr/lib32/libm.so.6 (0xf75f6000)
        libdl.so.2 => /usr/lib32/libdl.so.2 (0xf75f1000)
        libstdc++.so.6 => /usr/lib32/libstdc++.so.6 (0xf7507000)
        libpthread.so.0 => /usr/lib32/libpthread.so.0 (0xf74eb000)
        /usr/lib/ld-linux.so.2 (0xf770d000)
        libc.so.6 => /usr/lib32/libc.so.6 (0xf733e000)
        libglapi.so.0 => /usr/lib32/libglapi.so.0 (0xf7326000)
        libXext.so.6 => /usr/lib32/libXext.so.6 (0xf7313000)
        libXdamage.so.1 => /usr/lib32/libXdamage.so.1 (0xf730e000)
        libXfixes.so.3 => /usr/lib32/libXfixes.so.3 (0xf7308000)
        libX11-xcb.so.1 => /usr/lib32/libX11-xcb.so.1 (0xf7305000)
        libX11.so.6 => /usr/lib32/libX11.so.6 (0xf71ce000)
        libxcb-glx.so.0 => /usr/lib32/libxcb-glx.so.0 (0xf71b5000)
        libxcb-dri2.so.0 => /usr/lib32/libxcb-dri2.so.0 (0xf71ae000)
        libxcb.so.1 => /usr/lib32/libxcb.so.1 (0xf718b000)
        libXxf86vm.so.1 => /usr/lib32/libXxf86vm.so.1 (0xf7185000)
        libdrm.so.2 => /usr/lib32/libdrm.so.2 (0xf7177000)
        libgcc_s.so.1 => /usr/lib32/libgcc_s.so.1 (0xf715d000)
        libXau.so.6 => /usr/lib32/libXau.so.6 (0xf7158000)
        libXdmcp.so.6 => /usr/lib32/libXdmcp.so.6 (0xf7151000)

oster2011 ★★ ()
Ответ на: комментарий от oster2011

Ставьте тогда Ubuntu или SteamOS, там 100% гарантирован запуск.

kostik87 ★★★★★ ()
Ответ на: комментарий от kostik87

Это мне не подходит, может какие то библиотеки до установить можно?

oster2011 ★★ ()
Ответ на: комментарий от oster2011

В вашей системе так же проблемы с подгрузкой и 64 битных библиотек:

...
ERROR: ld.so: object '/home/denis/.local/share/Steam/ubuntu12_64/gameoverlayrenderer.so' from LD_PRELOAD cannot be preloaded (wrong ELF class: ELFCLASS64): ignored.
...
Скорее всего нужно подгружать так же и определённую версию glibc. В вашей системе он более новая.

kostik87 ★★★★★ ()

Другие игры нормально работают?

kerneliq ★★★★★ ()
Ответ на: комментарий от kerneliq

STEAM

  • Dota 2
  • Half-Life 2
  • Left 4 Dead 2
  • Serena
  • Team Fortess 2


Нормально работают в Steam.
Помимо steam игры в playonlinux работают тоже отлично.
Только пока проблема c Metro: Last Light

oster2011 ★★ ()
Ответ на: комментарий от oster2011

Запусти стим из консоли, запусти метро, посмотри на что ругается

Dantix ★★ ()

oster2011, другие игры ты устанавливал, пробовал запускать, они работали? Стоят ли 32-битные драйвера на видео? Стоят ли 32-битные либы?

У меня была похожая проблема с Team Fortress 2, при запуске коротко мигал экран (черным) и все. Для меня решилось снятием галочки «Enable steam community in game» в настройках игры (щелкаешь правой кнопкой по имени игры в своей библиотеке, выбираешь «Options», вроде так, там и найдешь этот пункт).

Policeman ()

При попытки запуска
ки

Падеж какой, ёпта?

Deleted ()
Ответ на: комментарий от Deleted

Вывод консоли есть выше. Вывод ldd тоже приводиться выше. Не хватает библиотеки какой то. Я не знаю что именно доставить надо.

oster2011 ★★ ()
Ответ на: комментарий от oster2011

Между играми из списка и Metro: Last Light единственная связь — их можно купить через стим. А теперь объясни мне, зачем ты их приводишь в пример, если у них движки разные? Под Last Light надо префикс допихивать, так он у тебя с полпинка на сыром вайне не запустится, как эти.

Deleted ()
Ответ на: комментарий от oster2011

Я тебя про твой ссаный выхлоп, который ты всё равно снял неправильно, не спрашивал. Я спросил «падёж какой, ёпта?».

Deleted ()
Ответ на: комментарий от oster2011

Падеж, чукча, какой ты использовал?

Deleted ()
Ответ на: комментарий от oster2011

Ололо, тред доставил. ТС, ставь убанту, и не выеживайся.

anonymous ()
Ответ на: комментарий от oster2011

Он имеет ввиду склонение слова «попытки».

Падежей несколько, этому учат в начальной школе:

  • Именительный - Кто? Что?
  • Родительный - Кого? Чего?
  • Дательный - Кому? Чему?
  • Винительный - Кого? Что?
  • Творительный - Кем? Чем?
  • Предложный - О ком? О чём?

Ну а так, возвращаясь к проблеме запуска Metro Last Light в Linux, всё же попробуйте поставить второй системой Ubuntu или Steam OS и проверьте как происходит запуск игры в этих системах.

kostik87 ★★★★★ ()
Ответ на: комментарий от oster2011

Как бы проблема возникает в Arch Linux, а не в Ubuntu.

kostik87 ★★★★★ ()

У меня тоже не взлетело, чего я только не делал. В итоге плюнул, запустил в оффтопике, и через 10 минут игры благополучно удалил. Не понравилась. А отдать нельзя.

false ★★★★★ ()
Ответ на: комментарий от Deleted

У вас совсем нет умения общаться с людьми. Вы из леса?

ipeacocks ★★★★★ ()

nvidia 520mx

А ты мин сис требования читал? (NVIDIA GeForce GT 640M 512 MB) Забей пока - не испортиться, потом на новом железе поиграешь.

fornlr ★★★★★ ()
Последнее исправление: fornlr (всего исправлений: 2)

Друг расшарил мне библиотеку, вчера вечером решил проверить работу сабжа. На Nvidia не запускал, но на Intel проблемы с текстурой над головой, отсутствие воды, освещения и другие траблы. Тоже Arch. Но думаю что графику отличную не получу на 635m.

ToaDron ()
Ответ на: комментарий от ToaDron

А вы не знаете какие библиотеки мне надо доставить что бы у меня запустилось?

oster2011 ★★ ()

Агрессивные убунтофилы тебя сильно обругали. Ну и фиг с ними. Решения проблемы не знаю, давай думать.

В самом стиме всё нормально. Не стартует именно файл игры. Посмотреть чего ему не хватает невозможно: статичная линковка. Тогда давай думать.

1). Может у тебя не проприетарный драйвер NVIDIA, а nouveau. Он не подходит.

2). Может у тебя проприетарный драйвер, но не установлен 32-битный OpenGL. Не пробовал Arch Linux и не знаю как там происходит установка. Знаю что просто запуск run-файла с инсталлятором будет спрашивать, нужны ли нам 32-битные библиотеки или нет.

3). Может быть что-то не так с разрешением экрана. Попробуй «r_fullscreen off» в /home/zenitur/.local/share/Steam/SteamApps/common/Metro Last Light/11000010205374c/user.cfg.

4). Попробуй выключить музыку в плеере. Мало ли что, вдруг шаманство сработает.

ZenitharChampion ★★★★★ ()

32-х битные версии видео дров стоят?

unikum ★★★★★ ()
Ответ на: комментарий от ZenitharChampion

1) На данный момент я использую я видео карту только intel, ибо nvida не определяться системой.
2) У меня стоит драйвер xf86-video-intel.
3) Когда в файле /home/denis/.local/share/Steam/SteamApps/common/Metro Last Light/user.cfg поменял «r_fullscreen on» на«r_fullscreen off», при запуски игры выбивает черное окно и через секунду сразу же закрывается.
4) Во время запуска игры у меня всегда открыт только один Steam.

oster2011 ★★ ()
Ответ на: комментарий от unikum

Как то ссылка не помогла(
VjМожет руки не с того места растут

oster2011 ★★ ()

Сколько же ненужностей в одном заголовке.

rskeyf ()
Ответ на: комментарий от oster2011

Так у тебя не установлен драйвер видеокарты? Что ж ты сразу не сказал. Bumblebee уже пробовал? На вот работающий рецепт, понадобится установить драйвер NVIDIA версии 319.xx или новее, скопировать xorg.conf, внести правку в xinitrc. Три возможные неполадки с решениями также есть по ссылке. У меня Optimus и всё работает, скриншот.

ZenitharChampion ★★★★★ ()
Последнее исправление: ZenitharChampion (всего исправлений: 1)
Вы не можете добавлять комментарии в эту тему. Тема перемещена в архив.