LINUX.ORG.RU

sbmd работает, но «падает» nmbd

 


0

1

Здравствуйте. Имею samba-3.0.24. Сегодня, что-то изменилось, и при работающем smbd «отваливается» nmbd. Перезапускаю samba- smbd & nmbd стартовали и создали для себя pid-файлы. Смотрю статус - оба процесса работают. Запрос статуса через 20-30 сек. выдаёт сообщение о том, что- nmbd в не рабочем состоянии:

[root@maestro bsm]# /etc/init.d/smb start
Syntax OK
Запускается процесс SMB:                                   [ ОК ]
Запускается процесс NMB:                                   [ ОК ]
[root@maestro bsm]# /etc/init.d/smb status
smbd (pid 17601 17599) Выполняется...
nmbd (pid 17603 17602) Выполняется...
[root@maestro bsm]# /etc/init.d/smb status
smbd (pid 17601 17599) Выполняется...
nmbd не живой, но pid-файл существует.
Как исправить ситуацию? Спасибо.


Ответ на: комментарий от kostik87

Из скрипта запуска:

start() {
        rootok
        KIND="SMB"
        echo -n $"Starting $KIND services: "
        daemon smbd $SMBDOPTIONS
        RETVAL=$?
        echo
        KIND="NMB"
        echo -n $"Starting $KIND services: "
        daemon nmbd $NMBDOPTIONS
        RETVAL2=$?
        echo
        [ $RETVAL -eq 0 -a $RETVAL2 -eq 0 ] && touch /var/lock/subsys/smb || \
           RETVAL=1
        return $RETVAL
}

bsm ()
Ответ на: комментарий от bsm

Не помогло:

[root@maestro init.d]# /etc/init.d/smb start
Syntax OK
Запускаются службы NMB:                                    [  ОК  ]
Запускаются службы SMB:                                    [  ОК  ]
[root@maestro init.d]# /etc/init.d/smb status
smbd (pid 23043 23041) выполняется...
nmbd неживой, но pid-файл существует

bsm ()
Ответ на: комментарий от bsm

Тогда нужно смотреть логи SAMBA и вывод dmesg.

Ну и надеюсь вы правильно отредактировали стартовый init сценарий, должно быть что-то вроде:

start() {
        rootok
        KIND="NMB"
        echo -n $"Starting $KIND services: "
        daemon smbd $NMBDOPTIONS
        RETVAL=$?
        echo
        KIND="SMB"
        echo -n $"Starting $KIND services: "
        daemon nmbd $SMBDOPTIONS
        RETVAL2=$?
        echo
        [ $RETVAL -eq 0 -a $RETVAL2 -eq 0 ] && touch /var/lock/subsys/smb || \
           RETVAL=1
        return $RETVAL
}

Так же неплохо бы было узнать значение $NMBDOPTIONS и $SMBDOPTIONS .

kostik87 ★★★★★ ()
Ответ на: комментарий от kostik87

/var/log/dmsg:

..
r8169 Gigabit Ethernet driver 2.2LK-NAPI loaded
eth0: Identified chip type is 'RTL8169s/8110s'.
eth0: RTL8169 at 0xf887a000, 00:1c:f0:6f:2c:b9, IRQ 10
r8169 Gigabit Ethernet driver 2.2LK-NAPI loaded
eth1: Identified chip type is 'RTL8169s/8110s'.
eth1: RTL8169 at 0xf887c000, 00:1c:f0:6f:2c:47, IRQ 11
parport: PnPBIOS parport detected.
parport0: PC-style at 0x378, irq 7 [PCSPP,TRISTATE,EPP]
PCI: Setting latency timer of device 0000:00:02.1 to 64
ehci_hcd 0000:00:02.1: EHCI Host Controller
ehci_hcd 0000:00:02.1: new USB bus registered, assigned bus number 1
ehci_hcd 0000:00:02.1: debug port 1
PCI: cache line size of 64 is not supported by device 0000:00:02.1
ehci_hcd 0000:00:02.1: irq 5, io mem 0xfe02e000
ehci_hcd 0000:00:02.1: USB 2.0 started, EHCI 1.00, driver 10 Dec 2004
usb usb1: configuration #1 chosen from 1 choice
hub 1-0:1.0: USB hub found
hub 1-0:1.0: 10 ports detected
ohci_hcd: 2005 April 22 USB 1.1 'Open' Host Controller (OHCI) Driver (PCI)
PCI: Setting latency timer of device 0000:00:02.0 to 64
ohci_hcd 0000:00:02.0: OHCI Host Controller
ohci_hcd 0000:00:02.0: new USB bus registered, assigned bus number 2
ohci_hcd 0000:00:02.0: irq 11, io mem 0xfe02f000
usb usb2: configuration #1 chosen from 1 choice
hub 2-0:1.0: USB hub found
hub 2-0:1.0: 10 ports detected
ACPI: Power Button (FF) [PWRF]
ACPI: Power Button (CM) [PWRB]
ibm_acpi: ec object not found
md: Autodetecting RAID arrays.
md: autorun ...
md: ... autorun DONE.
device-mapper: 4.6.0-ioctl (2006-02-17) initialised: dm-devel@redhat.com
EXT3 FS on sda3, internal journal
kjournald starting.  Commit interval 5 seconds
EXT3 FS on sda1, internal journal
EXT3-fs: mounted filesystem with ordered data mode.
kjournald starting.  Commit interval 5 seconds
EXT3 FS on sda2, internal journal
EXT3-fs: mounted filesystem with ordered data mode.
kjournald starting.  Commit interval 5 seconds
EXT3 FS on sda5, internal journal
EXT3-fs: mounted filesystem with ordered data mode.
kjournald starting.  Commit interval 5 seconds
EXT3 FS on sda8, internal journal
EXT3-fs: mounted filesystem with ordered data mode.
kjournald starting.  Commit interval 5 seconds
EXT3 FS on sda6, internal journal
EXT3-fs: mounted filesystem with ordered data mode.
kjournald starting.  Commit interval 5 seconds
EXT3 FS on sda9, internal journal
EXT3-fs: mounted filesystem with ordered data mode.
Adding 4200956k swap on /dev/sda7.  Priority:-1 extents:1 across:4200956k
[root@maestro bsm]#
Значения $NMBDOPTIONS и $SMBDOPTIONS:
# Options to smbd
SMBDOPTIONS="-D"
# Options to nmbd
NMBDOPTIONS="-D"
# Options for winbindd
WINBINDOPTIONS=""

bsm ()
Ответ на: комментарий от bsm

Проверьте, что процесса nmbd точно нет среди запущенных:

ps ax | grep nmbd

Затем можете запустить nmbd вручную:

nmbd -D -s /etc/samba/smb.conf

С другой стороны nmb - это поддержка netbios (WINS).

kostik87 ★★★★★ ()
Ответ на: комментарий от kostik87

Не помогло-

[root@maestro bsm]# /etc/init.d/smb restart; /etc/init.d/smb status; ps ax | grep *mbd; sleep 7; /etc/init.d/smb status
Останавливается процесс SMB:                          [ ОК ]
Останавливается процесс NMB:                          [ ОК ]
Запускается процесс SMB:                                    [ ОК ]
Запускается процесс NMB:                                    [ ОК ]

smbd (pid 6663 6661) Выполняется...
nmbd (pid 6665 6664) Выполняется...

 6675 pts/0    S+     0:00 grep *mbd
smbd (pid 6663 6661) Выполняется...
nmbd не живой, но pid-файл существует

[root@maestro bsm]# /usr/sbin/nmbd -D -s /etc/samba/smb.conf; /etc/init.d/smb status
smbd (pid 6663 6661) Выполняется...
nmbd (pid 6924 6923) Выполняется...

[root@maestro bsm]# /etc/init.d/smb status
smbd (pid 6663 6661) Выполняется...
nmbd не живой, но pid-файл существует

bsm ()
Ответ на: комментарий от fMad

В моём smb.conf всегда работало-

..
interface = eth0, lo
..
Теперь если указать-
..
interface = eth0, 192.168.0.1
..
то nmbd не падает.

bsm ()
Вы не можете добавлять комментарии в эту тему. Тема перемещена в архив.