LINUX.ORG.RU

No sound in Quake 4

 ,


0

1

Решил понекрофилить в Q4. Поставил с репозитория, запускаю - звука нет. Смотрю лог:

------ OSS Sound Initialization ------
opened sound device '/dev/dsp'
ioctl SNDCTL_SYSINFO failed: Invalid argument
this ioctl is only available in OSS/Linux implementation. If you run OSS/Free, don't bother.
/dev/dsp - bit rate: 16, channels: 6, frequency: 44100
allocated a mix buffer of 49152 bytes
Ушел гуглить. Подсказывают запускать через quake4 +set s_driver oss или aoss quake4. Пакет media-libs/alsa-oss стоит. Нифига. В настройках игры даже нет отображения звукового устройства. Права на /dev/dsp стоят как crwxrw-rwx+, в группу audio добавлен давно. Не работает.

Система у меня Gentoo x86_64 emul-linux-x86-medialibs, emul-linux-x86-opengl, emul-linux-x86-soundlibs. Блин, что еще надо?

Пакет media-libs/alsa-oss стоит

У тебя основная звуковая система какая? Если алса, то Q4 умеет напрямую через нее работать без oss. У меня все нормально с этим. Если у тебя oss, то ничего сказать не могу.

ATIpro ★★ ()
Ответ на: комментарий от KERNEL_PANIC

pulseaudio

Тогда лучше в конфигах Alsa указать, если не заработает (могут быть ошибки связанные с размером буфера) то план Б:

в конфигах Q4 указать OSS и запускать игру как padsp Quake4.bin (ну или как там бинарник называется). Главное не через их шелл скрипт запускать или поправить его.

Hope ★★ ()
Ответ на: комментарий от KERNEL_PANIC

pulseaudio

Попробуй так quake4 +set s_driver alsa +set s_alsa_pcm default. Нужны 32-хбитные либы алсы, на счет либ пульса не знаю. Чтобы пустить звук в обход пульсы замени default на что-нибудь вида plughw:0. Если либа установлена, а игра ее не видит, то добавить еще +set s_alsa_lib «libasound.so.0», заменив название на свое.

ATIpro ★★ ()
Ответ на: комментарий от ATIpro

Блин, нифига не помогает. Кстати на 32бит арче тоже звука не было, но там это лечилось простой установкой пакетов. Тут такое не катит. Уже как-бы подумываю о 32бит внутри на 64бит системе, только боюсь сабж не взлетит

KERNEL_PANIC ★★★ ()
Ответ на: комментарий от KERNEL_PANIC

Можешь привести лог инициализации звука при использовании алсы?

ATIpro ★★ ()
Ответ на: комментарий от ATIpro

Дум 3 говорит, что

------ Alsa Sound Initialization -----
dlopen(libasound.so.2)
asoundlib version: 1.0.25
ALSA lib conf.c:3314:(snd_config_hooks_call) Cannot open shared library /usr/lib/alsa-lib/libasound_module_conf_pulse.so
ALSA lib pcm.c:2217:(snd_pcm_open_noupdate) Unknown PCM default
snd_pcm_open SND_PCM_STREAM_PLAYBACK 'default' failed: No such file or directory
dlclose
WARNING: sound subsystem disabled
Однако:

$ ls -l /usr/lib/alsa-lib/libasound_module_conf_pulse.so                                                         
-rwxr-xr-x 1 root root 5984 лис 19 01:30 /usr/lib/alsa-lib/libasound_module_conf_pulse.so
KERNEL_PANIC ★★★ ()
Ответ на: комментарий от KERNEL_PANIC

ls -l /usr/lib/alsa-lib/libasound_module_conf_pulse.so

file /usr/lib/alsa-lib/libasound_module_conf_pulse.so

и

ldd /usr/lib/alsa-lib/libasound_module_conf_pulse.so
З.Ы. У меня на Арче x86_64 работает нормально. Пульсом я не пользуюсь, но скорее всего и с ним должно работать. Очевидно, что каких-то 32-хбитный либ не хватает.

ATIpro ★★ ()
Последнее исправление: ATIpro (всего исправлений: 1)
Ответ на: комментарий от ATIpro

Уже разобрался с проблемой. Когда перезапустил сервер альсы, вижу она ругается:

 * Restoring Mixer Levels ... 
 * No mixer config in /var/lib/alsa/asound.state, you have to unmute your card!               [ ok ] 
Тогда выполнил alsaconf, отконфигурировал, перезапустил альсу и все стало работать)

KERNEL_PANIC ★★★ ()
Вы не можете добавлять комментарии в эту тему. Тема перемещена в архив.