LINUX.ORG.RU

[ubuntu] [wine 1.2.2] Тормозит Fallout


0

1

Приветствую!

Решил поиграть в Fallout, но под Wine 1.2.2 (который из реп Ubuntu 10.10) он дико тормозит. А еще превращает ноут, конфигурация которого, разумеется, достаточная для этой игры, в печку.

Почему и как исправить?

★★★

Для быстрой игры в старые 2Д игры нужна вайн версии 1.0 или ниже.

Т.к. новые версии вайна оптимизированы под 3Д игры. В новых версиях вайна быстрый 2Д код удалён.

А еще превращает ноут, конфигурация которого, разумеется, достаточная для этой игры, в печку.


Fallout и в виндовс в 100% загружает процессор.

Поэтому у меня стоит несколько версий вайна.

anonymous ()
Ответ на: комментарий от gavlig

Уже да. Попробовал запустить с nice - легче не становится. Совместимость с win98 поставил интуитивно.

Mordrag ★★★ ()
Ответ на: комментарий от Mordrag

даже не знаю, что может быть причиной таких проблем.. Сам время от времени играю в старкрафт первый, второй фолл был пройден пару лет назад по стопицотому кругу под опять же вайном, но не думаю, что анон прав и надо ставить старую версию оного. Я бы проверил, поставили ли вы d3dx9 и opengl как стандартный рендерер. Возможно, это поможет.

gavlig ★★★ ()

Случайно не при перемещение по карте мира тормозит?

anonymous_sama ★★★★★ ()
Ответ на: комментарий от gavlig

но не думаю, что анон прав и надо ставить старую версию оного.


Я сравнивал скорость версий 0.9.15 и 1.3.3.
Версия 0.9.15 работает значительно быстрее.

anonymous ()
Ответ на: комментарий от Mordrag

Как вариант могу посоветовать поставить версию под dos в dosbox'е
Directx winetrick'сом я думаю ты уже поставил если что, попробуй удалить fallout.cfg, когда ставишь ставь самую большую установку, также лучше сразу патченный до 1.1 fallout ставить.

anonymous_sama ★★★★★ ()

Может быть, взять DOSBox и запустить версию для DOS?

proud_anon ★★★★★ ()

у меня на дряном компе тоже тормозит. попробовать рецепты с вайнэйчкью, поставить отдельный вайн старой версии, не играть фуллскрин. актуально для 1, 2, тактикс. сам задр^Wлюбитель фола до одури:)

sudoer ()

Я для игр что под современным вайном не идут держу работающую системку со всеми потрохами на флешке, так как зачастую просто вайн не помогает бывает несовместимость с иксами.

И да в Fallout скоро можно будет в реале играть!

anonymous ()
Ответ на: комментарий от anonymous_sama

Пропатчить попробую. С другими версиями (dos) заморачиваться не очень хочется: с лицензионного диска ставлю.

Mordrag ★★★ ()

Ещё можно ускорить вайн если перевести иксы в 16 (или 8) битный режим. Для этого нужно отредактировать иксовый конфиг.

А иксы по дефолту запускаются в 24 битном режиме. В отличие от виндовс, в линуксе икс сервер не умеет переключать битность видеорежимов по требованию програм.

anonymous ()
Ответ на: комментарий от anonymous

Спасибо, но это уже костылестроением попахивает =)

Mordrag ★★★ ()

У меня тоже тормозил, но я поставил патчик на высокие разрешения, теперь играю 1200*800, нагрузка 30-50% на одном ядре, температура 45 градусов.

anonymous ()
Ответ на: комментарий от anonymous

Любопытно. У меня он наоборот с hi-res паком тормозил, а без него нормально шёл.

cPunk ★★ ()

У меня все нормально было, только вместо ГГ почему-то Тукс бегал.

A_Dungeon ()
Вы не можете добавлять комментарии в эту тему. Тема перемещена в архив.