LINUX.ORG.RU
ФорумGames

Битва за веснот + freeciv - помогите установить


0

0

Система Ксандрос (дебиан). Может подскажете какие репозитории, где всякие нужные файлы и библиотеки (gcc например) лежат новые. Смотрел в репозиториях, как: deb ftp://ftp.us.debian.org/debian/ etch main contrib non-free

deb-src http://ftp.de.debian.org/debian/ etch main contrib non-free

deb-src http://http.us.debian.org/debian/ etch main contrib non-free

но в них все старое и по зависимостям не подходит, а порою даже доабсура доходит: Пакет А не встает без пакета Б, а пакет Б не встает без пакета А. Заранее спасибо


Re: Битва за веснот + freeciv - помогите установить

vim /etc/apt/sources.list
:%s/etch/sid/g
:wq
aptitude update
aptitude install aptitude
aptitude full-upgrade
#И помоги тебе <нужное вписать>

kilolife ★★★★★ ()

Re: Битва за веснот + freeciv - помогите установить

>Пакет А не встает без пакета Б, а пакет Б не встает без пакета А

Дебиан же

Gary ★★★★★ ()

Re: Битва за веснот + freeciv - помогите установить

1) поставить живой дебиян
2)собрать вручную из репов дебяна:
echo "deb-src http://ftp.de.debian.org/debian/ etch main contrib non-free" /etc/apt/sources.list.d/deb-src.list
apt-get update
apt-get source wesnoth -t etch
cd wesnoth
apt-get build-dep wesnoth
dpkg-buildpackage -b
dpkg -i ../wesnoth*

Fredy ()

Re: Битва за веснот + freeciv - помогите установить

уже скачал последнюю версию из репозиториев. Теперь может подскажет кто, как добавить опцию --enable-tinygui, чтобы выглядела нормально с моим маленьким экраном.

Jsiod ()

Re: Битва за веснот + freeciv - помогите установить

С репозитория версия начала глючить, решил собрать из исходников, но он не хочет даже делать ./configure с нужной опцией, а пишет checking for sdl-config... no checking for sdl11-config... no configure: error: *** SDL not found! Get SDL from www.libsdl.org. If you already installed it, check it's in the path. If problem remains, please send a mail to the address that appears in ./configure --version indicating your platform, the version of configure script and the problem. хотя из репозиториев все обновил вроде что с sdl связано, а сайт www.libsdl.org ссылается на тот же репозиторий для дебиана. И кстати в начале файла INSTALL написано что нужен libsdl >= 1.2.7, но такой версии негде не нашел. Помогите пожалуйста с этим сдл, не знаю что делать :(

Jsiod ()

Re: Битва за веснот + freeciv - помогите установить

Думаю стоит сначала почитать http://wiki.debian.org/DebianEeePC

Потому что хз что сотворили с дебианом создатели ксандроса для ееёшки. Думаю проще установить нормальный дебиан.

mono ★★★★★ ()
Вы не можете добавлять комментарии в эту тему. Тема перемещена в архив.