LINUX.ORG.RU
ФорумGames

Steam, Civ6, An unrecoverable error has occurred

 , ,


0

1

Ubuntu 20.04

Не запускал игры больше полугода и тут внезапно при запуске 6ой цивилизации из стима вылетает такое вот сообщение An unrecoverable error has occurred, and Civilization VI can not continue.

Из ошибок в логе только: ERROR: ld.so: object '/home/petr/.steam/ubuntu12_32/gameoverlayrenderer.so' from LD_PRELOAD cannot be preloaded (wrong ELF class: ELFCLASS32): ignored..

ldd грит что либы на месте

gdb грит что оно не крашится

У кого запускается, дайте lsof?

Апдейт. Попытался запустить через протон с PROTON_USE_WINED3D=1, но эта дрянь хочет directX11/12 а моя карточка не поддерживает вулкан.

Апдейт. У кого нить запускается на видяхе без вулкана?

Апдейт. Я докопался до ошибки рендерера

[2020-07-02 09:01:13]	Renderer::Startup(): Called with
	Device Index = 0
	Backbuffer Format = 87
	Resolution = (1360 x 768)
	RefreshRateInHz = 60
	WindowMode = Windowed
	VSync = 1
	Threading Mode = 0.
[2020-07-02 09:01:13]	ValidateRenderTargetDesc: Format 87 not supported at render target on this device!
Ещё бы понимать что это за «Backbuffer Format = 87»?

★★★★★

Ответ на: комментарий от ya-betmen

секта ламеров блин… $ lsb_release -a No LSB modules are available. Distributor ID: Ubuntu Description: Ubuntu 20.04 LTS Release: 20.04 Codename: focal

$ dpkg -l|grep i38|sed ‘s/i386.*/i386/’ ii gcc-10-base:i386 ii libasound2:i386 ii libasyncns0:i386 ii libatomic1:i386 ii libbsd0:i386 ii libc++1-10:i386 ii libc++abi1-10:i386 ii libc6:i386 ii libcrypt1:i386 ii libdbus-1-3:i386 ii libdrm-amdgpu1:i386 ii libdrm-intel1:i386 ii libdrm-nouveau2:i386 ii libdrm-radeon1:i386 ii libdrm2:i386 ii libedit2:i386 ii libelf1:i386 ii libexpat1:i386 ii libffi7:i386 ii libflac8:i386 ii libfreetype6:i386 ii libgcc-s1:i386 ii libgcrypt20:i386 ii libgl1:i386 ii libgl1-mesa-dri:i386 ii libglapi-mesa:i386 ii libglu1-mesa:i386 ii libglvnd0:i386 ii libglx-mesa0:i386 ii libglx0:i386 ii libgpg-error0:i386 ii libice6:i386 ii libidn2-0:i386 ii libllvm9:i386 ii liblz4-1:i386 ii liblzma5:i386 ii libogg0:i386 ii libopenal1:i386 ii libpciaccess0:i386 ii libpng16-16:i386 ii libpulse0:i386 ii libpulsedsp:i386 ii libsdl2-2.0-0:i386 ii libsensors5:i386 ii libsm6:i386 ii libsndfile1:i386 ii libsndio7.0:i386 ii libstdc++6:i386 ii libsystemd0:i386 ii libtinfo6:i386 ii libudev1:i386 ii libunistring2:i386 ii libuuid1:i386 ii libvorbis0a:i386 ii libvorbisenc2:i386 ii libvorbisfile3:i386 ii libvulkan1:i386 ii libwayland-client0:i386 ii libwayland-cursor0:i386 ii libwayland-egl1:i386 ii libwrap0:i386 ii libx11-6:i386 ii libx11-xcb1:i386 ii libxau6:i386 ii libxcb-dri2-0:i386 ii libxcb-dri3-0:i386 ii libxcb-glx0:i386 ii libxcb-present0:i386 ii libxcb-randr0:i386 ii libxcb-sync1:i386 ii libxcb1:i386 ii libxcursor1:i386 ii libxdamage1:i386 ii libxdmcp6:i386 ii libxext6:i386 ii libxfixes3:i386 ii libxi6:i386 ii libxinerama1:i386 ii libxkbcommon0:i386 ii libxrandr2:i386 ii libxrender1:i386 ii libxshmfence1:i386 ii libxss1:i386 ii libxxf86vm1:i386 ii libzstd1:i386 ii mesa-vulkan-drivers:i386 ii zlib1g:i386

anonymous ()
Ответ на: комментарий от DoctorSinus

Куда-куда, поддержку 32 бит в системе верни, в 20.04 по дефолту её убрали

Не обманывай.

А так автор скорее всего чего-то напетрушил с архитектурами. Может наставил и ARM. И чего-то напутал.

fornlr ★★★★★ ()

Это ни о чём не говорящая ошибка steam, она есть у всех кто 64бит линукс использует. И у меня тоже. И игровой оверлей при этом прекрасно работает кстати, потому что 64битная либа тем не менее прогрузилась. Битность оверлея не зависит от битности игры.

Ты не ту ошибку лечишь. Цива не по этому не запускается.

Jameson ★★★ ()
Ответ на: комментарий от Jameson

Та я знаю что она не поэтому отваливается, я написал что это единственный еррор, если б проблема была в нем уже бы починил. Никаких крашей нет, цива сама на что-то напарывается и выводит окно с ошибкой. Я только не могу понять что именно не так.

Если у тебя запускается можешь lsof выложить?

ya-betmen ★★★★★ ()

Попробуй включить встроенный контейнер: Свойсва игры -> Принудительно использовать инструмент совместимости -> выбрать в списке Steam Linux Runtime.

Kron4ek ★★★★ ()
Ответ на: комментарий от Thero

Через протон не взлетает т.к. у меня поддержки вулкана нету. Я вот думаю порт тоже через какой-нить dxvk пытается стартануть. Во всяком случае в ресурсах порта лежат виндовые либы и виндовые же культи.

ya-betmen ★★★★★ ()
Последнее исправление: ya-betmen (всего исправлений: 1)
Ответ на: комментарий от ya-betmen

нет там разные трансляторы несмотря на.. и да у протона есть флаг который запускает его через опенгл как старый добрый вайн специально для твоего случая..

Thero ★★★★★ ()

вот это пердолинг для проходной игрушечки))) которая даже нативочка бгг

Resolution = (1360 x 768)

ну и это кхмм ТС тоже охранником на стройке сидит?

anonymous ()
Ответ на: комментарий от ya-betmen

ну какбы дальше не навангуешь, что там на убунте сломано и как чинить.. на федоре на 6550G встройке запускается хорошо, шо нативно шо протоном. даже терпимо играть..

Thero ★★★★★ ()
Ответ на: комментарий от ya-betmen

Не знаю актуально или нет, но в своё время находил workaround по запуску из steam-native. В параметры запуска в стиме прописать:

LD_LIBRARY_PATH=/usr/lib/openssl-1.0:$LD_LIBRARY_PATH LD_PRELOAD=/usr/lib/libfreetype.so.6 %command%

С тех пор работает прекрасно и без нареканий.

Дай lsof работающей игры

Если пример с nvidia подойдёт, то вот мой выхлоп. Запустил прямо из директории игру (Civ6Sub), не через стим.

https://pastebin.com/3ur3VnkT

alarm ()
Ответ на: комментарий от alarm

LD_LIBRARY_PATH=/usr/lib/openssl-1.0:$LD_LIBRARY_PATH LD_PRELOAD=/usr/lib/libfreetype.so.6 %command%

Я по своему lsof смотрел вроде на месте они были.

Civ6Sub

Он у меня требует запущенного стима. Но спасибо, сравню.

ya-betmen ★★★★★ ()
Ответ на: комментарий от ya-betmen

Он у меня требует запущенного стима. Но спасибо, сравню.

Да, кажется целиком отделить не получится. Хотя я не проверял. Единственное что пришлось ручками id игры положить рядом в txt файлике. Но стим у меня был рядом запущен. Просто через него игра сначала запускает лаунчер Aspyr’овский.

alarm ()