LINUX.ORG.RU

Не компилируется. Ошибка — Configuring incomplete, errors occurred!

 


0

1

Здравствуйте! Установлена на впс-сервере Ubuntu 14.04. Не могу ничего скомпиллировать с исходников. Например, https://github.com/xcicoin/xcicoin

Делаю:

sudo apt-get update sudo apt-get install git cmake make gcc libboost1.55-all-dev git clone https://github.com/xcicoin/xcicoin.git cd xcicoin make

Выдает:

Call Stack (most recent call first): CMakeLists.txt:112 (find_package)

-- Found Git: /usr/bin/git -- Could NOT find Threads (missing: Threads_FOUND) -- Configuring incomplete, errors occurred! See also «/home/max/xcicoin/build/release/CMakeFiles/CMakeOutput.log». See also «/home/max/xcicoin/build/release/CMakeFiles/CMakeError.log». make: *** [cmake-release] Error 1

Что нужно, чтоб скомпиллировать программу?

Да, и еще, не устанавливается sudo apt-get install git cmake make gcc libboost1.55-all-dev выдает:

The following packages have unmet dependencies: libboost1.55-all-dev : Depends: libboost-iostreams1.55-dev but it is not going to be installed Depends: libboost-mpi1.55-dev but it is not going to be installed Depends: libboost-mpi-python1.55-dev but it is not going to be installed Depends: libboost-python1.55-dev but it is not going to be installed Depends: libboost-regex1.55-dev but it is not going to be installed E: Unable to correct problems, you have held broken packages.

Читай логи, пути к файлам тебе написали

annulen ★★★★★ ()
Ответ на: комментарий от annulen

логи

Run Build Command:/usr/bin/make «cmTryCompileExec1164743691/fast» make[1]: Entering directory `/home/max/xcicoin/build/release/CMakeFiles/CMakeTmp' /usr/bin/make -f CMakeFiles/cmTryCompileExec1164743691.dir/build.make CMakeFiles/cmTryCompileExec1164743691.dir/build make[2]: Entering directory `/home/max/xcicoin/build/release/CMakeFiles/CMakeTmp' /usr/bin/cmake -E cmake_progress_report /home/max/xcicoin/build/release/CMakeFiles/CMakeTmp/CMakeFiles 1 Building C object CMakeFiles/cmTryCompileExec1164743691.dir/CheckIncludeFiles.c.o /usr/bin/cc -std=c11 -Wall -Wextra -Wpointer-arith -Wundef -Wvla -Wwrite-strings -Werror -Wno-error=extra -Wno-error=unused-function -Wno-error=deprecated-declarations -Wno-error=sign-compare -Wno-error=strict-aliasing -Wno-error=type -limits -Wno-unused-parameter -Wno-error=unused-variable -Wno-error=undef -Wno-error=uninitialized -Wno-error=unused-result -Wlogical-op -Wno-error=maybe-uninitialized -Wno-error=clobbered -Wno-error=unused-but-set-variable -Waggregate-r eturn -Wnested-externs -Wold-style-definition -Wstrict-prototypes -march=native -maes -o CMakeFiles/cmTryCompileExec1164743691.dir/CheckIncludeFiles.c.o -c /home/max/xcicoin/build/release/CMakeFiles/CMakeTmp/CheckIncludeFiles.c /home/max/xcicoin/build/release/CMakeFiles/CMakeTmp/CheckIncludeFiles.c:5:5: error: function declaration isn’t a prototype [-Werror=strict-prototypes] int main(){return 0;} ^ /home/max/xcicoin/build/release/CMakeFiles/CMakeTmp/CheckIncludeFiles.c: In function ‘main’: /home/max/xcicoin/build/release/CMakeFiles/CMakeTmp/CheckIncludeFiles.c:5:5: error: old-style function definition [-Werror=old-style-definition] cc1: all warnings being treated as errors make[2]: *** [CMakeFiles/cmTryCompileExec1164743691.dir/CheckIncludeFiles.c.o] Error 1 make[2]: Leaving directory `/home/max/xcicoin/build/release/CMakeFiles/CMakeTmp' make[1]: Leaving directory `/home/max/xcicoin/build/release/CMakeFiles/CMakeTmp' make[1]: *** [cmTryCompileExec1164743691/fast] Error 2

Source: /* */ #include <pthread.h>

int main(){return 0;}

Вот лог. Ничего не понятно. Не компилится из-того, что не установлен sudo apt-get install git cmake make gcc libboost1.55-all-dev Как его установить?

maxsun ()

Could NOT find Threads

The following packages have unmet dependencies: libboost1.55-all-dev : Depends: libboost-iostreams1.55-dev but it is not going to be installed Depends: libboost-mpi1.55-dev but it is not going to be installed Depends: libboost-mpi-python1.55-dev but it is not going to be installed Depends: libboost-python1.55-dev but it is not going to be installed Depends: libboost-regex1.55-dev but it is not going to be installed E: Unable to correct problems, you have held broken packages

Тебе же всё написали

XMs ★★★★★ ()
Вы не можете добавлять комментарии в эту тему. Тема перемещена в архив.