LINUX.ORG.RU

Qt 4.8 + linux 2.4.32


0

2

Сие вещи скрестить можно или нет? как минимум у меня нет заголовка <linux/futex.h> и исходных кодов ядра, добавить futexы можно не перекомпиляя ядро?

На вопрос почему и нахрена ответ прост - МСВС3 и долбари из министерства обороны.

Это всего лишь библиотека, ей, как мне кажется, положить на версию ядра, главное что бы все иные либы и хедеры в /usr/include были правильные.

joy4eg ★★★★★ ()
Ответ на: комментарий от joy4eg

Это всего лишь библиотека, ей, как мне кажется, положить на версию ядра

как ей положить, если она создаёт треды и умеет синхронизацию, а это всё зависит от ядра.

dimon555 ★★★★★ ()
Ответ на: комментарий от mskmsk1985

Нет не курю: 2.4.32-vniis46 исходников по понятным причинам нет.

как-то я видел такую хрень, исходники были на диске. впрочем, это же старинный редхат, бородатой версии

dimon555 ★★★★★ ()
Ответ на: комментарий от oganicumak

Еще один слоупок. Привет.

Linux 2.4.32

+ у меня где-то до сих пор стоит 2.4.37. ха!

На сайте их нет, потому что до сих пор не восстоновили после взлома. Раньше — были. Точно.

Такие дела.

anonymous ()

Обломинго полное, или же вытащи старую реализацию мьютексов для кутей, которая не юзает futex'ы.

Gorthauer ★★★★★ ()
Ответ на: комментарий от Jetty

2.4.37

fixed. По непонятной мне причине не восстановили эти версии.

sniper21 ★★★★★ ()

пакет kernel-headers (или какой там в МСВС аналог)

ps. «долбари из МО» не приветствуют самостоятельную сборку Qt, как и прочих прикладных библиотек. Юзайте версию из официальной поставки.

MKuznetsov ★★★★★ ()
Ответ на: комментарий от MKuznetsov

линкуем прогу статически против чего хотим и будет нам счастье.

ЗЫ: Если ВНИИСу можно положить на лицензии то мне тоже можно.

mskmsk1985 ()
Ответ на: комментарий от mskmsk1985

Если ВНИИСу можно положить на лицензии то мне тоже можно.

ВНИИСУ в той части мира где рулят не софтверные лицензии я сертификаты в различных органах :) Не обеспечьте случайно реальную попоболь любимому начальству

MKuznetsov ★★★★★ ()
Ответ на: комментарий от MKuznetsov

«долбари из МО» не приветствуют самостоятельную сборку

думаю им наплевать
собирай, только приготовь деньги на «сертификацию» большой кучи исходников )

зы вроде бы есть мсвс 5.0 - там не 2.6 ядро ? (я не видел)
зыы есть ещё астра - там 2.6.34 и qt 4.6.3 - не подходит ?

x905 ★★★★★ ()
Ответ на: комментарий от unC0Rr

в лоб не вышло (переписывание файлов из 4.7 в 4.8) а ковырять неохота.

mskmsk1985 ()
Ответ на: комментарий от Jetty

Ты ничего не куришь ? Последнее ядро 2.4.31 !!! Боюсь что .32 никогда не будет :)

Из криокамеры чтоли? Были релизы вплоть до 2.4.37.10, просто убрали с kernel.org после августовского факапа.

Adjkru ★★★★★ ()
Ответ на: комментарий от Adjkru

Да, интересное совпадение получилось ;)

gag ★★★★★ ()

Понимаю, что уже прошло много времени, но недавно мне пришлось решать подобную задачу и возможно кому-то это будет полезно. Я заменил threads из Qt 4.8.4 на threads из Qt 4.6.4 с некоторыми необходимыми изменениями, патч прилагаю. С его применением возможно собрать Qt 4.8.4 на МСВС 3.0, правда без WebKit. Для сборки WebKit нужен более свежий GStreamer.

m0rph ★★★★★ ()
Вы не можете добавлять комментарии в эту тему. Тема перемещена в архив.