LINUX.ORG.RU

rpmbuild sentry Could not determine sentry version or build

 ,


0

1

Собираю sentry в rpm:

sudo setenforce 0
sudo yum install -y epel-release rpmdevtools mc
sudo yum install -y python-devel gcc gcc-c++ zlib-devel libjpeg-devel 
sudo yum install -y python34 python3-pip 
curl -sL https://rpm.nodesource.com/setup_12.x | sudo bash -
sudo yum install -y nodejs
curl -sL https://dl.yarnpkg.com/rpm/yarn.repo | sudo tee /etc/yum.repos.d/yarn.repo
sudo yum install yarn
pip3 install --user pyp2rpm

############ Install sentry by pip on Centos 7
pip install --upgrade pip
pip install requests==2.20.1 -U --ignore-installed
pip install PyYAML==3.11 -U --ignore-installed
pip install sentry==9.1.2
######### 

pyp2rpm sentry -t epel7 -b2 -p2 -v 9.1.2 > sentry-9.1.2.spec Удаляем из sentry-9.1.2.spec

< BuildConflicts: python2-configparser = 3.5.2
< BuildConflicts: python2-configparser = 3.5.3
< BuildConflicts: python2-configparser = 3.7.0
< BuildRequires:  python2-Babel
< BuildRequires:  python2-autopep8 < 1.4.0
< BuildRequires:  python2-autopep8 >= 1.3.5
< BuildRequires:  python2-docker < 3.8.0
< BuildRequires:  python2-docker >= 3.7.0
< BuildRequires:  python2-flake8 < 3.6.0
< BuildRequires:  python2-flake8 >= 3.5.0
< BuildRequires:  python2-isort < 4.4.0
< BuildRequires:  python2-isort >= 4.3.4
< BuildRequires:  python2-pycodestyle < 2.4.0
< BuildRequires:  python2-pycodestyle >= 2.3.1
< BuildRequires:  python2-sentry-flake8 >= 0.0.1
< BuildRequires:  python2-setuptools

Оставляем только 1 BuildRequires

BuildRequires:  python2-devel
BuildRequires:  nodejs
BuildRequires:  yarn

sudo yum-builddep sentry-9.1.2.spec LANG=C rpmbuild -bb sentry-9.1.2.spec

using node (v12.16.1) and yarn (1.21.1)
pulled version information from 'sentry' module
building assets for sentry v9.1.2 (build UNKNOWN)
Could not determine sentry version or build
error: Bad exit status from /var/tmp/rpm-tmp.MHlxLW (%build)

cd /home/centos/rpmbuild/BUILD/sentry-9.1.2

/usr/bin/python2 setup.py build
running build
running build_integration_docs
running build_assets
pulled version information from 'sentry' module
using node (v12.16.1) and yarn (1.21.1)
pulled version information from 'sentry' module
building assets for sentry v9.1.2 (build UNKNOWN)
Could not determine sentry version or build
cd /home/centos/rpmbuild/BUILD/sentry-9.1.2/
/usr/bin/python2 setup.py build

Ошибка та же самая. Как ее исправить? Спасибо