LINUX.ORG.RU
ФорумAdmin

Error: Package Requires: python2-dateutil = 2.8.0 Installed: 1:python2-dateutil-2.8.0-1.el7.noarch

 


0

1

Имеется SPEC файл botocore-1.5.70.spec:

# Created by pyp2rpm-3.3.3
%global pypi_name botocore

Name:           python-%{pypi_name}
Version:        1.5.70
Release:        1%{?dist}
Summary:        Low-level, data-driven core of boto 3

License:        Apache License 2.0
URL:            https://github.com/boto/botocore
Source0:        https://files.pythonhosted.org/packages/source/b/%{pypi_name}/%{pypi_name}-%{version}.tar.gz
BuildArch:      noarch

BuildRequires:  python2-devel
#BuildRequires:  python2-dateutil = 2.8.0

%description
 A low-level interface to a growing number of Amazon Web Services. The botocore
package is the foundation for the AWS CLI < as well as boto3 < Documentation -
Documentation for botocore can be found on Read the Docs <

%package -n     python2-%{pypi_name}
Summary:        Low-level, data-driven core of boto 3

Requires:       python2-dateutil == 2.8.0
%description -n python2-%{pypi_name}
 A low-level interface to a growing number of Amazon Web Services. The botocore
package is the foundation for the AWS CLI < as well as boto3 < Documentation -
Documentation for botocore can be found on Read the Docs <


%prep
%autosetup -n %{pypi_name}-%{version}
# Remove bundled egg-info
rm -rf %{pypi_name}.egg-info

%build
%{__python2} setup.py build

%install
%{__python2} setup.py install --skip-build --root %{buildroot}

%files -n python2-%{pypi_name}
%doc README.rst tests/unit/response_parsing/README.rst
%{python2_sitelib}/%{pypi_name}
%{python2_sitelib}/%{pypi_name}-%{version}-py%{python2_version}.egg-info

%changelog
* Tue Mar 24 2020 Cloud User - 1.5.70-1
- Initial package.

Перед сборкой и установкой установил пакет

sudo yum install -y https://cbs.centos.org/kojifiles/packages/python-dateutil/2.8.0/1.el7/noarch/python2-dateutil-2.8.0-1.el7.noarch.rpm

LANG=C sudo yum install -y rpmbuild/RPMS/noarch/python2-botocore-1.5.70-1.el7.noarch.rpm
Loaded plugins: fastestmirror
Examining rpmbuild/RPMS/noarch/python2-botocore-1.5.70-1.el7.noarch.rpm: python2-botocore-1.5.70-1.el7.noarch
Marking rpmbuild/RPMS/noarch/python2-botocore-1.5.70-1.el7.noarch.rpm to be installed
Resolving Dependencies
--> Running transaction check
---> Package python2-botocore.noarch 0:1.5.70-1.el7 will be installed
--> Processing Dependency: python2-dateutil = 2.8.0 for package: python2-botocore-1.5.70-1.el7.noarch
Loading mirror speeds from cached hostfile
 * base: mirrors.xservers.ro
 * epel: fedora-mirror02.rbc.ru
 * extras: mirrors.xservers.ro
 * updates: mirrors.xservers.ro
--> Finished Dependency Resolution
Error: Package: python2-botocore-1.5.70-1.el7.noarch (/python2-botocore-1.5.70-1.el7.noarch)
           Requires: python2-dateutil = 2.8.0
           Installed: 1:python2-dateutil-2.8.0-1.el7.noarch (installed)
               python2-dateutil = 1:2.8.0-1.el7
           Available: python2-dateutil-1.5-0.el7.noarch (epel)
               python2-dateutil = 1.5-0.el7
 You could try using --skip-broken to work around the problem
 You could try running: rpm -Va --nofiles --nodigest

Почему ошибка? Версия верная.