LINUX.ORG.RU

прблема с mysql и python3

 , , ,


0

1

помогите пожалуйста разобраться. на python.su говорят, решение зависит от типа linux

я пытаюсь на python3.4 использовать БД mysql. для этого утсанавливаю MySQL-python. дистрибутив linux mint

(zapsum)kalinins@kalinins-Lenovo-Z580 ~/.virtualenvs/zapsum/zapsum $ pip install MySQL-python
Downloading/unpacking MySQL-python
  Downloading MySQL-python-1.2.5.zip (108kB): 108kB downloaded
  Running setup.py (path:/home/kalinins/.virtualenvs/zapsum/build/MySQL-python/setup.py) egg_info for package MySQL-python
    Traceback (most recent call last):
      File "<string>", line 17, in <module>
      File "/home/kalinins/.virtualenvs/zapsum/build/MySQL-python/setup.py", line 13, in <module>
        from setup_posix import get_config
      File "/home/kalinins/.virtualenvs/zapsum/build/MySQL-python/setup_posix.py", line 2, in <module>
        from ConfigParser import SafeConfigParser
    ImportError: No module named 'ConfigParser'
    Complete output from command python setup.py egg_info:
    Traceback (most recent call last):

  File "<string>", line 17, in <module>

  File "/home/kalinins/.virtualenvs/zapsum/build/MySQL-python/setup.py", line 13, in <module>

    from setup_posix import get_config

  File "/home/kalinins/.virtualenvs/zapsum/build/MySQL-python/setup_posix.py", line 2, in <module>

    from ConfigParser import SafeConfigParser

ImportError: No module named 'ConfigParser'

----------------------------------------
Cleaning up...
Command python setup.py egg_info failed with error code 1 in /home/kalinins/.virtualenvs/zapsum/build/MySQL-python
Storing debug log for failure in /home/kalinins/.pip/pip.log

, то есть этот пакет не устанавливается потому что нужно установить ConfigParser. пробую:

kalinins@kalinins-Lenovo-Z580 ~/.virtualenvs/zapsum/zapsum $ sudo apt-get install python3-dev
[sudo] password for kalinins: 
Reading package lists... Done
Building dependency tree       
Reading state information... Done
python3-dev is already the newest version.
0 upgraded, 0 newly installed, 0 to remove and 387 not upgraded.

что можно попробовать ещё сделать?

Ответ на: комментарий от stormblastt

печально. но я надеялся, что за год всё таки что-нибудь изменилось

Last Update: 2013-06-28

prozaik ()
Ответ на: комментарий от Qwentor

О, какой старый тред.

В общем, за прошедшее время pip умудрились изменить так, что теперь mysql-connector вот так легко не поставить. Тут варианты:

  • поставить mysql-connector-python-rf (через pip)
  • скачать официальный mysql-connector (с гитхаба или в виде архива с их сайта) и в директории сделать python setup.py install.
  • попробовать некий mysqlclient
  • ещё что-нибудь

Я давно с мускулем из питона не работал, так что не знаю, какой вариант лучше, и что ещё есть (пишут, что pymysql должен таки работать). Но перечисленное сейчас в virtualenv-е сделал - вроде бы всё поставилось и импортируется без ошибок, проверял на python 3.5.

risenshnobel ★★★ ()
Ответ на: комментарий от risenshnobel

Решил проблему установкой 3.4 питона из исходников и установкой pymysql

Qwentor ★★★★★ ()
Вы не можете добавлять комментарии в эту тему. Тема перемещена в архив.