LINUX.ORG.RU

Python 3.5+ на Ubuntu 10.04 32bit

 , ,


0

1

Ubuntu 10.04 LTS 32bit! Нужен Python 3.5+ версии.

Пробую собрать из исходников:

sudo apt-get install build-essential libncursesw5-dev libreadline5-dev \
libssl-dev libgdbm-dev libbz2-dev libc6-dev libsqlite3-dev tk-dev g++ gcc

wget https://www.python.org/ftp/python/3.5.7/Python-3.5.7.tgz
tar xvzf Python-3.5.7.tgz
cd Python-3.5.7/
./configure
make
sudo make install

Оно ругается:

ModuleNotFoundError: No module named '_ctypes'
Шо ему надо? Есть вариант завести? Желательно Python 3.7.3, конечно. :)

Так! А главный виновник - SSL? Каких SSL'ей ему надо? Как варили SSL в 2010 году?

The following modules found by detect_modules() in setup.py, have been
built by the Makefile instead, as configured by the Setup files:
_abc                  atexit                pwd                
time                                                           


Failed to build these modules:
_ctypes                                                        


Could not build the ssl module!
Python requires an OpenSSL 1.0.2 or 1.1 compatible libssl with X509_VERIFY_PARAM_set1_host().
LibreSSL 2.6.4 and earlier do not provide the necessary APIs, https://github.com/libressl-portable/portable/issues/381

Ballu16 ()
Ответ на: комментарий от darkenshvein

Добавил

deb http://mirror.yandex.ru/debian/ testing contrib non-free main
В
/etc/apt/sources.list
Потом добавил
APT::Cache-Limit "100000000";
В
/etc/apt/apt.conf.d/70debconf
Иначе ругалось на маленький APT::Cache-Limit.

Но с чего мы решили, что оно всанет само?

Ballu16@vr10:/etc/apt$ sudo apt-get install python3.7
Чтение списков пакетов... Готово
Построение дерева зависимостей       
Чтение информации о состоянии... Готово
Некоторые пакеты невозможно установить. Возможно, вы просите невозможного,
или же используете нестабильную версию дистрибутива, где запрошенные вами
пакеты ещё не созданы или были удалены из Incoming.
Следующая информация, возможно, поможет вам:

Пакеты, имеющие неудовлетворённые зависимости:
  python3.7: Зависит: python3.7-minimal (= 3.7.3-2) но он не будет установлен
             Зависит: libpython3.7-stdlib (= 3.7.3-2) но он не будет установлен
E: Сломанные пакеты

Нравится фраза «Возможно, вы просите невозможного»

Ballu16 ()
Ответ на: комментарий от eternal_sorrow

Смысл этих манипуляций прост. Есть древний ноутбук 2005 года с 32bit CPU. На нём заводится Lubuntu 19.10 с lxqt, но... под современными ОС он греется и быстро разряжается. На Ubuntu 8.04 отлично работает. На 10.04 тоже около дела. Никакого смысла во всем этом нет. Баловство. Второй нормальный ноутбук у меня есть, но хочется некрофилии.

Ballu16 ()
Ответ на: комментарий от Ballu16

Попробуй скачать DEB-SRC пакет с OpenSSL 1.0.2 и пересобрать. Тебе рассказать как собирать DEB-SRC пакеты? Я на ЛОРе много раз про это писал, но могу ещё раз написать

ZenitharChampion ★★★★★ ()
Последнее исправление: ZenitharChampion (всего исправлений: 1)
Ответ на: комментарий от I-Love-Microsoft

Anaconda - как я понял, альтернативный дистрибутив Python. На Ubuntu 10.04 32bit завелось - есть Python 3.7. Но никакие Anaconda-штуки с GUI (spyder, anaconda-navigator) не стартуют из-за:

ModuleNotFoundError: No module named 'PyQt5.QtWebKitWidgets'
или
This application failed to start because it could not find or load the Qt platform plugin "xcb"
in "".
Это уже совсем другая история...

Anaconda Distribution Python old package list https://repo.anaconda.com/archive/

Текущая 32bit c Python 3.7 https://repo.anaconda.com/archive/Anaconda3-2018.12-Linux-x86.sh

Есть даже специальный JetBrains PyCharm для Anaconda, но ему нужна актуальная Java https://www.anaconda.com/pycharm.

Ballu16 ()
Ответ на: комментарий от Ballu16

под современными ОС он греется и быстро разряжается

На ноутбуке 2005го года батарея давным давно пришла в негодность и работать он может только от сети. Так что чего-то ты нам не договариваешь. Опять же, что там, какой-нибудь Pentium M на 1.5-2 гигагерца и полгига памяти, запускать там софт на третьем питоне — та ещё боль.

gremlin_the_red ()
Ответ на: комментарий от gremlin_the_red

На ноутбуке 2005го года батарея давным давно пришла в негодность и работать он может только от сети.

Я не хочу тебя расстраивать, мой недалёкий друг, но батарею у ноутбука можно и поменять.

hateyoufeel ★★★★★ ()

Для Ubuntu 14+ есть репозиторий deadsnakes

sudo apt update && \
sudo apt install software-properties-common && \
sudo add-apt-repository ppa:deadsnakes/ppa && \
sudo apt update && \
sudo apt install python3.7
anonymous ()