LINUX.ORG.RU

python2.6 - ошибка при сборке


0

0

Debian-stable lenny

Собираю сабж по этому мануалу:
http://weblog.patrice.ch/2009/01/14/install-python-2-6-on-debian-etch.html

В debian/control в первой части - автор мануала предложил две секции Build-Depends, на что ругается сборщик. Как объединить в одну, чтобы не напортачить? Там разные версии деб-хелпера упомянуты. (А в том конфиге, что у меня получился - вообще было >=7).
К томуже, там hurd упомянут зачем-то. Может выкинуть лишнее?
Помогите, пж, разобраться. Первый раз за это дело взялся.

Source: python2.6
Section: python
Priority: extra
Maintainer: Patrice Neff
Build-Depends: debhelper (>= 5), autotools-dev
Standards-Version: 3.7.2
Build-Depends: debhelper (>= 4.2), autoconf, libreadline5-dev, libncursesw5-dev (>= 5.3), tk8.4-dev, libdb4.4-dev, zlib1g-dev, libgdbm-dev, blt-dev (>= 2.4z), libssl-dev, sharutils, libbz2-dev, libbluetooth2-dev [!hurd-i386 !kfreebsd-i386 !kfreebsd-amd64], locales, libsqlite3-dev, libffi4-dev (>= 4.1.0), mime-support, libgpmg1 [!hurd-i386 !kfreebsd-i386 !kfreebsd-amd64], netbase, lsb-release, bzip2, libffi4-dev (>= 4.1.1-11) [m68k], binutils (>= 2.17-2+b2) [m68k]
Build-Depends-Indep: libhtml-tree-perl, tetex-bin, tetex-extra, texinfo, emacs21, debiandoc-sgml, sharutils

★★

Ответ на: комментарий от nnz

Дык я народ черным по белому спрашивал, как лучше (я этот вариант с экспериментальной сборкой тоже рассматривал, даже скачал). Однако посоветовали собирать ручками, вот я и попробовал.

Да, спасибо за ссылку на мануал!

Надо сказать, что объединение Build-Depends: в один раздел помогло (вписал младшую версию deb-helper), но все заткнулось в конце компиляции с ошибкой 1. Дело, видимо, в том, что я выкинул из зависимостей 4 библиотеки, которые не нашлись у меня в репах (а искать и качать вручную было лень). Удивительно - зачем там столько запихано? Архивов на 300 метров с хвостиком скачалось. Какие-то языковые пакеты для текса... для емакса чего-то. Ужос, кактус.

frpaul ★★ ()
Ответ на: комментарий от frpaul

>Дык я народ черным по белому спрашивал, как лучше

Дык меня там не было :)

Имхо у тебя в любом случае сборка получится по качеству ненамного лучше экспериментальной (созданной профессиональными мейнтейнерами).

nnz ★★★★ ()
Ответ на: комментарий от nnz

Вы правы. Но экспериментальная сборка тянет за собой еще штук пять пакетов, которых нету в стейбле. Проще уж включить экспериментальные репы. Нашел выход в том, что обновил tk до версии 8.5. Добился, чего хотел (морда моей программы до этого криво рисовалась и шрифты тоже). Ну а в Сквизи, наверное, уже добавят питончик 2.6.

В любом случае, спасибо за помощь!

frpaul ★★ ()
Вы не можете добавлять комментарии в эту тему. Тема перемещена в архив.