LINUX.ORG.RU

Не компилит код в Code::blocks в gentoo

 ,


0

1

запуская код в code::blocks на gentoo 4.9.95

#include <iostream>
using namespace std;
int main()
{
    cout << "Hello world!" << endl;
    return 0;
} 
выводит
-------------- Build: Debug in test (compiler: GNU GCC Compiler)---------------
g++ -Wall -fexceptions -g  -c /home/tujh/Desktop/test/main.cpp -o obj/Debug/main.o
g++  -o bin/Debug/test obj/Debug/main.o   
Output file is bin/Debug/test with size 27.85 KB
Process terminated with status 0 (0 minute(s), 0 second(s))
0 error(s), 0 warning(s) (0 minute(s), 0 second(s))
-------------- Run: Debug in test (compiler: GNU GCC Compiler)---------------
Checking for existence: /home/tujh/Desktop/test/bin/Debug/test
Executing: gnome-terminal -t test -x  /usr/bin/cb_console_runner LD_LIBRARY_PATH=$LD_LIBRARY_PATH:. /home/tujh/Desktop/test/bin/Debug/test  (in /home/tujh/Desktop/test/.)
Process terminated with status -1 (0 minute(s), 0 second(s)) 
Как видно, компилятор стоит gcc. Помню в арче была такая же проблема, решилась она установкой build-essential. Что мне нужно сделать? xterm есть З.Ы Компилить в терминале не предлагать


Ты хоть проверь, файлы-то появляются? И да, скомпиль в консоли: если и там проблема проявится, значит, дело в системе, если нет — в IDE

XMs ★★★★★ ()

всё он тебе скомпилил, о чём написал вполне внятно. затем он пытается запускать гномотерминал, которого, очевидно, на твоей генте нет, и обламывается. ты, очевидно, нажимал не сборку, а сборку и запуск. так пропиши ему в настройках (в General Settings) нужный терминал, если хочешь сразу запускать.

P.S. зачем люди ставят генту, если даже элементарный выхлоп в лог прочитать не могут?

Iron_Bug ★★★★ ()
Последнее исправление: Iron_Bug (всего исправлений: 2)
Ответ на: комментарий от Iron_Bug

гномотерминал у меня есть, и xterm я пробовал, менял я как раз в general settings,

tujh ()
Ответ на: комментарий от tujh

Значит, всё компилируется. Выполни команду, которую он пишет в конце:

gnome-terminal -t test -x  /usr/bin/cb_console_runner LD_LIBRARY_PATH=$LD_LIBRARY_PATH:. /home/tujh/Desktop/test/bin/Debug/test
в каталоге /home/tujh/Desktop/test/

XMs ★★★★★ ()
Ответ на: комментарий от XMs

Blyad'. Извините, ребят. Вопрос решен. Самолично ставил gnome-terminal и установил его в качестве терминала для запуска консольных приложений в codeblocks'e. В итоге перебрал все, что есть, заработал только terminator(видимо изза того что я его использую или хй знает изза чего). В общем все работает.

tujh ()
Ответ на: комментарий от Iron_Bug

самое странное, что по умолчанию, насколько помню, там xterm стоит в настройках. То есть, он сам такую настройку выставил.

grem ★★★★★ ()
Ответ на: комментарий от grem

ну, есть многое на свете, друг Горацио. бывает, что в каких-нибудь дистрах проставляют какие-то свои настройки. мало ли. но в оргинальных сорцах - да, xterm.

Iron_Bug ★★★★ ()
Вы не можете добавлять комментарии в эту тему. Тема перемещена в архив.