LINUX.ORG.RU

Не стартуют Х после обновления archlinux

 , , ,


2

2

Обновил cвой archlinux после примерно месяца без обновления. После перезагрузки перестал запускаться GDM. В таких случаях обычно запускался xfce4, но сейчас даже он не стартует. Поставил lxde, однако startlxde ничего не возвращает, команда выполнилась и всё. X :0 показывает чёрный экран.

Xorg.0.log: http://pastebin.com/EMtgmZkW

gdm/:0.log: http://pastebin.com/rQvqzFif

Помогите, пожалуйста, очень нужна рабочая система...

Ответ на: комментарий от tazhate

Да, только там и работают. Правда клавиатура перестала там корректно работать.

vitali ()

Ахах, у меня тоже самое, ну практически. LightDM блинкает. GDM виснет. KDM запускается. startx ручками работает, но при этом gnome-session нет.

А все собственно говоря почему, не знаю верно ли, но кажется из-за Cinnamon пакетов, которые в community. Причем после апдейта на Gnome 3.8, потому что когда я снес cinnamon-control-center, LightDM стал запускаться, но потом поставил nemo и он снова перестал. Теперь все снес, но все равно не запускается. И подобные выкрутасы не впервые, поэтому свалил на Fedora :D

dearboy ()

Кстати да, присоединяюсь. Поставил опенбокс+тинт2+слим. Решил доустановить archey и feh. Он мне сказал типа нельзя это сделать. Я обновил репозитории, после чего он без вопросов поставил мне что надо. Но стал виснуть. Тинт2 не запускается при старте опенбокса, меню показыват, но программы оттуда тоже не запускаются. Какое-то киллер-обновление наверное было. Работать можно только в tty.

cinyflo ★★★★★ ()
Последнее исправление: cinyflo (всего исправлений: 2)

Enjoy your Arsch Arch.

anonymous ()

терпилы знали же чем пользуетесь

а у меня убунту глючит после того как удалил не сколько пакетов так что плюнул и вернулся на win 8

anonymous ()

Лог последнего обновления можешь привести? Я пока отложил обновление, увидев мажорный апдейт libpng и УМВР. Может у тебя что-то из АУР-а на него завязано, тогда могут быть самые разные глюки. Обычно все забывают пересобрать cairo.

ATIpro ★★ ()
Ответ на: комментарий от ATIpro

Я откатывал mesa, mesa-libgl, cairomm, libpng - безрезультатно...

toney ★★★★★ ()

А у меня просто через раз вываливется gdm c ошибкой, при этом клавиатура странно себя ведет(не хочет переключать терминалы), потом зам же перезапускается и все ок.

ЗЫ:а еще в скайпе невозможно писать, после n предложений отваливается клавиатура, печатает что ей вздумается и т.д.

Linuxman ()
Ответ на: комментарий от toney

Я откатывал mesa, mesa-libgl, cairomm, libpng - безрезультатно...

Проблем с пакетами из официального репозитория быть не должно, там уже все пересобрали. Нужно внимательно на пакеты из АУР-а смотреть. Да и откатывать нужно явно больше пакетов. Мне сейчас предлагается такой список обновления, абсолютное большинство из которых просто пересобрано из-за нового libpng:

==> Package upgrade only (new release):
extra/alsa-lib                  1.0.27-1   1 -> 2
extra/avahi                     0.6.31-6   6 -> 7
extra/cairo                     1.12.14-3  3 -> 4
extra/cairomm                   1.10.0-2   2 -> 3
extra/firefox                   20.0.1-2   2 -> 5
extra/gdk-pixbuf2               2.28.1-1   1 -> 2
extra/gegl                      0.2.0-7    7 -> 8
extra/ghostscript               9.07-1     1 -> 2
extra/libwmf                    0.2.8.4-9  9 -> 10
extra/librsvg                   2.37.0-1   1 -> 2
extra/gimp                      2.8.4-1    1 -> 2
extra/gnome-icon-theme-symbolic 3.8.0.1-1  1 -> 2
extra/gstreamer0.10-bad         0.10.23-3  3 -> 4
extra/mjpegtools                2.0.0-2    2 -> 3
extra/gstreamer0.10-bad-plugins 0.10.23-3  3 -> 4
extra/gstreamer0.10-good        0.10.31-1  1 -> 3
extra/imlib2                    1.4.5-2    2 -> 4
extra/poppler                   0.22.3-2   2 -> 3
extra/libreoffice-common        4.0.2-3    3 -> 4
extra/libreoffice-calc          4.0.2-3    3 -> 4
extra/libreoffice-gnome         4.0.2-3    3 -> 4
extra/libreoffice-math          4.0.2-3    3 -> 4
extra/libreoffice-writer        4.0.2-3    3 -> 4
extra/poppler-glib              0.22.3-2   2 -> 3
extra/qt4                       4.8.4-16   16 -> 17
extra/slim                      1.3.5-2    2 -> 3
community/mplayer-vaapi         35107-5    5 -> 6
community/virtualbox            4.2.12-1   1 -> 2

==> Software upgrade (new version) :
core/iproute2                   3.8.0-1    -> 3.9.0-1
core/mkinitcpio                 0.13.0-1   -> 0.14.0-1
extra/libpng                    1.5.15-1   -> 1.6.2-3
extra/imagemagick               6.8.4.10-1 -> 6.8.5.3-1

ATIpro ★★ ()
Ответ на: комментарий от ATIpro

Да, я вчера утром большинство из этих пакетов обновил, после чего перестали взлетать Х-ы, либо XFCE падает, glib?

toney ★★★★★ ()
Ответ на: комментарий от toney

Да, я вчера утром большинство из этих пакетов обновил, после чего перестали взлетать Х-ы, либо XFCE падает, glib?

Покажи вывод pacman -Qm. Ну и проверь свое зеркало, может оно тупит.

ATIpro ★★ ()

Дебиан слоупочный, надо bleeding edge, ко-ко-ко.

anonymous ()

Зеркало какое?

Еще раз обновиться пробовал?

На новом пользователе проверял?

vadik ★★ ()
Ответ на: комментарий от toney

Xorg.0.log

Ты пытался грузиться с vesa? Если с ним будет работать, то проблема с дровами via и тут я точно ничем помочь не смогу. Если и с ним не работает, то возвращаемся к апдейту libpng и пакетам из АУР-а. У тебя точно не используется что-нибудь типа cairo-ubuntu или cairo-cleartype?

ATIpro ★★ ()
Ответ на: комментарий от ATIpro

Ты пытался грузиться с vesa?

Yep! Does not work - shouts at DRI

У тебя точно не используется что-нибудь типа cairo-ubuntu или cairo-cleartype?

No, I do not use AUR for system. Only for games.

toney ★★★★★ ()
Ответ на: комментарий от toney

Yep! Does not work - shouts at DRI

Можешь выложить лог пакмана с тех времен, когда все точно работало нормально?

Ну и смотри не только xorg.conf, но и в journalctl, может там есть что-то более разумное.

ATIpro ★★ ()

Мне помогло следующее: удалил GDM, Gnome, xfce, переустановил yaourt (я его удалял незадолго до обновления из-за конфликтов) пересобрал cairo-ubuntu, после этого поставил xfce снова. И тот запустился. Ура. Gnome не ставил, не проверял.

Возможно, достаточно было просто пересобрать cairo-ubuntu.

Спасибо за подсказки!

vitali ()
Ответ на: комментарий от vitali

пересобрал cairo-ubuntu

Вот оно! Благодарю! У меня каким-то боком эта гадость подтянулась из AUR (вероятно вместе с какой-то игрушкой)... Удалил к чертям и поставил нормальное cairo - Х-ы взлетели! Как всё неочевидно было...

toney ★★★★★ ()
Ответ на: комментарий от toney

Как всё неочевидно было...

Обычно все забывают пересобрать cairo.
Нужно внимательно на пакеты из АУР-а смотреть.
Покажи вывод pacman -Qm.
Если и с ним не работает, то возвращаемся к апдейту libpng и пакетам из АУР-а. У тебя точно не используется что-нибудь типа cairo-ubuntu или cairo-cleartype?

facepalm

ATIpro ★★ ()
Последнее исправление: ATIpro (всего исправлений: 1)
Ответ на: комментарий от ATIpro

Да я всё на последнее обновление грешил, а cairo-ubuntu вообще уже не помню. как попало в систему. Такая вот фигня.

toney ★★★★★ ()
Вы не можете добавлять комментарии в эту тему. Тема перемещена в архив.