LINUX.ORG.RU

Debian проблема c apt (linux-headers)


0

0

Проблема такая:
пробую установить linux-haders:
apt-get update apt-get install linux-headers-$(uname -r)
Он мне пишет:

Пакеты, имеющие неудовлетворённые зависимости:
 linux-headers-2.6.32-5-686 : Зависит: gcc-4.3 но он не будет установлен
E: Сломанные пакеты
Далее смотрю dpkg -l | grep gcc
И убеждаюсь что ни одна версия gcc не установлена, а есть только gcc-версия-base, командую gcc а он мне пишет нет такой команды.

Далее пытаюсь установить gcc-4.3: apt-get install gcc-4.3

Пакеты, имеющие неудовлетворённые зависимости:
 gcc-4.3 : Зависит: cpp-4.3 (= 4.3.5-4) но он не будет установлен
           Зависит: binutils (>= 2.19.1) но он не будет установлен
           Зависит: libgcc1 (>= 1:4.3.5-4) но он не будет установлен
           Зависит: libgomp1 (>= 4.3.5-4) но он не будет установлен
           Зависит: libc6 (>= 2.11) но он не будет установлен
           Рекомендует: libc6-dev (>= 2.5) но он не будет установлен
E: Сломанные пакеты
Теперь становится интересно:
# dpkg -l | grep cpp-4.3
ii  cpp-4.3                              4.3.5-4                        The GNU C preprocessor
# dpkg -l | grep binutils
ii  binutils                             2.20.1-16                      The GNU assembler, linker and binary utilities
и так далее...
 libgcc1 1:4.7.2-5
 libgomp1 4.4.5-8
 libc6   2.13-37
Все пакеты подоходят, у всех статус ii, в чем может быть проблема ?

P.S. sources.list - http://pastebin.com/XmnBTS0P Для некоторых пакетов мне требовались пакеты из testing и unstable.


А просто если сделать? :)

apt-get update && apt-get install build-essential -y

tazhate ★★★★★ ()
Ответ на: комментарий от tazhate
#  apt-get install build-essential
...
...
build-essential : Зависит: libc6-dev но он не будет установлен или
                                   libc-dev
                   Зависит: gcc (>= 4:4.4.3) но он не будет установлен
                   Зависит: g++ (>= 4:4.4.3) но он не будет установлен
                   Зависит: dpkg-dev (>= 1.13.5) но он не будет установлен
 libgcc1 : Ломает: gcc-4.3 (< 4.3.6-1) но 4.3.5-4 будет установлен
 libstdc++6 : Ломает: gcc-4.3 (< 4.3.6-1) но 4.3.5-4 будет установлен
E: Неудовлетворённые зависимости. Попытайтесь выполнить 'apt-get -f install', не указывая имени пакета, (или найдите другое решение).
demsi ()
Ответ на: комментарий от leonidko

на команду от root apt-get -f install что отвечает?

root@PK-Note:~# apt-get -f install
Чтение списков пакетов... Готово
Построение дерева зависимостей       
Чтение информации о состоянии... Готово
обновлено 0, установлено 0 новых пакетов, для удаления отмечено 0 пакетов, и 0 пакетов не обновлено.
demsi ()
Ответ на: комментарий от demsi

У меня есть смутное сомнение что мне придется переустанавливать/ удалять пакеты:
gcc-4.4-base
gcc-4.7-base
если командую apt-get remove gcc-4.4-base
То он предлагает удалить среду рабочего стола, иксы, и так далее.

apt-get remove gcc-4.7-base
Вообще все предлагает удалить (пакетов на гиг), и даже сам apt.

demsi ()
Ответ на: комментарий от tazhate

покажи содержимое /etc/apt/sources.list

В первом посте в самом конце. P.S. смотрите. Там ссылка

demsi ()
Ответ на: комментарий от tazhate

Может ядро обнови? В сквизе не 32, емнип.

Я систему недавно поставил. И пологаю что ядро новое.

Что такое емнип ?

demsi ()
Ответ на: комментарий от blokant

http://packages.debian.org/ru/squeeze/linux-source-2.6.32 http://www.debian.org/News/2011/20110205a

root@PK-Note:~# apt-cache search linux-source
linux-patch-debian-2.6.32 - Debian patches to version 2.6.32 of the Linux kernel
linux-source-2.6.32 - Linux kernel source for version 2.6.32 with Debian patches
linux-source-2.6 - Linux kernel source for Linux 2.6 (meta-package)

root@PK-Note:~# apt-cache policy linux-source-2.6.32
linux-source-2.6.32:
  Установлен: (отсутствует)
  Кандидат:   2.6.32-46
...

root@PK-Note:~# apt-get install linux-source-2.6.32
Установилось все норм.

root@PK-Note:~# apt-get install gcc-4.3
...
Пакеты, имеющие неудовлетворённые зависимости:
 gcc-4.3 : Зависит: cpp-4.3 (= 4.3.5-4) но он не будет установлен
           Зависит: binutils (>= 2.19.1) но он не будет установлен
           Зависит: libgcc1 (>= 1:4.3.5-4) но он не будет установлен
           Зависит: libgomp1 (>= 4.3.5-4) но он не будет установлен
           Зависит: libc6 (>= 2.11) но он не будет установлен
           Рекомендует: libc6-dev (>= 2.5) но он не будет установлен
E: Сломанные пакеты
demsi ()
Ответ на: комментарий от leonidko

Было. apt-get --reinstall install gcc-4.{4,7}-base

apt-get --reinstall install gcc-4.7-base
...
Переустановка gcc-4.7-base невозможна, он не скачивается.
...
demsi ()
Ответ на: комментарий от blokant

полный выхлоп покажи

Проблему с gcc-4.7 решил, он не скачивался, так как я в sources.list за коментил wheezy. gcc имеется и работает.
Но основная проблема остается:

root@PK-Note:~# apt-get install linux-headers-$(uname -r)
Чтение списков пакетов... Готово
Построение дерева зависимостей       
Чтение информации о состоянии... Готово
Некоторые пакеты невозможно установить. Возможно, вы просите невозможного,
или же используете нестабильную версию дистрибутива, где запрошенные вами
пакеты ещё не созданы или были удалены из Incoming.
Следующая информация, возможно, поможет вам:

Пакеты, имеющие неудовлетворённые зависимости:
 linux-headers-2.6.32-5-686 : Зависит: gcc-4.3 но он не будет установлен
E: Сломанные пакеты

root@PK-Note:~# apt-get install gcc-4.3
Чтение списков пакетов... Готово
Построение дерева зависимостей       
Чтение информации о состоянии... Готово
Некоторые пакеты невозможно установить. Возможно, вы просите невозможного,
или же используете нестабильную версию дистрибутива, где запрошенные вами
пакеты ещё не созданы или были удалены из Incoming.
Следующая информация, возможно, поможет вам:

Пакеты, имеющие неудовлетворённые зависимости:
 gcc-4.3 : Зависит: cpp-4.3 (= 4.3.5-4) но он не будет установлен
           Зависит: binutils (>= 2.19.1) но он не будет установлен
           Зависит: libgcc1 (>= 1:4.3.5-4) но он не будет установлен
           Зависит: libgomp1 (>= 4.3.5-4) но он не будет установлен
           Зависит: libc6 (>= 2.11) но он не будет установлен
           Рекомендует: libc6-dev (>= 2.5) но он не будет установлен
E: Сломанные пакеты

demsi ()

ССЗБ. Сперва сделал кашу из стейбла, тестинга и сида, а потом новые ветки закомментировал.

Excavator ()
Ответ на: комментарий от demsi

Я если честно не совсем понимаю, разве gcc-4.7 не совместим с gcc-4.3?
То есть по идее то что компилится на gcc-4.3 должно компилится и на gcc-4.7?
Нафига ему вообще 4.3 сдался ?

demsi ()
Ответ на: комментарий от Excavator

ССЗБ. Сперва сделал кашу из стейбла, тестинга и сида, а потом новые ветки закомментировал.

Согласен, с вами .
Это все из за моей не опытности. Сначало все было норм, но когда мне понадобилось, установить некоторые программы, которые требовали библиотеки более новых версий, пришлось включать testing и unstable. И с тех пор проблем не оберешься. Установилось несколько версий gcc. Много версий разных библиотек и так далее.

demsi ()
Ответ на: комментарий от blokant

несколько версий gcc я бы собиралв в виртуалке.

Да я же не совсем по своей воле.
Видимо что то понадобилось мне установить. Я скачал deb пакет. Кинул его в root/debs, dpkg-scanpackages и так далее.
apt-get install этот пакет -y
У него в зависимостях gcc-4.7 и пошло поехало...
Может дадите советы, как лучше поступать в таких случаях ?

demsi ()
Ответ на: комментарий от demsi

1. Не делай мешанину из релизов, только stable 2. Ставь только из репозитория. 3. Если что - то может загадить систему - отправляешь в виртуалку

blokant ★★ ()
Ответ на: комментарий от demsi

Тебе получается надо откатиться/обновиться на какую-нибудь определённую ветку. Current stable | testing. А потом в виртуалке/чруте колбаситься по чёрному с фаршем из всего подряд.

leonidko ★★★ ()
Ответ на: комментарий от demsi

Почитай лучше про бэкпорты и больше так не делай.

Deleted ()

GCC 4.3 слишком старый набор. Программы в Debian, скорее всего, собраны GCC 4.4 и более старших версий, поэтому пакет GCC 4.3 сломан намеренно, чтобы не ломать рантайм пользователям.

iZEN ★★★★★ ()
Ответ на: комментарий от demsi

если командую apt-get remove gcc-4.4-base
То он предлагает удалить среду рабочего стола, иксы, и так далее.

apt-get remove gcc-4.7-base
Вообще все предлагает удалить (пакетов на гиг), и даже сам apt.

Чтобы избавиться от этих двух компиляторов, библиотеки рантайма которых в зависимостях у установленных программ, то нужно установить GCC 4.6.x, библиотеки рантайма которого возьмут на себя все их зависимые программы. А GCC 4.4 и 4.7 после этого уже можно удалять.

iZEN ★★★★★ ()
Последнее исправление: iZEN (всего исправлений: 1)
Ответ на: комментарий от Deleted

Почитай лучше про бэкпорты и больше так не делай.

Интересно, про это не знал, суди по описанию:

Backports создан специально для решения подобных задач, новые пакеты при установке не тянут за собой библиотеки из не стабильного Debian и не создают проблем с зависимостями, софт собран специально под текущую стабильную ветку Debian, это очень удобно не правда ли?

Если это описание верно, то это как раз то что нужно.
Спасибо за совет

demsi ()
Ответ на: комментарий от demsi

Для этого и создан. Естественно, что там есть не всё, но тем не менее.

Deleted ()

На десктоп уже смело можно ставить Wheezy.

ololoid ★★★ ()
Ответ на: комментарий от ololoid

Тестинг в заморозке хуже анстейбла, так что не стоит...

kma21 ★★★★ ()
Ответ на: комментарий от leave

В таком, что не раз сталкивался с определёнными проблемами. Иногда убирается пакет из репов (потом конечно добавляется, но нужен сейчас, а не потом). Так было с каким-то system-settings (для KDE настройка gtk). Могут быть какие-то заскарузлые баги, которые упорно не правятся. И если в unstable прилетает новый софт, то здесь остаётся бажный софт и приходится ждать, пока мейнтейнеры Debian отрегаируют на багзиллу.

Поэтому я предпочитаю или stable или unstable. Хотя сейчас десктопы на Ubuntu.

kma21 ★★★★ ()
Ответ на: комментарий от kma21

ну не обновляйся, если нужный тебе пакет убирается. Опять же, при safe-upgrade такого не случается.

leave ★★★★★ ()
Ответ на: комментарий от leave

Дык в том и дело, что поставил я Testing. А нужного мне пакета нет на данный момент. Есть в stable, есть в unstable, а в testing нет.

И вообще, «не обновляться» это костыль, не должна нормальная ОС так работать.

kma21 ★★★★ ()
Ответ на: комментарий от kma21

Дык в том и дело, что поставил я Testing. А нужного мне пакета нет на данный момент. Есть в stable, есть в unstable, а в testing нет.

если тебе _так_ не повезло - чисти карму ;)

Обновляться можно, не нужно делать full-upgrade, не читая вывод апта.

leave ★★★★★ ()
Ответ на: комментарий от leave

Я лучше буду юзать или stable или unstable =)

Дык никто и не говорил, что нужно отключать мозг. Всегда надо думать, прежде чем что-то делать, не обязательно обновляться.

kma21 ★★★★ ()
Вы не можете добавлять комментарии в эту тему. Тема перемещена в архив.